Question about 2006 Mitsubishi Eclipse

1 Answer

Was listening to radio then all power shut down,tried starting it it wouldn't start I finally got it to start but now my service engine soon light is on

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 137 Answers

Replace the fuel filter first.

Posted on Aug 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1994 jeep grand cherokee manufactured in October 1993. The problem I'm having is that the jeep wont start. At first we had no gas, no spark. We checked crankshaft sensor...it's ok, but...


Try this. Lock and unlock the tail gate with the key and see if it will start. The battery must be hooked uo when this procedure is followed. Whenever the battery is disconnected, the security circuit shuts the ignition down.
When you hook up any battery, make certain that you connect the positive battery cable first and negatvie (ground) second.

May 16, 2011 | Jeep Grand Cherokee Cars & Trucks

1 Answer

Service engine soon light on 1998 buick regal gs


It is most likely a crank sensor!!!!!!! i am 99.9999% positive that this is the culprit. I am a mechanic and this is the first thing i would check with your description.

Mar 06, 2010 | 1998 Buick Regal

1 Answer

99 buick regal 3.8 starts for 3 seconds and shuts down,


Had the same problem drove me nuts until I tried disconnecting Mass Air Flow Sensor, the car should drive normally but with a "Service Engine Soon Light" on. Mass air flow can run from $140 up, picked one up at recycler for $40.

Worth a try.

Mar 01, 2009 | 1999 Buick Regal

1 Answer

Hi please help i have a peugeot 406 hdi i have had nothing but problems with the fuel system first i changed the bosch pump in the tank i then changed the high pressure pump and the car run lovely for one...


Try this but the fault I have is intermittent so may take a bit to work out - switch off everything in the car so there is no noise. Turn on ingnition (do not start) and listen for the sound of of the fuel pump below the rear seat - behind the drivers seat. The pump should run for about 5 - 10 sec then shut off, it may work but if you cannot hear it it may be an ECU issue. If it does run start the car and drive it until it stops again, switch the ignition on/off and listen for the pump running. if you can confirm that the pump is running intermittently you have the same ECU problem I have. The official solution is to replace the ECU - ££££££. The low cost alternate is to run a wire from the ingnition controlled feed at rear of the radio and connect to the pump feed at the fuel tank, ensure a correct rated fuse is installed somewhere along the wire. There is a least one issue with this - if the ignition is on the pump is running, so not a good idea to sit with the key turned to listen to the radio.

Feb 19, 2009 | 2005 Peugeot 405

1 Answer

Battery not charging in Mazda Millenia year 2000


Sounds like a similar problem I had. I had a bad battery. Jumping the car and charger did not help. All instruments work as I am guessing the battery had enough juice to light those but not enough to start car. Either bad battery or alternator. I changed out the battery and everything was fine. If you have an aftermarket stereo or amp, make sure they are setup right. The amp may be drawing power even if radio and car is off which may attribute to low start power (including above suggestions).

Jul 20, 2008 | 2000 Mazda Millenia

1 Answer

Won't Start/Then Starts Badly


maybe you need a battery or aternator

Jul 12, 2008 | 2002 Kia Spectra

Not finding what you are looking for?
2006 Mitsubishi Eclipse Logo

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...