Question about Chevrolet Cavalier

1 Answer

Ok so, I have a 2005 Chevrolet Cavalier 4D. Its got about 135k miles on it. Just paid it off this year. I moved my car from one parking spot to another that was on a downhill slope, the nose of the car facing downhill. When I went to start it up again it wouldn't start. The engine would begin to turn over but it wouldn't ignite. At first I thought it was a battery problem. Its not a battery problem because it has charge and it does try to ignite. I had a friend who is a mechanic come take a look at it, we decided to replace the ignition control module on the car to see if that would work, it didn't. We replaced the spark plugs with brand new ones. It didn't work. We got a new crank position sensor on there, no go. The spark plugs work, we have seen them work. There is gas thats being distributed in where the spark plugs are. The two are just not doing what they're supposed to though. We took a look at the fuses and they're all ok as well. I had a friend said it could be the timing belt, but it doesn't sound like it. I saw it could be the mass airflow sensor. My friend who has a car computer got in and saw that everything is working just fine. Any clues as to what I can do or get before taking it to a mechanic to spend tons of money on it?

Posted by on

  • 1 more comment 
  • Pedro Cabrera Aug 28, 2010

    55psi. Unplugging that and checking for damage or wear and tear?

    Sorry, I just looked up some other things online about the MAF. My friend told me later that this car didn't have that.

  • wmstalk Aug 28, 2010

    Try starting the car withthe MAP sensor unplugged, also have you tried starting while holding the gas pedal to the floor?

  • Pedro Cabrera Aug 31, 2010

    I've tried to start it with the gas pedal down. I'll try with the MAP sensor unplugged soon. I'll let you know the results.

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Champion:

    An expert who has answered 200 questions.

  • Contributor
  • 264 Answers

HI. it sounds as if you have no fuel pressure have you checked? Most likely what happen when you parked the car on the slope there was not enough fuel in the tank to keep the fuel pump cavity filled with enough fuel. Then when you tried to start the car the fuel pumps vanes broke away.

Posted on Aug 28, 2010

  • Pedro Cabrera Aug 28, 2010

    My friend has a pressure gauge and we did have sufficient fuel pressure. There was at least a quarter tank, maybe a bit less.

  • wmstalk Aug 28, 2010

    Sorry that was the one thing you left out. You were so good at listing the rest I thouhgt it was over looked. Do you rember just what the fuel presure was and did he take a volume test? Try un-pluging the MAP sensor (manifold asolute pressure) you can reach the connector for it from the top of the manifold just a tight fit. You listed you had checked the data for the MAF sensor (mass airflow sensor) ? This Gm 2.2 does not use that sensor.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car wont switch gears!!!


Call 6ya. Experts who can help 24/7 and actually work in the field. I'm on all evening for support and the service is totally free.

May 25, 2017 | 2005 Chevrolet Cavalier

2 Answers

Does a 2003 cavalier have timing belt or chain?


Most overhead valve engines have a belt. You need to get your engine size, make, model and year and call your local parts house and they can tell you this for sure.

Feb 06, 2011 | 2003 Chevrolet Cavalier

1 Answer

2005 cavalier all of the sudden took a long time to start finally started,but misfiring and check engine light blinking, drove car really sluggish and rough idle, It has always ran really good very zippy...


It is high time to see that your car had a decent maintenance done on it as it has served you 110K miles. Please get this necessary schedules of work done with replacement so that it will continue to give you many more years of service.
Some tips for poor start and performance.

http://www.fixya.com/cars/r5843031-tips_check_car_not_start

Oct 11, 2010 | 2005 Chevrolet Cavalier

2 Answers

2005 Cavalier fuel guage stopped working


Have a techn check gauge, wiring lastly, float in tank attached to fuel pump. This could get a little pricy.

Apr 29, 2010 | 2005 Chevrolet Cavalier

3 Answers

Have a 1997 2.2L Chevy Cavalier automatic. The


Does it feel like the shifter cable is actually moving the detent in the transmission? I've seen a broken shifter cable in a cavalier a while back with the same symptoms you described. Check the cable where it connects to the transmission. It's under the hood on the drivers side.

Dec 03, 2009 | 1997 Chevrolet Cavalier

1 Answer

2005 chevy aveo only high beam and parking lights work?


check bulb, and connection, if all ok then put on new switch in steering column

Oct 23, 2009 | 2004 Chevrolet Cavalier

1 Answer

Instrument panel gauges not reading correctly


this kind of a pain the **** the dealer sells a cluster for about 350 then they turn around and charge to program it (60 to 80) dollars if you choose to buy a used one it could do the same thing shortly after you get it i am getting ready to replace a 2005 cavalier cluster that only has 33000 miles on it and i have another 2005 with 83000 miles with the same prob. so come to believe it is a age prob and not the use of it. i say pay the big money if you are going to keep car at least it will have a warranty

Feb 24, 2009 | 2005 Chevrolet Cavalier

2 Answers

2005 Chevrolet Cavalier, No power


check air intake hose first, including MAF sensor (if dirty must clean) , then check for all other hoses for leaks and last but not least check air filter.

Feb 19, 2009 | 2005 Chevrolet Cavalier

1 Answer

2005 Saturn Ion problem starting


Maybe 5 or 6 years , depends . Battery in my chevy cavalier lasted 6 yr's .

Mar 19, 2017 | 2005 Saturn ION

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

100 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...