Question about 1994 Isuzu Rodeo

2 Answers

Crown victoria lx 2000 No injector pulse theres spark and gas in rails ecm is good crankshafh sensor replaced dont know what it is help.

Posted by on

  • chkreloaded Aug 27, 2010

    Vehicle speed sensor does that send a signal to injector, and injectors have power when the key is inserted.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,559 Answers

The normal way that injectors are controlled is via the permanent application (ignition on obviously) to one side of the coil that operates the enclosed piston, and the precisely timed application of ground (negative) to the other side of the coil. The transistors that control this switching under the command of the engine computer are typically contained within the computer itself. Measuring the voltage at the injectors is not productive since the common multimeter is incapable of detecting the very short pulses that activate the coil. Some kind of visual means would be needed to observe this pulse such as an oscilloscope or an engine analyzer equipped with a 'scope.
It's unlikely that all of the switching transistors (or the injectors) have failed simultaneously so either the computer has a problem or there is no fuel being delivered to the fuel rail that feeds the injectors. You should find a pressure regulator that sits between the fuel line coming from the tank that controls the fuel pressure for the injectors. This device seem to be a sore point in many vehicles and can make it appear that the injectors are not working. Many fuel rails have a fitting similar to a tire valve to allow the testing of the pressure being delivered. I would recommend you check this before assuming that the injectors are at fault.

Posted on Aug 27, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,016 Answers

Hi,

The only other options I can tell you to do is the following:
1. Check your Vehicle speed sensor, this is mounted on your transmission.
2. Check that the wiring from the PCM to the injectors is ok.
3. Check the wiring from the VSS is also ok.
4. Check your camshaft position sensor as this also initiates the injector pulse on start up.

Check these areas and let me know if there is any more information you need.

Thanks

Jason

Posted on Aug 27, 2010

  • Jason Maurirere
    Jason Maurirere Aug 27, 2010

    Yes vehicle speed sensor is for your ignition and injection timing.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why isn't it firing?


With engine cranking, do you have spark at the spark plugs? Do you have fuel injector pulse? I can't tell if that fuel pressure is initial prime or not? The initial prime doesn't need rpm signal, no cranking, after that the computer needs to see rpm signal. I saw what you replaced, I'd have to check wiring circuits before replacing anything.

Feb 04, 2016 | 1999 Ford Crown Victoria

1 Answer

1990 eighty eight 3.8l. Why no fire/pulse to the injectors?


The camshaft sensor may be bad. Check the fuse for the injectors and it is possible the ECM is bad or the injector drivers more specifically are bad in the ECM .

Nov 24, 2015 | Oldsmobile Cars & Trucks

2 Answers

My 05 Crown Vic LX is misfiring Cylinder 1 2 and 3.


Your next step would be to check for injector pulse (signal at injector) and are the injectors working. Is the miss while driving, at idle, under load, or decell? What codes are u getting?

Oct 22, 2014 | 2005 Ford Crown Victoria

1 Answer

No Injector Pulse


run fault codes as there is a problem sensor in the system. volts at the injector is suspect as the voltage will vary with the fuel requirement.

Jan 05, 2014 | 2005 Mazda Tribute

1 Answer

91 buick skylark 2.5lt fuel injector wont pulse please help


do you have power and ground to the injector?do you have spark? a bad ignition module?

Oct 06, 2012 | 1991 Buick Skylark

1 Answer

Crown victoria lx 2000 4.6 no injector pulse theres spark but injectors wont open.


Hello! Number 1 suspect is the Throttle Positioning Sensor (TPS)...It can be tested using a volt meter...If you do not have one let me know...
The TPS is mounted on the throttle body and held in place by two bolts...It has a three wire connector...Wire colors are...Gray/White...Brown/White...And Gray/Red...Using two safety pins...Push one pin into the rear of the in-place connector on the Gray/White wire...And the other on the Brown/White wire...Place + probe of meter (set to read 5 volts) on the Gray/White and the - probe on the Brown/White...Turn key to on...Meter should read less than 1 volt (.85)...Move the + probe with safety pin to the Gray/Red wire...Should read 5 volts..Send results...

Guru..........Saailer.

Aug 27, 2010 | 2000 Ford Crown Victoria

2 Answers

Try to start truck but battery dies.


check your ground wires. its quite common that they rust off and then that causes a no start. check along the frame by the battery, and starter.

Apr 10, 2010 | 1997 Dodge Ram 1500 Club Cab

1 Answer

I have a 2001 crown victoria. and it wont start. i smell fuel what do that mean we think it might be the throttlebody. or the ejecters. clogged. what should i do.it trys to start. do the ecm or egr have...


the rule is checking for spark at the spark plugs, if you have spark then check for fuel pressure at the test port on the fuel rail.
since you smell gas, you need to check to see if there is any fuel leak.
if you don't have spark but you have fuel pressure then it's more likely the ignition module.
if you have spark but don't have gas then check the inertia switch and fuel pump. assuming that you already check your fuses.

Mar 16, 2010 | 2001 Ford Crown Victoria

1 Answer

I have a 1997 chevy cavalier and the cc cable snaped and the car just stoped running i have checked that there was gas spiting out at the fuel rail and that is fine it is getting plenty of gas and spark...


hi I'm litoshop you my have fuel pressure and spark on your plugs but it sounds to me that you don't have injector pulse the injectors or not opening to release the fuel the sensor responsible for this is the crank sensor check that the sensor harness is plugged in tight and if it look good then replace the sensor if this information have been helpful please let us know good luck

Jul 28, 2009 | 1997 Chevrolet Cavalier

Not finding what you are looking for?
1994 Isuzu Rodeo Logo

Related Topics:

243 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Steve Hurc
Steve Hurc

Level 3 Expert

450 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...