Question about 1985 Cadillac Eldorado

1 Answer

Getting fuel to throttle body, but, car will not start. Fuel injected system. Injecters are not firing. Starts when gas is poured in throttle body then dies. What's my problem?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 864 Answers

Sometimes there is a fuse just for the injectors if none of the injectors are firing id check the fuse.
But first check to see if the fuel injectors click because if they do click it could be the fuel pump.
Are you able to figure out what the fuel pressre is at when you prime the system? You can do this by checking the schrader valve on the fuel rail by plugging in a gauge and see if it has pressure when you turn the key.
if the injectors dont click and you have fuel pressure check the fuse for the fuel injector system (depending on model fuel injector system.) Cause you need to first make sure the fuel injectors arent firing cause it may be a pressure regulator problem or a fuel pump.
if you need further assistance or have a question about anything ive said please follow up with a comment and i will be glad to assist you further from there. Thanks and good luck.

Posted on Aug 26, 2010

  • Nathan Ayers
    Nathan Ayers Aug 26, 2010

    forgot to mention you can generally check them clicking by putting the key forward but not in start position and then press the gas pedal down. This should work on your model but im not sure.
    cause i believe you have a ht4100 system which is a TBI or throttle body injection. but generally both injectors dont go at the same time and you feel a loss in power when one is failed.

  • Dave May 03, 2013

    I have the same problem but my car (85 eldorado/HT4100/DFI - TB)started hesitating thhen stalled out and would not start. I have spark and compression so I checked the fuel pump because I could not hear it. It was filthy but worked with direct DC connection so I cleaned the junk out of the tank, replaced fuel Filter (in line) replaced bad fuel pump relay but I am stiull not getting the injectors to fire even though I have 10 PSI of fuel pressure at the shrader valve. the injectors are not even firing but when I hook a 10 volt batery directlt and fire the injectors it runs for a few seconds. I no I need to find the oil pressure switch and unhook it hile I jump the fuel pump relay to see if the oil switch is the problem. any ideas ewhat else I can try or where I can find the diagnostic flow chart??? Thank you all, Dave

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starting issues


So you know it is not getting fuel thru the injectors.
Have you checked fuel pressure at the rail, and do you know if the pump is running when you turn the key on ?

Sep 11, 2012 | 1998 GMC Yukon

1 Answer

97 jimmy runs when you pour gas into throttle body, fuel pumps is putting out 55 to 56 psi. but will not pickup the gas from the injectors, fuel manifold psi is 55 to 56psi. 1997 4.3 vortec engine


If the 8th letter of the VIN # is W which i bet it is than your fuel pressure is to low.

This engine uses a CPI unit to deliver fuel to the cylinders. The CPI unit consists of a central injector that feeds fuel to the poppet valve that are right above the intake valves. The poppet valves require high fuel pressure in order to open and deliver fuel to the cylinders at start up.

The reason why it starts and runs if you add a little gas through the throttle body is that once the vehicle is running the intake is under vacuum. The poppets can open with less fuel pressure in a vacuum. This is a real common scenario with these style injection systems.

A new good quality fuel pump (a/c delco or delphi are good pumps) and your fuel pressure should be back into spec of 58 psi or more and the vehicle should fire right up. Make sure you replace the fuel filter when you replace the pump.

Oct 17, 2010 | 1997 GMC Jimmy

1 Answer

Wont start,pour little fuel in throttle body runs 4 little, changed fuel filter,psi seems good off fuel pump


The injecters may be bad, or not getting power.Check wires to injecters @ throttle body to make sure they have not rubbed bare .

Mar 08, 2010 | 1985 Oldsmobile Ciera

1 Answer

Not getting fuel to injecters starts but stops


electric problem there must be a loose connection,the wires for the solenoid on the fuel rail ,the solenoid is not opening at the right time ,see for the electric connection,when replacing head gasket,may be you have not plug the wire connection

Jan 12, 2010 | 1994 Volvo 940

2 Answers

99 tahoe,changed fuel filter,and poured some gas in the throttle body and it will start.


i am assuming that this vehicle will not start without the gas poured into the throttle body? If so then there is a fuel dilevery problem which can be coming from injectors that are not firing due to clogged injectors or a malfunctioning injection pulse. or clogged fuel delivery system which is most probaly not the case due to you changing the fuel filter, or a bad fuel pump. you have some testing ahead of you.

Aug 29, 2009 | 1997 Chevrolet K1500

1 Answer

Engine won't start.


Sounds like your fuel injecters are plugged. Wouldn't do you any good to add fuel injecter cleaner to your gas if engine won't run, so you would need to remove your injectors and clean or replace them. Hope this helps: http://www.autozone.com/autozone/catalog/parts/partsShelf.jsp?displayName=Fuel+Injector&currentPage=1&categoryDisplayName=Fuel+Delivery&navValue=14900120&itemId=prod61264&parentId=cat30060

Jul 30, 2009 | 1994 Toyota 4Runner

1 Answer

98 astro van starts and dies immediately


hello, I really feel by the sound of ur story that it is carbon build up egr valve on side of throttle body if it is fuel injected then it mght be bad injecters, otherwise if its not getting spark check ur altnator

Jul 29, 2009 | 1998 Chevrolet Astro

1 Answer

Only starts when pouring gas in throttle body


Tried changing the fuel filter? If that's not it it could be a bad pump

Jun 02, 2009 | 1998 Dodge Durango

1 Answer

98 chevy s-10 wont start


real comon starting problem for these is moisture in the cap and rotor and plug wires. replace cap, rotor, and wires. while you have the cap and rotor off check the two vent holles in the base of the distributer to see if the screens are plugged. be careful with the srews that hold the cap on the distibuters are plastic and will break.

Nov 14, 2008 | 1998 Chevrolet S-10 Pickup

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

395 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...