Question about 2003 Buick Century

1 Answer

I've had this start problem since it was new,now it's getting worse. When it first started i had trouble starting if i made more than one stop. Now it does it all the time cold or hot. This is what has been done to try to solve-cleaned fuel delv. components & inside combustion chamber,fuel pressure & volume test,gas cap,fuel pressure regulator (twice),fuel filter,starter,under hood elect. center,ignition lock cylinder & keys,replaced ubec,internal pcm.I'm out of ideas and a lot of money and it's still not fixed. .I have also done my regular maintance,oil,plugs,plug wires,etc.... ANY HELP WOULD BE GREAT. Tina

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 197 Answers

Take car back to dealer, explane problems and show him your bills.Be nice but tell him you are going broke and need help.

Posted on Sep 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does engine stutters when car is stopped


If you are talking about a missfire, you should have a check engine light and trouble codes stored in the engine computer.

Nov 03, 2015 | 2001 Hyundai XG300

1 Answer

2001 saturn sl1 wont start on first crank getting worse


How about a repair shop & actually
have the issues diagnosed to find a solution?

Jul 26, 2013 | Cars & Trucks

1 Answer

Oldsmobile cutlass ciera


Could be crankshaft sensor.

May 04, 2013 | Cars & Trucks

1 Answer

I have no spark on my 1990 Ford E-150 5.8L. I have replaced the coil.


Are you getting power to the coil? If coil voltage is low, suspect the radio capacitor is shorted. If the voltage is good, the problem may be the ignition module. One other possibility is a problem with the distributor pickup coil or connector. See 2nd page at link below.
http://www.revbase.com/BBBMotor/Wd/DownloadPdf?id=15586

Aug 02, 2017 | 1991 Ford F150

1 Answer

It has a knocking sound in the motor and 0power,and i can have my truck in 4th gear and full throttel and still only will go 25 mph's


First of all, stop driving it and don't try to start it again.
You've got serious trouble. At the least, you've got a bad valve lifter or something worse. Even starting it one more time is likely to lead to much worse trouble. If you're lucky, you'll only have to rebuild the top end. If you're not lucky, you're looking at a complete rebuild.

Jan 08, 2011 | 1984 Isuzu Pickup

1 Answer

My '97 Jimmy misses when I accelerate and lunges when stopped.My fuel injection was cleaned and fuel filter was changed last week and my service engine light is still on.


My 96 started out that way, then got worse and worse. Got all kinds of trouble codes,like multiple misfires, maf sensor bad, map sensor, O2senssor rich. Turned out to be the distributor cap and rotor. Rotor had carbon track on the backside. Other than that, they looked perfect. New ones solved the problem and all the trouble codes went away. All that misfiring was causing all the sensors to throw false codes. I figured out I needed to look for something not so obvious when the $100 maf didn;t change a thing.

Jan 03, 2011 | 1997 GMC Jimmy

1 Answer

Trouble starting


SOUNDS LIKE IT COULD BE THE ALTERNATOR NOT CHARGING AT PEAK UNDER A LOAD WITH THE A/C ON, OR A STARTER DRAWING TO MANY AMPS.

Sep 30, 2009 | 2006 Kia Rio

1 Answer

1994 jetta 2.0 has trouble starting up


Your troubles could be coming from a dying starter. I would have it tested just to be on the safe side.

Jun 26, 2009 | 1994 Volkswagen Jetta

1 Answer

1999 3.8L V6 Firebird - Cyl 6 misfire, stalls at idle, hard start


look at spark plug 6 see if it is foul out with oil. when you first start you car up and it smokes blue you have leaking valve seals and stop up oil return holes.if all is good .check 6 injector make sure its getting power.

May 16, 2009 | 1999 Pontiac Firebird

2 Answers

Trouble starting


check the fuel pressure sounds as if fuel pump quit

Nov 01, 2008 | 2000 Dodge Durango

Not finding what you are looking for?
2003 Buick Century Logo

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...