Question about Chevrolet Tracker

1 Answer

Its getting no power to anything it has a brand new battery and all the fuses are good, but maybe the ignition fuses under the hood what is could be the problem

Posted by on

  • Ronny Bennett Sr.
    Ronny Bennett Sr. Aug 26, 2010

    need to know the year make and model please.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 7,353 Answers

What do you mean "anything" headlights? horn? dash lights? what year? make? model? engine?

Posted on Aug 26, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 86 grand Marquis ,I am not getting power to anything, lights, anything. New battery. New cables.. Any ideas?


Check fuses, grounds and /or follow the positive cable until you find where it's disconnected

Nov 27, 2016 | 1986 Mercury Grand Marquis

1 Answer

What can I do to get power to inside the car?


Check the wire from the + terminal of battery to underhood fuse box. It may be broken or not connected. Also, the ignition switch could be at fault.

Mar 05, 2016 | Cars & Trucks

2 Answers

Power Accessory jack used to have power even with ignition off. Inside cabin Under hood main ignition fuse is good. Are there any fusible links in this circuit ??


main ignition fuse is only for just that...

if you checked that the circuit to that power outlet is OK, including the wiring, maybe the jack itself is bad

disconnect it, then use jumper wires to the battery to see if it powers on

Apr 10, 2015 | 2001 Nissan Frontier

1 Answer

Where does the ignition switch and fuse panel get its power from? 4 dead fuses, not blown.


I have found with these Crown Vic's,especially police cars,they manage when the get in accidents to hit the right front of the cars and when they do they damage the wiring harness. The rain,salt,snow get in the harness and you eventually have problems. Look under the car in front of the right front tire and you'll see. Good size wiring harness. Look at it for damage,or sometimes you'll see like a light green dust coming out of the harness. Usually where I find my breaks,shorts or opens.

Apr 06, 2013 | 2004 Ford Crown Victoria

1 Answer

Polarity was reversed when jump starting vehicle installed new battery & no power to anything mechanic said fuse got blown.What fuse,where it is located & cost of it.


Hard to say without make, year, and model-but check all fuses in the power distribution box under the hood- ignition, alternator fuse, etc.-all of them, the small ones and the maxi-fuses. All fuses are pretty cheap. If you still have nothing, you may need a wiring diagram to check for fusible links that would be power distributors right off or near the battery. Fusible links work much like a fuse, and most have been replaced by maxi-fuses, but many vehicles have both. If there is a designated main fuse, it should be in the distribution block or box under the hood.

Feb 06, 2013 | Cars & Trucks

1 Answer

Alternator is good battery is new but no power after siiting an hour


Yo may have a bad ignition fuse under the hood. Should be a big square box, pop the cover off and look for that fuse, maybe a gray square type fuse.

Aug 10, 2012 | 2004 Ford Expedition

1 Answer

1996 jetta no electrical power to car. has new battery and cables all connections are good


check the fuses under the hood.maybe ignition or just check them all.

Jan 06, 2011 | 1996 Volkswagen Jetta

1 Answer

My escort just stoped running.No power to anything.The battery is not dead all fuses are good,evwn the ones that are under the hood .has any one have any idea what wrong with my car.Thanks


CHECK BATTERY VOLTAGE ITS SHOULD BE 12.5 VOLTS.IF YES.I AM LOOKING AT BAD GROUND BATTERY CABLE OR LOOSE CORRODED BATTERY CABLES.REPLACE THEM IF THEY ORIGINALS CABLES.TURN OFF RADIO FIRST BEFORE REMOVING BATTERY CABLES.IF BATTERY AND CABLES GOOD.CHECK IGNITION POWER FUSES AND ALTERNATOR FUSE.IF ALL LOOK GOOD.YOUR ALTERNATOR COULD BE BAD OR A OPEN IN IGNITION SWITCH COULD BROKE OR LOOSE WIRE IN SWITCH.

May 12, 2010 | 2001 Ford Escort ZX2

1 Answer

Will not start


check the ignition fuse under the hood and also check the ignition relay, if this does not fix it you probably have a ground problem if you are not getting any power to anything

Aug 20, 2009 | 1995 Honda Accord

1 Answer

Fuel pump relay, fuse??


check there should be a fuse box under the hood are some small little black are green boxes under the hood one of them is your fuel pump relay.

Feb 16, 2009 | 1987 Ford F 150

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

61 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6918 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...