Question about 1987 GMC VanDura

1 Answer

My 1987 gmc van back fires and loses acceleration at 25 miles per

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 8,273 Answers

Symptoms indicate timing chain has slipped a notch

Posted on Aug 25, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine misfires and hesitation


Ignition Wires on wrong

Worn out Cats --can't test?
140,000 miles & 11 years--replace them

Check Fuel pressure

Front O2 Sensors--not the issue, but get
changed at 100,000 miles

Aug 29, 2012 | 2002 GMC Savana

1 Answer

Loses pressure when driving forward and backwards. It won't go any faster than 25 miles per hour


Sounds your catatylic converter is clogged.You will need to have the exhuast pressure tested.Or the next time you drive it for a little while stop and look under at the converter to see if its cherry red.Also put your hand behind tail pipe and feel how much pressure is coming out at idle.

Jan 14, 2012 | 1993 Ford Explorer Limited

1 Answer

Acceleration - cannot get above 40 miles per hr.


If the engine revs up while in drive and running at 40mph, your transmission is probably slipping. Try checking your transmission fluid level. If it is OK, I would get it by a garage to have them look at it to cofirm.

Mar 30, 2009 | 1998 Land Rover Discovery

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...