Question about 1993 Chevrolet Lumina

1 Answer

Rough idle,lost of power,rich smell of exhaust. Replaced,fuel pump & filter, O-2 senor,spark plugs,coil pack, any ideals?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 36 Answers

Could have a bad fuel injector may be leaking in the cylinder.

Posted on Aug 24, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What causes loss of excelleration while driving


It sounds like either your fuel pump has quit or your fuel filter is badly plugged. If you crank it for a while and do not smell gasoline back at the exhaust, your fuel pump has probably quit.

Nov 27, 2014 | 1994 Ford Escort

4 Answers

What would cause 93 chevy c1500 rough idle smells of excess gas at exhaust


Does the truck seem fine when you first start it & then acts up when it reaches operating temp?
That would lead me to look at my oxygen sensor, a bad sensor can cause the truck to run "rich" which would explain the fuel smell in the exhaust.

Jun 28, 2014 | 1993 Chevrolet K1500

1 Answer

2.3l 2001 ford ranger rough idle and running rich and misfiring with p0301 code


You have to correct the cylinder misfires first

You may have vacuum leaks somewhere in the
intake or exhaust

You really need to look at data with a scan tool

You start with Mode $06 & cylinder misfire count ,if that
even works well on your motor

Then you look at fuel trim & add short & long together,
to get an idea if it is running rich,which would be a lean
condition from a vacuum leak or rich from leaking injectors

All the data is only good if you haven't cleared it or disconnected
the battery. If you did, then you have to drive until all I/M Monitors
run & then look at data

You look at O2 sensor data & even scope them

You made no mention of checking for codes
No mention of a cylinder leak down test for valve leaks
Exhaust Converter age or condition !
Fuel Pressure !

Mar 05, 2014 | Ford Ranger Cars & Trucks

2 Answers

Car is idling rough all coil packs have been changed along with spark plugs


Dont get another harness. If you are using Autozone supplied coil packs, the problem is most likely the coils from Autozone. I have went through this exact same thing before. I changed the coild because one had a burn mark on the boot between the plug and the coil pack. I noticed it when changing spark plugs. The new coil from Autozone made the vehicle struggle on take offs and idle rough and the vehicle had no power. I installed another coil from Autozone again which was supposedly a better model and costed more. The vehicle ran a little smoother but the rough idle and small misfire was still there. I installed another coil from the dealership and the problem was fixed immediately.
I also replaced one of the coil connectors for a different cylinder but only because i broke it when disconnecting the coil packs to remove the spark plugs.
And when I installed all my coils and the new one from Autozone, I used dielectric grease on all the connectors. But the rough idle and power loss was immediate following installing the new coil from Autozone.
Beware if you are using coils from another part store because many part stores get their parts from the same source.

Jul 18, 2012 | 1996 Volvo 960

2 Answers

98 expedition 5.4 4x4 with dual a/c..sputters and shakes while idle and driving...please help me ! i have replaced 5 of the 8 spark plugs till i can get to the back 3 (pain in the ****) no change not even...


When you know the symptom who needs codes?And if there was a code it probable say lean bank 02. why simple you have a misfire. the smell rich exhaust the shake and sputter in drive. 2 causes the Expedition suffer from ,An open EGR valve.If you can change a fuel filter and change a spark plug you can test this. when the engine is running and misfire at idle and the vehicle is warmed up and at operating temperature. Turn off engine. Go to the EGR is it hot to touch. because if it is it open and this the the culprit.Another misfrie is from COP (coil on plug.)When you change the spark plug where any of the spark boot torn or worn that spark can go through. Or even a faulty COP will do this .To find it you have the engine running and lift one COP out of the cylinder and listen for a engine drop if the engine RPM drop the COP is good if no change in engine the COP is bad. By the way 600rpm in drive is low

Feb 27, 2012 | 1998 Ford Expedition

3 Answers

Why is my 1986 toyota pickup running rough


Thanks for choosing FixYa and welcome to the site. There are a few things that can cause a vehicle to run rough. First, check for vacuum leaks. A simple leak can cause a car to act up. Make sure the air filter and fuel filter are not clogged up. If you haven't had a tune up in a long time, it may be that. Replace spark plugs, coils, distributor cap, coil packs. Make sure no wires or hoses have come loose. Check to make sure your pcv valve is not clogged or broke. You might want to flush your coolant as well. Go ahead and change your transmission fluid and filter as well. It is possible that you have a sensor going bad also. Try to pull any codes off the computer that you can. If you can, it may lead you to the root of the problem. If you have any questions, feel free to ask and thanks for using FixYa.

Apr 12, 2011 | 1986 Toyota Pickup 4WD

2 Answers

Have a 2006 Dodge Durango. 96000 miles. Regular maintenance. Idling rough, excessive vibration and loss fo power on acceleration. Check engine light flashed at 2500 rpms. Check engine light stays on, but...


i would do a tune up and this should fix your problem, i think the coil packs are around $30 a piece, you can just replace the spark plugs first, then if needed the coil packs. Hope this helped Tim

Mar 29, 2011 | 2006 Dodge Durango

2 Answers

1997 Mustang Cobra (4V, 4.6L), rough idling, won't stay running


It seems you have a problem with firing into combustion chamber,did you check if there is spark coming to all cylinders? It may also the coil pack that sits on the spark plug or the wiring to it ,whichever applicable.Be careful as this could cost a lot in terms of buying parts..hope this helps.

Dec 18, 2009 | 1997 Ford Mustang Cobra

2 Answers

89 Corsica: no power, hesitates in drive, idles


What engine? Sounds like maybe timing chain jumped or it is very lean.

Apr 26, 2009 | 1989 Chevrolet Corsica

Not finding what you are looking for?
1993 Chevrolet Lumina Logo

Related Topics:

196 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...