Question about 1997 Buick LeSabre

Open Question

How to fix Speedometer in a 1997 Buick Lesabre How

How to fix Speedometer in a 1997 Buick Lesabre How to install a speedometr in a 1997 Buick Lesabre

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Buick LeSabre speedometer problem

My speedometer was stopped working, It was reading 40 mph when I was going around 65. Than it dropped to 0.
After I turned off ignition everything now works.

Posted on Jul 30, 2008

  • 1 Answer

SOURCE: Buick LeSabre speedometer problem

i have a 2004 buick lasabre gauges are not working can anyone give me an answer of how to fix this

Posted on Feb 08, 2009

honeymokey
  • 3113 Answers

SOURCE: 2004 Buick Lesabre speedometer not working

Yes it's on the right side othe transmission just above the passenger side cv axle. You most likley need to send the cluster off and have it checked. Model Electronics in NY.

Posted on Oct 09, 2009

  • 1 Answer

SOURCE: How to replace Speedometer Sensor

1. disconnect the PCM connecter C1
2. connect a signal generator I/P test J 33431-B to PCM connector C1, terminal 55.
3. Connect J 33431-B ground to terminal to a good chassis ground
4. set the signal generator I?P test J 33431-B to 54 mph.
5. turn the ignition siwtch to RUN.

Yes it reads 54 then
1. inspect CKT 817 (dark green/white) for the following
a. a short to ground
b. a short to voltage
c. an op
If no problem --> check IP wiring for connection, if ok then Replace IP cluster.
If yes problem, repair CKT 817 wiring

If NO 54
1. inspect for poor connection at C1, 55
2. if OK, then go check engine controls

Posted on Oct 25, 2009

daves944
  • 1050 Answers

SOURCE: abs & traction light on 1997 buick lesabre

This is a fairly common problem, Gm has actually issued a service bulletin regarding this repair. The problem probably originates from one of your wheel speed sensors that is mounted inside one of your front wheel bearings. To be sure, you need to have the car scanned to find out which one and then you have to replace the whole bearing assembly because the sensor is integral to the bearing. The bearing is not hard to do but you will need some professional tools if you want to do it yourself. At a shop it should cost between 3 and 400 dollars complete.

Posted on Jan 10, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My speedometer is not working is it a cable? a fuse? a relay? i need to fix 1985 buick lesabre 307 v8 4 barrel rocker


Yes it is the cable type. The instrument cluster must first be removed. Depress the retaining clip on the back of the cluster to release the speedometer cable. Once the end of the speedometer drive cable is exposed, grip the inner cable with pliers and draw it out of the housing. Installation is the reverse of removal, but lubricate the entire cable. Use special speedometer cable lubricant, Not oil, for this purpose. Insert the cable into the housing using a twisting movement until the lower end is felt to engage with the pinion gear at the transmission. You can also check the Pinion Gear at the transmission, That is where the speedometer cable connects to the transmission. Some times these small nylon gears will strip out caused from no lubrication in the speedometer cable housing. If the above does not solve your problem you may need to change out the cluster itself to obtain a good working speedometer head. Good Luck and Happy New Year. From Ernie @ RedDeer, Alberta, Canada.

Dec 30, 2010 | 1985 Buick LeSabre

1 Answer

I have a 1997 buick lesabre and the speedometer is reading way too high. Is there any way to fix this without replacing the whole unit?


Your best bet is to go to a transmission repair shop.
The sensor should be on the outside of the transmission case
Again,don't replace anything based on my guess,have things tested first

Oct 16, 2010 | 2004 Buick LeSabre

1 Answer

Speedometer does not work but the hud one does


Pretty common issue with the 03-06 Lesabre instrument clusters, usually they start going out when they get some miles on them. It's due to failing stepper motors on the cluster's circuit board. Check this page out for more about it and how to get it fixed - Lesabre speedometer fix

Oct 14, 2009 | 2004 Buick LeSabre

1 Answer

Speedometer on 1997 Buick LeSabre Broken


Yes Yes have it diag maybe blown fuse the old one can be sent out for repairs if bad

Sep 08, 2009 | 1997 Buick LeSabre

1 Answer

Transmission slipping on 97 buick lesabre


The clutch apply seals have hardened or rolled over. Only a transmission rebuild will fix. Try to get a used one to save some money.

Apr 13, 2009 | 1997 Buick LeSabre

1 Answer

Buick LeSabre speedometer problem


i have a 2004 buick lasabre gauges are not working can anyone give me an answer of how to fix this

Feb 07, 2009 | 2004 Buick LeSabre

1 Answer

1997 buick lesabre


Get the speedometer head fixed,repaired or replaced at you local gm dealer. Model electronics in NY repairs them.

Nov 23, 2008 | 1997 Buick LeSabre

1 Answer

Buick LeSabre speedometer problem


My speedometer was stopped working, It was reading 40 mph when I was going around 65. Than it dropped to 0.
After I turned off ignition everything now works.

Jul 26, 2008 | 1997 Buick LeSabre

1 Answer

No speedometer


Two seperate problems. Your transmission like needs a rebuild, one of your bands or clutch paks are failing. That's why it will only do one gear. The no speedo reading, is likely a broken or disconnected speedometer cable.

Jul 26, 2008 | 1997 Buick LeSabre

Not finding what you are looking for?
1997 Buick LeSabre Logo

Related Topics:

216 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...