Question about 1995 Oldsmobile Aurora

1 Answer

Poor acceleration. Jumpy once it hits about 40 mph. has backfired before. What causes this?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 8,567 Answers

Possible timing chain has skipped a link.

Posted on Aug 23, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my 1999 Chevy Tahoe backfiring?


Hi Dion:
When under acceleration, an engine experiences increased cylinder pressures. If you have a spark plug(s) that is in poor condition, it can misfire (or not fire) then, so the unburned fuel will ignite in the exhaust, and "backfire".

Another possible cause could be that the timing is not retarding when the vacuum drops under acceleration.

My recommendation?
TIME FOR A TUNE UP
Cheerfuls.

Aug 08, 2015 | Cars & Trucks

1 Answer

I have a 2008 chevy equinox to which I actuall love...but recently av been having issues with hesitation at about 40 mph and 60 mph...once I take my foot off accelerator and then reapply foot to...


I wouldn't think the PCM/ECM is the problem , hesitation at about 40 mph and 60 mph.. Something in the ignition system is breaking down causing a misfire or maybe TPS - throttle position sensor , these wouldn't cost to much. The dealer should be able to find the problem . An usually lights Flickering could be loose connection , high resistance in the circuit. Fixing Strange Auto Electrical Problems

Apr 17, 2017 | Chevrolet Equinox Cars & Trucks

1 Answer

Will not accelerate past 25 mph


If O2 sensor the car will jump while accelerating. Could be that it is the catalytic convertor. Could be an issue with fuel filter, though unlikely. If its jumpy at 20-25 then I would agree with you.

Sep 20, 2012 | 1997 Ford Thunderbird LX

1 Answer

I have problems with my 98 chevy k1500 pickup on the highway. Once i hit about 65 mph it wont accelerate and it backfires. also, after i come to a stop and try to accelerate up to highway speeds again,...


If it is running bad enough to be backfiring, the Check Engine light should be on. I would start with scanning the engine computer for fault codes.

Feb 20, 2011 | 1998 Chevrolet K1500

1 Answer

My truck was traveling at 70 mph, I gave it more fuel and it bucked and backfired hard enough to feel in cab. Just got new wires, plugs, cap and rotor. Once I let off it continued fine and even ran well...


definately clogged fuel filter or poor fuel pressure. Remove the filter and blow through it-if you have veins stick out of your forehead it is clogged. Go run it hard and then park it and observe the catalytic converter. If it is glowing red, then you have a clogged cat.

Dec 05, 2009 | 1995 GMC Sierra

1 Answer

Engine light,poor acceleration and bucking from engine


The evaporation canister can cause this, so would any vacuum leak. A faulty throttle position sensor or camshaft position sensor would also cause this but it would in the diagnostics most likely.

Jul 22, 2009 | 1999 Toyota Camry

1 Answer

Poor acceleration


Could it be a bad exhaust? Not enough pressure will leave you with less horsepower any time you hit the gas. Just a thought.

Nov 13, 2008 | 1996 Mazda Protege

1 Answer

Bogging and no power!


check your distributor cap for cracks, check te condition of your rotor, check your timing. hope this helps. good luck and remember to rate the comments you get thanx.

Oct 27, 2008 | 2001 Chevrolet Blazer

Not finding what you are looking for?
1995 Oldsmobile Aurora Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8567 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...