Question about 2001 Kia Rio

Open Question

I have a 2001 Kia Rio and I think I am having problems with a sensor of some kind. The car only at times will idle really high then idle really low so it sounds like it will stall and sometimes it does. It also does it while I drive it. It is standard and when I am at a constant speed it pulls back like it isn't getting fuel but then it will go back to normal. When I also shift gears it will also do this and will idle so low that sometimes it stalls. I also get a really strong fuel exhaust smell like it is burning really rich. I have had it to a mechanics three times for this problem and he can't find nothing wrong with it cause it won't do this when he has it. I have had the crank shaft sensor replace 2 years ago for similar problem and was good, could this be acting up again. Please help me I am getting frustrated with this. Thanks Christine

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: checking manual transmission fluid

Thanks for your response. We have the problem fixed, we went to our dealership.

Posted on Jun 25, 2009

  • 733 Answers

SOURCE: i have a kia rio 2005 wagon is standard i

does it shake really bad, like a missfire? If so, replace your spark plug wires, if that fixes the problem, also replace the sparkplugs.

Posted on Oct 26, 2009

Testimonial: "great"

  • 740 Answers

SOURCE: kia rio ccvt 2007 ''' dry hot smell ventilation system.

sounds like you have a bad heater core leaking or seaping radiator fluid into the air ducts

Posted on Jan 06, 2010

  • 7 Answers

SOURCE: 2003 kia rio- water pumps

If it is your first time having the timing belt changed, chances are the water pump is still in good enough shape to hold out until you are due for your next belt change. No sense throwing away money prematurely...

Posted on Apr 14, 2010

Testimonial: "thanks"

  • 5252 Answers

SOURCE: 2001 Kia rio automatic but it sounds like a

If it doesnt shift at proper speeds when its driving, then yes, the transmission. Make sure the fluid is full when engine at operating temp., idle. in park. If it's full, and no obvious shifter linkage problems, then you need to have it looked at by a transmission shop.

Posted on Oct 17, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to fix 2012 kia sorento camshaft sensor


replaced crank and cam sensor [Archive] - Sorento Nation - KIA ...

www.sorentonation.com/forum/archive/index.php/t-913.html

20 posts - ‎6 authors
replaced crank and cam sensors put back together cranked up very rough idle some tapping any ... 12-17-2012, 12:24 AM ... It's a 2006 3.5 Kia Sorrento. ... I found theproblem the SUV has a aftermarket alarm and remote start system I tripped ...

Kia Rio Crankshaft Position Sensor Replacement - YouTube

? 4:44
https://www.youtube.com/watch?v=hihQxMWuSFY
Mar 21, 2014 - Uploaded by Jason Roush
While looking for how to replace a Kia Rio crankshaft positionsensor, ... is on and i have a P0340 code, think this is theproblem? kia rio 2002.

Kia Sorrento/Sedona: 3.5 Litre Engine/Timing Belt/Crank ...

? 20:23
https://www.youtube.com/watch?v=CjaD_zYPrUA
Mar 29, 2014 - Uploaded by JamieJones TheCarMan
Repair and/or Replacement tips for timing belt, crank sensor,cam sensor, water pump and drivebelt ...

Crankshaft position sensor - 2003 Kia Sorento - RepairPal

repairpal.com > Questions > Kia > Sorento > 2003 Kia Sorento


Jan 20, 2016 | 2012 Kia Sorento Base 4dr SUV 2.4L 4-cyl....

1 Answer

2005 KIA Rio belts have been making noise. Now check engine light is on and I get codes p0101, p0101 pending, and p0170 pending?


The belt tensioner is defective. It automatically keeps the belt at the proper tension. P0101 - MAF sensor (mass air flow sensor) or circuit problem. P0107 - MAP sensor (manifold absolute pressure sensor) signal is low.

Mar 01, 2015 | 2005 Kia Rio

1 Answer

CAN I CLEAN MY IDLE ACTUATOR OF MY KIA RIO IT IS IDLING HIGH AND LOW OR EVEN DIE


Yes, will idle better, and control fuel better...be sure to use the
Mass Air Flow Sensor spray to clean...this does not harm any of the
factory coatings...Hope this helps.

Oct 16, 2014 | Cars & Trucks

2 Answers

Have an automatic transmission, 2001 Kio Rio. Problems when idling, sometimes high, sometimes low and will stall but starts right back up. I've replaced the Mass Air Sensor, spark plugs, air filter, coil....


It sounds to me like you have replaced everything except the most likely cause of your idle control problem...The Idle Air control. (IAC) (or Idle Speed Control Valve) It is located onthe throttle body and looks like the picture below.

dttech_3.jpg

Feb 22, 2011 | 2001 Kia Rio

1 Answer

Wont idle rite runs real ruff


Could be low idle and needs raised but may be the IAC sensor. Take off air intake assembly and clean the throttle body real good. Let it air out and then put assembly back on and try.

Sep 03, 2010 | 2001 Kia Rio

4 Answers

2003 kia rio I changed the fuel filter the car


had similar problem, 2003 rio 1.6l idle fine and die when trying to accelerate or lurch and die ran fine in reverse change timing belt,wires plugs, had codes for multi cyl misfire and low injector voltage, still same lurch and die. try wiggle test on sensor plugs and main engine harness between battery and engine . i did this and found car smoothed out,tried wiggle again and car died,took harness apart where i wiggled it and found broken wire to crank sensor.good now

Apr 11, 2010 | 2003 Kia Rio

2 Answers

No fuel economy


system is probably running "open loop".

use a scantool to get system codes.

You likely need a tuneup, i.e. O2 sensor(s), fuel injectors (system) cleaning.

Jan 06, 2010 | 2003 Kia Rio

1 Answer

2003 Kia Rio Cold Start Problem


http://www.kiatechinfo.com/index.asp

Good source for Kia its free to register NO STRINGS

May 15, 2009 | 2003 Kia Rio

1 Answer

Back fireing


The timing belt very well could be the problem. Those things last about 60k, 75k tops. The fuel filter should be checked( replaced ) as well. You can have the check engine checked for free at Advanced Auto. Does this car have a computer board ?

Dec 30, 2008 | 2003 Kia Rio

Not finding what you are looking for?
2001 Kia Rio Logo

Related Topics:

125 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

74945 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...