Question about 1996 Pontiac Grand Am

Open Question

My 2010 Subaru WRX STI is currently running on CobbAccessport 91 stage 2 map(with aftermarket dp that has been on running without a problem for a long time, and the greddy SE Elite) and I just installed an aftermarket header manifold today but since then the Check Engine Light, Cruise light, Traction Control Light and S light have been on, I tried to overwrite it by reflashing the map but the lights always come back on after abt a min since the engine starts. The error code i get is the P0134 02 sensor no activity bank1. The sensor seems to be working properly(my technician friend took it off and tested it out...) Is there a CEL fix for this situation like this one for the bank 1 sensor 2? http://www.bigdaddiesgarage.com/straight-cel-fix.html

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: CEL is ON. OBD code P2181. I already replaced the ECT.

P2181 is a overheating engine.  
Can be:
Bad fan themoswitch, temp sensor themostat water pump impeller fan motor or fuse on battery
check to see if fans work by turning on Air Conditioner (fans should run with A/C on). Turn A/C off, warm engine, check to see if fans come on, if they do NOT it may be thermo switch on radiator on lower left side, has 3 wire plug, takes 1-1/8" wrench/socket to remove.  This thermo switch controls fans when temp reaches 195F, if fans do not come on at engine temp 190-195F try  replace switch VW part number: 1J0-959--481-A  You can verify if the switch is bad by shorting wire 1 and 2 (fans should come on when jumpered).

Posted on Oct 26, 2008

  • 1 Answer

SOURCE: 1995 subaru impreza wrx sti overboost problem

Do you have a manual boost controller (mbc) installed? I have a 96 WRX and had the same problem and so took out the MBC. It now runs sweet. If you don't have one check the vacuum hoses from the turbo to the wastegate and also to the boost control solenoid, make sure they are tightened with cable ties or a hose clamp.  Also could be your spark plugs make sure you have iridium ones, they out perform any others.

Posted on Dec 17, 2008

  • 15 Answers

SOURCE: subaru wrx/sti

Hi,
Fault codes as follows
45 Pressure Sensor Duty Solenoid (Turbo Models)
42 Idle Switch or Circuit

Those are the correct codes for a Subaru.

good luck

Dan

Posted on Jan 06, 2009

  • 6 Answers

SOURCE: 2001 audi a4 1.8 random misfire

Have you changed the coils at each misfing cylinder? I had a misfire on cylinder 3, running really rough with flashing check engine light when engine was warm. The Check Engine light did come on solid after the misfire cleared. Swapped the coil with another cylinder and the misfire code followed the coil, so I replaced the suspect coil with a known good one. Voila, problem solved. My vehicle is a 2001 Jetta 1.8t, and from what I've read on the internet, failing coils is a very common problem. Good luck.

Posted on Jun 25, 2009

  • 10 Answers

SOURCE: cruise control dont work

the problem is your car has'nt been made yet 2205?

Posted on Jul 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed light bulb on 1993 subaru impreza now car won't start, everything lit up on the dashboard


1993 Subaru Impreza Won't Start! - NASIOC

forums.nasioc.com > ... > NASIOC Technical > Service & Maintenance
Sep 12, 2004 - 3 posts - ‎3 authors The car has been running fine, but recently in the morning especially, it won't turn over. I crank it and its trying to start, but there is no spark. Car won't start, cranks but no start. - NASIOC - North ...
19 posts
Aug 26, 2013
car wont start, getting fuel and spark - NASIOC - North ...
5 posts
May 22, 2012
HELP: Car won't start after timing belt change - NASIOC ...
19 posts
Sep 23, 2008
Weird starting problem--1993 Impreza - NASIOC ...
9 posts
Mar 4, 2003
More results from forums.nasioc.com

my 1993 impreza wrx wont start please help - ClubWRX.net

www.clubwrx.net/.../134323378-my-1993-impreza-wrx-wont-start-pleas...
Dec 5, 2009 - 7 posts - ‎2 authors can anyone help me, my 1993 impreza wrx wont start, 2 days ago i went to ...ClubWRX Forum - Subaru Impreza WRX and STi Community and ...

Oct 24, 2015 | 1993 Subaru Impreza

1 Answer

How do I fit a dump valve to an rb320


The best answer is DON'T. Contrary to popular belief the Impreza will run far better with the standard recirc valve unless its a good quality VTA replacement you're fitting AND you have it mapped in. If not, spend your money on better mods my friend.

Mar 11, 2012 | 2007 Subaru Impreza WRX STI Limited Sedan

1 Answer

I put the wrong octane in my '08 wrx sti


all impreza recommends high ROM.
although 99ron or 100ron is recommended, some uses unleaded for non-turbo and of course notice a sligth defference in performance using high ROM fuel.
in your case is the reverse, means does't need to drain for a change.

Feb 18, 2012 | 2007 Subaru Impreza WRX STI Limited Sedan

1 Answer

I have a 2006 wrx sti type uk it has done only 29.004 miles and the oil pick up pipe in the sump has snapped can subaru cover this under warrenty as it seems to be a common falt


a car maker fixing a car over 3 yrs old???what..are you dreaming?even if it has a full service history with a subaru dealer... BUT.... you could phone subaru head office and being very nice and polite, ask them....

Mar 01, 2010 | 2007 Subaru Impreza WRX STI Limited Sedan

1 Answer

Wiring loom diagram for subaru 97 sti & 00 ra ?


can any1 help me as my interior light not workin with doors when i use door settings get nothing till i close the doors and it comes on dull

Jan 22, 2009 | 1996 Subaru Impreza

1 Answer

Fuel Pump issue with 95 WRX STi


On both cars, check the fuel pump/guage harness connector under rear seat - the old fuel pump draws too much current and melts the connector causing poor conatct & voltage drop off. Easy to see usually, just cut the two fuel pump wires from either side of the connector and re-join with new crimp connectors, or solder joint.

Oct 07, 2008 | 2007 Subaru Impreza WRX STI Limited Sedan

Not finding what you are looking for?
1996 Pontiac Grand Am Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...