Question about 1998 Dodge Avenger

1 Answer

1998 dodge avenger missing, replaced plugs, wires, all sensors took exhaust off, nothing works put on a new computer , fuel filter still does the same thing, you have to hold the gas down to even get it to start and still missing

Posted by on

  • yadayada
    yadayada Aug 21, 2010

    have u done a compression test of all the cylinders?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 707 Answers

Clean or replace the EGR valve..........Hope this helps.

Posted on Aug 21, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1998 gmc jimmy 4.3 6cylinder 4x4 I blew


What I've seen done to test an injector is to pull it, and swap it for another cylinder. If the miss moves, then the injector is bad. If the miss stays on #5, then the problem isn't the injector.

Sep 17, 2014 | 1998 GMC Jimmy

1 Answer

97 dodge avenger 2.5 ...I have a misfire at no. 2 and no.4 .distributor ,wires,plugs less than 6 months old....also an egr code ...just replaced it ..no change new fuel filter ..no change...any ideas???


There are cam and crank sensors listed for that engine.
Is there a trouble code in the computer other than 304 or 302 ?
Do you know for a fact those cylinders are getting spark ?

Aug 05, 2013 | Dodge Cars & Trucks

1 Answer

I have a 1998 dodge avenger se 6 cyl,, an it wont start its not the battery or the Fuel Pump not the Starter it just dont have any spark it acts like its out of gas but has a haf tank all looks good an...


when you turn on key, do you hear the fuel pump run for a couple of seconds ? check fuses, & fuel pump relay,(it has a fuse also). fuel pump cannot be ruled out. next, your coil provides spark to plug wires, with an assistant, in drivers seat, pull off a spark plug wire from a spark plug, use a paper clip, insert into end of wire, with the helper turnning the key to crank engine, hold the wire w/clip about an 1/8 " from clean metal, to see if a spark occurs, wear gloves, or you may get jolted, if you know what I mean. if no spark, replace coil, I would replace plug wires also. remove spark plugs , if worn, replace. just do it !!! you need spark correct ? well then ! whens the last time you replaced fuel filter ? do it ! a new air filter will help also. air, fuel, spark all work together. go to parts store, if you can, see if they can pull any trouble codes . if you can't do the work mentioned above, it just might be your problem . now get to work , make it happen !!!!

Feb 17, 2013 | 1996 Dodge Avenger

1 Answer

1998 avenger crank no start!


I don't have experience with the avenger itself, but i've been wrenching on cars for longer then i care to admit and age myself... LOL.... but from what your describing i would almost suspect a ECU problem, but that doesn't make sense since you have injector pulses and spark. If you have fuel, air, and spark... The only thing i could suggest is recheck all electrical connections and possibly do a compression test to rule out anything that might have failed with the relearn test drive. A quick google search through some dodge forums didn't really turn up any common avenger issues, sounds like a hair pulling problem!

May 04, 2017 | 1998 Dodge Avenger

3 Answers

I changed my headgasket on my 1999 dodge avenger and water pump spark plugs even the hydraulic timing belt tensionerand it is still misfiring


Why did you change the head gasket Patrick,
Was the engine missing before you did this,or did you over heat the engine from low coolant?
If the miss was there before you may have burnt a valve,

Jan 23, 2010 | 1998 Dodge Avenger

3 Answers

Shogun 3.0 v6


your engine is running very lean. you may have a vacum leak, bad injectors, fuel pump, mass airflow sensor ect. do not continue to run the engine or sever damage will result

Nov 16, 2009 | 1993 Mitsubishi 3000GT

3 Answers

1998 dodge avenger stalls while drivingand/or idle


Sounds like the electric fuel pump in the tank has a intermittent fault.

Apr 30, 2009 | 1998 Dodge Avenger

1 Answer

1995 Dodge Avenger 2.0 engine bogging


i think your on the right path with wires and plugs. also has your timing belt ever been replaced. if is a little lose it could be retarding the valve timing.

Mar 15, 2009 | 1995 Dodge Avenger

1 Answer

My avenger cuts off after being driven for at least 5-30 minutes


a very common problem with these cars is the crankshaft position sensor. also camshaft position sensor. they will make the car do exactly what you described. let me know what you find

Jan 06, 2009 | 1995 Dodge Avenger

Not finding what you are looking for?
1998 Dodge Avenger Logo

Related Topics:

141 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...