Question about 1995 Mazda MX-5

Open Question

I have a 1995 Mk1 MX5 1.8. It runs fine on long unbroken journeys but once well warmed up and on jtrips requiring turning or negotiating roundabouts, I experience loss of power ( with no drop in engine revs) that eventually clears itself - any idea what causes this?

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
mmptruck
  • 124 Answers

SOURCE: idle problems

With the engine running at normal temperature, put a bent paperclip between gnd and ten in the diagnosis box (
Left side of engine bay above the shock tower)
Under a plastic bung on the throttle body where the big black tube fits in near throttle cable, turn the screw until the revs are about 800-900 rpm ,Remove the clip and your done!.




Posted on Aug 08, 2008

Ad
  • 73 Answers

SOURCE: power/reving up issues

The engine has a rev limiter to keep from blowing engine up with too much rpms at idle.

Posted on Sep 10, 2008

  • 124 Answers

SOURCE: MAZDA 626

Hi, Does the car have a problem changing gears? Does the RMP fluctuate rapidly? By the way, I have the same car. I encounter almost the same problem as you. The mechanic put the car under diagnostic and that I needed to change three sensors. Of course I did not agree to that because logically it did not make sense that all three sensor failed. I took the car to another shop, they said the same thing. I am very stubborn so I did not have them change the sensors. I know the problem could be from lack of oxygen or fuel. I decide to clean the MAP sensor. As soon as I clean the sensor, the car start to run like it was a brand new car. The HP increased, the pick up increased. All because the dust built-up blocked the sensor from given an acurate reading. Let me know if your RMP is fluctuate rapidly. Thanks, Mike

Posted on Nov 05, 2008

  • 750 Answers

SOURCE: my mazda mx5 mk1 has suddenly started to shudder

worn bushings,worn shocks, worn wheel bearings loose wheel nuts,loose suspension components are just some of what may cause the rear shoddering

Posted on Sep 17, 2009

duane_wong
  • 6826 Answers

SOURCE: gearbox oil capacity of mx5 mk1 1800cc 5 speed

4.2 Pints for a 1997 Mazda Miata, but that's for the U.S. MX6, I believe.

Posted on Sep 18, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a '96 mk1 cti, replaced the coil and module and the car still doesn't spark, the module gets warm when cranking so i also cleaned the ground wires, what else should i check?


Try your CRANK SHAFT SENSOR or CAM SHAFT SENSOR.

If there is no Reference ZERO signal, then the car will not spark or SPARK ONCE and then nothing.

Put a Timing Light on the Car and then turn it over, if you get a single light, then it is one of those 2 sensors (Probably the CRANKSHAFT)

Apr 08, 2013 | Cars & Trucks

1 Answer

How to add freon to a 2009 dodge journey


You need 22oz for a "front only" a/c system and 32oz of R-134a refrigerant for "front and rear" a/c system.

The compressor is off likely due to insufficient refrigerant charge in the system. Once the minimum required charge has be provided, the compressor clutch should engage (check for blown fuse if it does not). Refrigerant is added only to the low or suction side of the compressor and only as a gas. Do not invert the refrigerant tank in an attempt to add refrigerant as a liquid! Placing the tank in warm water is a better way to fill the system (raises the pressure in the tank) without concern for slugging the compressor.

Mar 24, 2013 | 2009 Dodge Journey

1 Answer

When it rains or is foggy car sputters and backfires or requires restarting. Once warmed up it rus fine. Also runs fine upon restart after allowed to sit in parking lot while I do shopping or appts. I...


After it has warmed up and is running fine. Take a spray bottle of water and spray around the plug wires and coils. If it starts to run bad suspect water getting into the coils or the ingnition modual under the coils. MOTOR62500..

Jun 21, 2011 | 1993 Buick Park Avenue

1 Answer

Engine turns off when it warms up


Low power as it gets hotter??

Try this run it at night but look under the vehicle, does the catalytic converter get red hot?? If so it is plugged......Need a new cat and need to find out why it failed! (usually fuel problem)

Jul 29, 2010 | 1995 Honda Accord

2 Answers

Stalls when warm 95 camry


sound like your have the bad distributor, when you have trouble starting remove the distributor and have the auto part check it.

Nov 23, 2009 | 1995 Toyota Camry

1 Answer

Will not stay running, once it gets warm runs like a dream .have changed several sensors and has made no change..fule pump filter tpr idel sensor and so on once you get the motor warm she runs fine ,,


The vehicle runs in what is called 'open loop' system when it is cold. The open loop system is a predefined set of parameters (including fuel/air mixture) embedded into the ECM to run the vehicle until the vehicle warms up and goes into closed loop system. Then the ECM works off the sensors.

You could have a failing ECM

Nov 10, 2009 | 1995 Chevrolet Blazer

2 Answers

1995 Lexus SC300 looses power as temp increases.


could be clogged cats or may even be bad crank sensor.

Jul 06, 2009 | 1992 Lexus Sc 300

2 Answers

I recently bought a second hand grand voyager and occaisionally when the car is started a little symbol on the dash comes on and stays on. when it stays on and i come to the end of my journey, the car...


It means that the pre heat is in operation.It is a system that burns diesel to create heat to warm up engine quicker so that warm air comes into car sooner.The smoke is the exhaust gasses from the system and normally the whistleing and smoke stops when engine reaches running temperature or on short journeys approx 1 minute after engine is turned off
During summer when no heat is required and air con is on cooling it should not light even when starting from cold

hope this helps

May 18, 2009 | 2004 Chrysler Voyager

Not finding what you are looking for?
1995 Mazda MX-5 Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...