Question about 1999 Chevrolet Blazer

1 Answer

1999 Blazer -4x4 4.3 liter 140,000 miles- lost reverse...no prior problems or symtoms...happened pretty much at once, Fluid ok...linkage appears to be ok....time for new tranny?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

That year of blazer would have the electronic transmission in it, a 4L60E I believe? A pretty common problem I have seen with people who have the same kind of vehicle is the control module for the transmission and not so much the transmission itself, especially in 4x4's. Often times this problem occurs after going out wheeling, and it's often as simple as reconnecting the plug on the tranny, or pulling it off and cleaning off the contacts, or if that doesn't work then head to the junkyard and pull the module off of one from there (and hope that it didn't have the same problem)

Posted on Aug 20, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 Kia Spectra won't go in reverse and stuck in overdrive what's wrong? Had the trans fluid changed at 140,000 last week


Was it working ok then? If so you probably have bad bushings in shift lever mechanism or linkage below. Usually checked when serviced.

Mar 08, 2015 | Kia Cars & Trucks

1 Answer

'95 Mercury Tracer automatic transmission; let go running down highway. when stopped, would not engage either in reverse or forward. fluid level ok. fluid appears ok, normal color, no burn. ...


sir .
it is a torque converter problem not a gearbox problem
it contains oil also if it lost no power transfer between engine and gearbox could be th oil sealing of your converter
have a good day

Jun 11, 2011 | 1995 Mercury Tracer

1 Answer

99 chevy lumina 94k mi transmission stopped working. Fluid good.


check fluid level, make sure proper fluid is in transmission otherwise take to trans shop to diagnse if level and type is correct(check at idle normal operating temp)

Oct 21, 2009 | 1999 Chevrolet Malibu

1 Answer

I Hard Shifting, No Speedo, Anti lock light on


1 Inspect Clutch Disc Contaminated Clutch or Pressure Plate Surface. 2 Inspect Clutch Disc Worn or Damaged Clutch Pressure Plate. 3 Inspect Clutch Disc Improperly Adjusted Clutch Cable or Linkage. 4 Inspect Transmission Shift Linkage (Manual) Loose or Worn Shifting Linkage. 5 Inspect Clutch Disc Broken, Missing or Weak Clutch Disc Springs. 6 Inspect Clu 1 Inspect Transmission Modulator(Automatic) Modulator Leaking Fluid into Vacuum System. 2 Inspect Transmission(Capacity) Fluid Level Incorrect. 3 Inspect Transmission Fluid Type Contaminated Transmission Fluid. 4 Inspect Transmission Filter (A/T) Clogged or Dirty Transmission Filter. 5 Inspect Automatic Transmission Internal Transmission Problems.tch Disc Broken, Missing or Worn Pressure Plate Diaphragm Fingers.

Sep 02, 2009 | Chevrolet 2500 Cars & Trucks

2 Answers

Where is the neutral safety switch located on 1998 Town & Country


It is built into the valve body of the transmission. It can be replaced, but it should be done by a pro. What are the symtoms that make you ask>

Aug 16, 2009 | 1999 Lincoln Town Car

4 Answers

96 chevy blazer 3rd gear and overdrive slipping


i got a 1996 chev. blazer s-s10 4.3 engine 4x4.problem i got is i got 1st 2nd & overdrive & reverse but no 3rd gear what should i do

Jun 30, 2009 | 1996 Chevrolet Blazer

1 Answer

I have no reverse what should i check first fluid ,linkage?2001 chevy blazer


Fluid wouldn't likely be an issue if all the other gears work. I'd first check linkage.

May 07, 2009 | 2000 Chevrolet Blazer

1 Answer

1997 Grand Cherokee trans hangs up on 2-3 shift


i would do a fluid flush then have a scanner installed to check if the fuild temp sensor is working correctly kdc744

Jan 27, 2009 | 1997 Jeep Cherokee

Not finding what you are looking for?
1999 Chevrolet Blazer Logo

256 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6924 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...