Question about 2004 Chevrolet Impala

1 Answer

Cooling fans wont run fuse ok - 2004 Chevrolet Impala

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 38 Answers

Run direct wires to cooling fan if not working change fans if working, check for short

Posted on Aug 20, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1998 Saturn sl1 keeps blowing 30amp cooling fan fuses. it runs for maybe 20 seconds then fuse blows


The cooling fan motor is likely drawing to much current because it is worn out.

May 18, 2016 | Saturn Cars & Trucks

1 Answer

Cooling fan does not run?


At the main fuse and relay box, check the 30A EGI INJ fuse. If OK, the main relay closes to apply power to the cooling fan relay. Next, check the 30A FAN 1 and FAN 2 fuses.If OK, power is being applied to the fan control module. The PCM processes engine coolant temperature sensor input and sends a signal to the fan control module which, in turn, causes the cooling fan motor to operate. Fan failure could be caused by malfunction of the cooling fan relay, the fan control module, the engine coolant temperature sensor, the cooling fan motor itself, or the PCM

Oct 06, 2012 | 2005 Mazda MPV

1 Answer

My cooling fan wont turn on and engin stays at normal temp. how do i know im getting a correct reading i did have to replace the radiator replaced


electric fans only run when it needs to. There should be a Thermal switch on the radiator. Short that switch to Ground and fans should run. Turn On AC and one fan should run.

Oct 03, 2012 | 2003 Land Rover Freelander

1 Answer

2000 chrysler grand voyager fan wont turn off


its a stuck sensor or relay ,, fans will run with the car off until the desired heat and or cooling is completed . check the under hood fuse block for a relay for the fan, see if you have another one that's the same, and switch them out,, if it stops and works ok,, replace the bad relay

Sep 23, 2011 | 2000 Chrysler Grand Voyager

1 Answer

How do i check the cooling fan my car is over heating


HOT WIRE COOLING FAN USING JUMPER WIRES TO BATTERY.IF FAN DONT RUN WHEN HOT WIRED FAN MOTOR BAD NEED REPLACING. IF FAN RUN WHEN HOT WIRED. CHECK COOLING FAN FUSE AND RELAY.IF ALL IS GOOD.YOUR ENGINE COOLANT TEMPERATURE SENSOR NOT WORKING.IT CONTROL COOLING FAN AT SET TEMPERATURE IF SENSOR OPEN OR FAULTY THE COOLING FAN WONT TURN ON.CHECK COOLING FAN WIRES FOR DAMAGE.IF ALL STILL CHECK OUT GOOD HAVE VECHICLE SCANNED FOR PCM FAULT.IF IT FAILS NO COOLING FAN WONT TURN ON.

Dec 13, 2010 | Hyundai Elantra Cars & Trucks

1 Answer

Engine cooling fan not running checked fuse ok


I would check the fan first disconnect the electrical connectors on it and use a pair of home made jumper cables and run it from the battery. If it works move unto relay if it doesn't you've found the culprit.
Next check relay in the fuse box. Coolant tempertant switch and its circuit aka thermal switch in the water jacket by the t-stat.

Apr 02, 2010 | 1994 Saturn Sl

3 Answers

Battery drain. alternator and battery ok. 30 amp fuse in front location shows arc. can't identify what fuse controls. is there a schematic which will show these fuses and their. purpose? ie coutesy lights,...


my battery drain indicator lamp is lit on my 2000 Toyota Camary. i checked the battery and have 12.5 volts when not running and 14.5 volts when running with lights & heater on. since all my other gauges are working ok i'm not sure if its a fuse or what fuse. can you help. altenator shows 14.5 volts when running.

Oct 26, 2009 | 2001 Toyota Avalon

1 Answer

My car fan dont turn on when ac is off


Check the operation of the radiator cooling fan circuit:-
1) check fan control temperature sensor is ok,
2) check/replace the cooling fan control relay,
3) check supply fuse for cooling fan is ok.

Oct 01, 2009 | Hyundai Motor 2002 Elantra

1 Answer

Cooling fans wont come on with out the a/c


First check all your fuses in both the under hood (60 amp) and right rear (10 amp) fuse blocks. Remove the low speed fan relay (in the under hood fuse box) and install a jumper across terminals #30 & #87. These are not marked on the box, but you will find these numbers identifying these terminals. With power at the #30 terminal, installing the jumper wire will send power directly to the primary fan. The fan should now run, if it doesn't, check it's ground wire, if that's OK, replace the fan.
Charlie

Jun 15, 2009 | 1997 Oldsmobile Aurora

3 Answers

My radiator fan does not work under any conditions, all fuses ok, wondering which relay is it to check conditions, thanks


Here are the cooling system diagnostic steps...First does the cooling fan kick on (with engine hot)? If not, check the fuse, if good then check the thermoswitch in the radiator (it's about an inch and a half in diameter located on the lower part of the radiator with two wires ) by disconnecting the wires and touching them together (again, with engine hot...at least 190 degrees) if the fan comes on, you have a bad switch. If not connect a 10 gauge jumper wire from the battery to the fan itself (there are three terminals,,, one high, one low and ground). With power direct from the battery (and a ground wire, if necessary) fan should run... if not replace the fan assembly... if it does run then you have a bad cooling fan relay. It will be located above the fuses on the fuse block... Hope this helps...;-)

Apr 24, 2009 | 1991 Buick Century

Not finding what you are looking for?
2004 Chevrolet Impala Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6910 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...