Question about 1990 Toyota Pickup

1 Answer

My window wipers work but my window washer fluid doesn't work is there a fuse for it and if so were is it cause I can't find. Also under the hood fuse box has CMH on it but when I opened it up there was nothing in that spot. What does CMH stand for

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 395 Answers

It sounds like the seal in the washer pump has worn and let washer fluid into the little motor, causing it to corrode and seize. Pump is usually located on bottom of washer fluid bottle.

Posted on Aug 20, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Looking for the fuse for the wiper motor 2008 chevy impala


WPR fuse 25amp under hood fuse box .
Wiper/Washer System Components
The Wiper/Washer System consists of the following components:
• Windshield wiper/washer switch
• Body control module (BCM)
• Wiper PCB relay
• Wiper high PCB relay
• Windshield wiper motor
• Windshield washer fluid pump
• Windshield washer fluid level switch
• WPR fuse 25 A
• WSW fuse 10 A
This is more then likely not a fuse issue !!!!!!!
Low Speed Operation
When the wiper switch is in the low speed position, ground is applied through the switch internal resistor and the wiper switch low signal circuit to the body control module (BCM). In response to this signal, the BCM energizes the WIPER PCB relay by applying battery voltage through the wiper relay control circuit to the coil side of the relay. This allows battery positive voltage from the WPR fuse to flow through the switch input side of the WIPER PCB relay and out to the switch input side of the WIPER HIGH PCB relay. Since the wiper high relay is de-energized and its switch contacts are normally closed to the low speed control circuit of the windshield wiper motor, the motor will operate at low speed.
Wiper motor low speed operation and the wiper PCB relay can also be commanded ON/OFF by using a scan tool. Refer to Control Module References.
The PCB relays mentioned above are soldered right into the circuit board inside the fuse/relay block under the hood . There are alot of reasons for the wipers not to work ! The fuse could be blown but fuse's don't just blow for no good reason , short to ground , low resistance high current flow etc.... Intermittant !

Power and Grounds
With the ignition in the ON position, accessory voltage is supplied through the 25A WPR fuse to the WIPER PCB relay, the WIPER HIGH PCB relay and the WS WASH PCB relay that are all located in the underhood fuse block. Refer to Wiper/Washer Schematics.
G200 provides ground for the windshield wiper motor and the WIPER PCB relay. G100 provides ground for the windshield washer fluid pump and the windshield washer fluid level switch.

Dec 04, 2016 | Cars & Trucks

1 Answer

Dodge dakota wipers problem


wiper pump under hood near window bad Can go on internet ask question where it is located on your vehicle as a google question

Sep 06, 2012 | 2001 Dodge Dakota

4 Answers

My 2004 Ford Expedition will not spray windshield wiper when the button is pushed. The wipers do turn on, but no spray. Would this be caused by a fuse (the wipers do turn on) or is the motor bad?


Can you hear the washer pump running when you operate the washer switch? The washer pump is in the bottom (side) of the washer fluid reservoir. You should hear it running. If not, you can disconnect the wire connector at the pump and use a test light to check to see if there is power and ground at the connector when you operate the switch. If there is power and ground, replace the washer pump motor. If there is no power or ground, you most likely have a bad washer control switch. (You have to replace the entire Multifunction Switch)

If you can hear the pump running, check for washer fluid pouring on the ground. If this is the case, you have a broken hose between the washer pump and the jets that spray on your windshield.

Also note that there is no way possible that your problem could be CAUSED by a fuse!
For more information on this subject, please review this article: Where's The Fuse?

May 17, 2011 | 2004 Ford Expedition

1 Answer

Hello i have a Hyundai accent 2000. The washer fluid has stopped working. It doesn't even make a noise when operated. the first thing i would like to do is check the fuse, i understand that it is the...


check all the fuses with a test light.if the fuses are good then its the washer pump that needs replacing.if the fuse is the same as the wipers then if the wipers work then the fuse is good.

Apr 25, 2011 | Hyundai Accent Cars & Trucks

1 Answer

I have a 2001 Hyundai Elantra GLS four door car and about a month ago the windshield wiper fluid has stopped working. When I pull the wiper ledger in the car to clean the windows, no fluid is coming into...


With the hood up, try to clean your windows. If you hear the washer motor running, you have clogged jets that need to be cleaned. You can use a small, sharp object to try to clean out the jets. If you can access the hoses that go to the jets, you can disconnect them and see if you can blow through them to clear the line or use compressed air.

If the washer pump is not working, I would disconnect the wires going to the pump. Test them using a voltmeter to see if you are getting power to the pump. If you are, it may be time for a new pump. If not check the fuse. If the fuse is good its in the control mechanism. Hope this helps. Good luck!

Mar 11, 2010 | Hyundai Motor 2003 Elantra

3 Answers

No fluid from wiper


Either the pipework is blocked or the wiper motor is faulty.

Remove hose at window washer under the hood (Just one only), then switch on and water should be seen/ If not you need to gain access to the washer bottle and test / remove the pump and probably replace.

Dec 21, 2009 | 2006 Volkswagen Jetta

1 Answer

Windshield wipers on pt cruiser


the pump wire is probably not making good connection with the pump that is why the washer fluid wont work try and clean the connection. the pump is located under the fill tank

check for a bad relay for the wipers not working. the relay will be under the hood or under the dash next to the fuses. the cover will tell you what piece is the relay. the relay controls the delay in the wipers so that is probably bad and you can get them at napa for cheap. and simple to install its just like a fuse.

Mar 28, 2009 | 2006 Chrysler PT Cruiser

3 Answers

Can't find fuse for windshield wipers in 2008 Ford Crown Victoria.


Fuse no. 7(10amp) in interior fuse panel and fuse no.110 (30amp) in underhood fuse panel

Mar 02, 2009 | 2008 Ford Crown Victoria

1 Answer

Washer fluid not working


There is a fluid "pump" that is generally below the washer fluid reservoir under the hood. To check if the pump is bad try to spray some fluid and have someone listen under the hood while you are doing this. If they hear a hum or the system sounds like it is active but you are getting no fluid spraying out then you probably have a kink or stoppage. The spray nozzles are right below the windshield wipers and sometimes a piece of debris has lodged itself in. You can take a safety pin or something similar and try to get it out that way. If not you may have to take the hose apart and clean it that way. Hope this works for you.

Feb 10, 2009 | 2003 Hyundai Accent

Not finding what you are looking for?
1990 Toyota Pickup Logo

408 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...