Question about 1999 Chevrolet Blazer

1 Answer

When engine is at normal temp and accelerate it starts pinging

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 146 Answers

Either your knock sensor is bad , usually indicated by a
check engine light , or you need to step up on the octane
rating of the gas you use , does the motor run hot?
if so this can also affect the knocking as well.

Posted on Aug 20, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 425 CI 7 litre Cadillac V8 in a 1979 Diamanté. Once the engine is up to temperature a rattle like noise comes into the engine under acceleration. The noise goes when the throttle is


You need to find where the noise is coming from. On the top could be lifters, valves or low octane gas causing a ping. On the bottom could only one thing. Rod knock. The bearings for the pistons and crankshaft are worn.

Jan 01, 2015 | Cadillac Cars & Trucks

1 Answer

Since day one, my 2007 Dodge Ram Hemi always starts like its in a cold engine cycle. In other words, it starts at a high rpm and steps down in increments for about 20 seconds. Hot, cold no matter. It...


Yes, it is normal for a vehicles idle to be high when first starting up, no mater what the temp. If it`s already warmed up to operating temp, it will still have a high idle for a brief moment when starting. Usually this is the IAT (Intake Air Temperature) sensor. Located in the air duct down from the air filter, and before the throttle body.

Main proplems from IAT sensors are to low of an idle at normal temp, or the idle never comes down after warm up.

Your gas milage problems would stem from Oxygen sensors, plugs, wires, timing, etc...

Here is a quick test, just incase your OBD II (Computer, PCM..) memory module is not working properly. With the engine running, using the tips of your fingers, tap on the PCM, if the engine stumbles or stalls and sends troubles codes that light up your check engine light while tapping, if it does, check to make sure all wires are securely attached to it.

Apr 19, 2011 | 2007 Dodge Ram 1500 Quad Cab Sport

1 Answer

95 ford knock/ping when accelerating and the temp gauge is whack


whether llight is out or not you should be able to pull codes the plugs are a bear to replace and are there to assist in emissions check the ever faulty ford egr valve for your ping problem hope i helped alanwrench

Sep 13, 2009 | 1995 Ford Ranger Supercab

1 Answer

2003 f150 supercrew 2wd 4.6 romeo has 62000 miles.Pinging noticed when thermostat opens after cold start.Pinging occurs with most throttle positions/loads except full throttle (cant hear it) or idle.EGR...


do not use any fuel additives at all. and only use 87 octane fuel nothing higher. 4.6 and 5.4 ford engines do have a pinging sound especially with a load. but it is normal

Aug 19, 2009 | 2003 Ford F150 Regular Cab

1 Answer

Getting a ping on my '02 Maxima between 1800 and 2000 rpm. light to med load. I am using 93 octane gas. Timimg was recently retarded 2 deg at dealer but not much help. Analyzer showed no sensor faults....


Hello , does the pinging only happen when the car is at normal running temp , or anytime you press the accelerator? What temp is the car operating at? It may be running to hot or to lean as well. It may have a valve timing issue cause by a faulty sensor. Quinn , Arizona

Jul 17, 2009 | 2002 Nissan Maxima

1 Answer

1999 TJ Wrangler/Sah runs rough after warm


we have the same problem on our 2004 dakota. The mechanic says that it could be the exhaust vacuum that needs to be replaced. Also, they also mentioned that sometimes when the catalytic converter is plugged it acts that way also.

Let me know if this helps.

Jul 02, 2009 | 1999 Jeep Wrangler

2 Answers

1991 toyota corolla gts, acceleration hesitaion


it could could be the coolant temp sensor.

Sep 20, 2008 | 1991 Toyota Corolla

1 Answer

Engine knock 1999 ford crown vic


Are u using the recommended fuel ? if so try running a couple of cans of fuel injection upper cylinder cleaner through the system with the next few tanks of gas, try LUCAS brand, it is among the best, the next step is to have the engine de-carboned by the dealer, this works very well, you can also remove an octane selection jumper, it retards the timing 2 degrees, that will most times stop the ping.

Sep 10, 2008 | 1999 Ford Crown Victoria

Not finding what you are looking for?
1999 Chevrolet Blazer Logo

Related Topics:

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...