Question about 2005 Chevrolet Cavalier

1 Answer

Temp guage quit working - 2005 Chevrolet Cavalier

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 34 Answers

May need to replace the coolant temperature sending unit

Posted on Aug 07, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

OHMS Resistance for temp gauge


The OHM's are different from manufacturers. Usually the work or don't. I just test the leads and heat up the sensor with a lighter. If the resistance changes, it is good. If it doesn't read or doesn't change, it is bad. Wires usually break right behind the plug. Check for continuity at the lead and about two inches back on the wire.

Jun 18, 2015 | Cars & Trucks

2 Answers

No heat blowing from vents


1st check fuse to the heater
2nd check relay
3rd the filament wire of the heater

Dec 09, 2013 | Volkswagen Jetta Cars & Trucks

1 Answer

2000 acura tl coolant fan after fluid change


New thermostat, installed, saw, new coolant made a little mess filling reservoir, (normal) checked fan fuse for some reason, and condenser fan fuse (xxx ?:), and temp guage, is slightly lower on gauge (than normal?) (disconnected xxxx? quit? a bit? to get to thermosta?.t no dash warning lights have a feeling I popped a relay.

Answer:

ok, you did a coolant service with STAT,

and it failed.

tell us what works right and wrong, symptoms only.

over heating? parked, (fan never comes on)? as it hits 225F?

under heating? ( fan stuck on , up North can cause huge cold engine)

dash gauge stuck low. (thermostat wrong heat range 180f is best. see FSM for spec. on this temp. spec..

Dash guage varies.? oddly (air in system)?

Dash gauge too high.? (Stat put in upside-down or bleed hole (jiggle) not UP side. higher side of mount , trapping air.)

Does something wrong happen only driving?

leaks?

does cap on rad hold 12-14psi pressure, hot.?

if car has fan belts, are they tight? (for sure water pump does)

Nov 19, 2013 | 1994 Honda Civic

1 Answer

TEMP GUAGE JUST QUIT WORKING. COOLANT LEVEL IS FINE, HOSES ARE FINE. EVERYTHING IS COOL TO THE TOUCH. TEMP GUAGE READS BELOW COLD, YET ELECTRIC COOLING FAN COME ON WHEN ENGINE IS SHUT DOWN.


your gage has just gone out and needs to be replace. the computer control the fan. so as long as the temp sensor is connected to the engine it will work fine but you will not know the temp of your vehicle.

Nov 30, 2010 | 2001 Chevrolet Malibu

1 Answer

Dash guages quit working. Gas, temp, tach and


Try disconnecting battery for couple minutes and see if it starts working again I have done that in the past

Aug 05, 2009 | 2000 Chrysler Town & Country

1 Answer

Driving lights,tack and engine temp guage


Check the mounting of the fuses for the concerned instruments they maybe loosely installed.

Mar 18, 2009 | 1996 Suzuki Sidekick

1 Answer

Instrument panel guages don't read accuratly


I have a chevy cav 03 and my problem is just in the gas guage and temp guage now i cant seem to figure out how to fix it but for a quick fix i have jut been pulling out the instrument panel fuse and putting it back in it seems to fix t

Feb 26, 2009 | 2000 Chevrolet Cavalier

1 Answer

My 3.1 Monte wont start.


These sensors are sensitive, no way should they be hot wired like that,when any sensor goes bad it needs replacing. you probably blew something else. My advise, would be, to take it to a garage and have it tested, starting with the computor. good luck.

Jan 24, 2009 | 2000 Pontiac Montana

2 Answers

Ambient temp guage problems


The temperature sensor is located in front of the radiator on the passenger side. Replacements cost approx $25.00.

Jul 23, 2008 | 2000 Chevrolet Impala

Not finding what you are looking for?
2005 Chevrolet Cavalier Logo

Related Topics:

173 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...