Question about 1995 Chevrolet S-10 CA Edition

2 Answers

1995 chevy s10 2.2L I am having a serious issue with my truck. Took it out the other night and it just bogs, cannot get above 80kmph. I have cut out the cat thinking it was clogged, it was pretty close. Second the fuel pump is only 2 months old, I also replaced the fuel filter yesterday! Now I have checked the plugs and #1 & 4 are black with carbon ( not enough ignition?) # 2 & 3 had a very thin coat of gas that evaporate right away and they have normal wear marks. Would this mean I need to replace both coil packs?? any help would be great!! Thanks!

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 3,356 Answers

Other parts of the exhaust can clog apart from the CAT.

Certainly the rule-of-thumb should always be basics first. Don't jump at what seems the most obvious answer because it usually isn't.

The sooty plugs indicate there is too much fuel or not enough air rather than not enough spark, though it would do no harm to physically check the sparks.

If a comprehensive tune-up and a check of the basics doesn't provide a cure and considering the age of the vehicle it would be wise to remove the injectors and have them checked and ensure the fuel pressure and volume are sufficient.

When an engine is giving trouble and the fuel filter is changed it is a good idea to cut it open carefully to check for any unusual contamination...

Posted on Apr 27, 2017

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 5,666 Answers

Tune up, coils ,wires.

Posted on Apr 27, 2017

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Diesel13
  • 11 Answers

SOURCE: 1995 Chevy Cavalier 2.2L Automatic

Check your egr vavle. i had this problem with my old cavalier and it was as easy as removing it and cleaning it. It's probably plugged up with carbon

Posted on Aug 27, 2008

  • 15 Answers

SOURCE: 1999 S10 Pickup miss fire

Your throttle position sensor should be located on the throttle body opposite of where the throttle cable hooks on too. Look for a small black box on the other side with wires leading into a connector. get your codes read and re post them it could be a simple fix.

Posted on Oct 22, 2008

  • 2 Answers

SOURCE: hard to start and smell gas

have 1994 4.3 cpi and the problem I had sounds same.
It was a leaky pressure line in pletium . easy fix $45.00 part $15.00 gasket.
the leak was caused from the fuel lines rubbing together in pletium.
take the vortec cover off ,then remove air regulator in middle and look inside . I turned on power to key and gas spray came from drivers side of pletium looking in hole.fuel line side. if gas spray on passanger side then gas regulator faulty. takes 5 min to check
After fixing truck runs runs great. no more gas smell in cab.
also you can smell oil for gas

Posted on Feb 06, 2009

sledge1863
  • 149 Answers

SOURCE: 1995 lumina cranks but will not start

Sounds like it has jumped timing, dont know which engine you have so could be chain or belt.

Posted on Mar 23, 2009

  • 102 Answers

SOURCE: 1995 chevy s10 starts but stalls when i drive it

I see that this is an old posting so you probably have it fixed by now. If you were asking me today I would say to drive it with the fuel cap off and see what it does. If it clears up you probably have the tank vent stopped up. It would be interesting to me to know what you found.

Posted on Aug 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When accelerate above 30mph its cuts out or loses power but runs smooth at idle


Acceleration cut off when reach 30mph - Range Rovers

www.rangerovers.net/...rover.../27680-acceleration-cut-off-when-reach-...

Mar 30, 2010 - 16 posts - ‎6 authors
All of a sudden, RRSport HSE 2006 can not speed above 30mph. ... It's only an hour's drive away if your car could go straight upwards. .... My guess is that some control module got fried or out of whack when the power spike ...

WILL NOT GO OVER 30MPH WITH PEDLE TO METAL ...

repairpal.com > Questions > Dodge > Charger > 2006 Dodge Charger
... and a 18 wheeler comes up behind me going 85mph. or more and my car drops down to 35 to 40. ... It would not let me go pass 30mph and it would bog out. .... His truck was barely over 36k. when this happened. ... sudden I was cruising at 30 more or less and could not accelerate or shift gears I could just switch to Drive.

My Chevy Silverado won't go over 25 miles an ... - CarGurus

www.cargurus.com > Questions > Chevrolet > Silverado 1500

CarGurusSep 19, 2012 - His response wasn't even there until the page refreshed when I hit ...The engine would shut off due to a clogged fuel filter not hit 25 MPH and just stopaccelerating. ... when the gas pedal was to the floor but it wouldn't go over 30 MPH?.... When I punch it at 110 or above, it will cut out and drop to 103kph, ...

Starts,Idols perfect Bogs down, no power upon acceleration ...


Jan 31, 2016 | Cars & Trucks

1 Answer

My 97 Bonneville lost power while I was driving about 55. When I tried to give it some gas it just bogged down more...it suddenly started running good but only for a few seconds then back to the bogging...


Exhaust leak causing the PO131 & lean condition
Evap leak causing the lean condition

Two lean conditions that can't be controlled
until you fix all the issues

Sep 02, 2013 | Cars & Trucks

1 Answer

I have a 1995 chevy caprice classic, the check engine light is flashing six times and the car is idling high then low. when I accelerate it bogs down and or cuts out. I changed egr, fuel pump and the tpi...


It is a possible misfire code. If it does end up being that try running a bottle or two of Chevron Techron fuel system cleaner through the car. An uncle of mine 96 Skylark had a similar issue, rough running combined with blinking CEL, I had him run a bottle of the fuel system cleaner through and problem was solved. After running the fuel system cleaner through you may want to replace the fuel filter(rear drivers side frame rail bolted to the frame with 2 quick disconnect connectors attaching the filter to the lines).

Also check for any damaged plug wires because one shorting out or broken can cause a misfire code as well.

Aug 30, 2011 | Chevrolet Caprice Classic Cars & Trucks

1 Answer

I drive a 2008 Chevy Malibu LS and when I take my foot off the gas pedal at 60 km/h, the car doesn't slow down right away.


lol thats not a problem thats a good thing
i have the same car same model same year
some cars just coast faster than others
ive noticed my car likes to go 80kmph

Jun 16, 2010 | 2008 Chevrolet Malibu

2 Answers

1995 chevy blazer running bad shooting an EGR code,


Hook up a fuel pressure guage. Now with the key on and engine off does the fuel pressure come up fast and hold steady at a fixed value?

Dec 28, 2008 | 1995 Chevrolet Blazer

1 Answer

1995 honda accord Check engine light/ wont go above 2100RPMs


If it runs good with cat disconected with out clearing the codes; replace the cat.

Dec 03, 2008 | 1995 Honda Accord

1 Answer

1995 chevy blazer running lights


when i changed my radio in my blazer i discovered there were a lot of wires that ran through it like my dash lights interior lights and a bunch of other stuff you probably just missed a connector or got two of them mixed up you might have to take out the dash again

Nov 14, 2008 | 1995 Chevrolet Blazer

Not finding what you are looking for?
1995 Chevrolet S-10 CA Edition Logo

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...