Question about 1991 Cadillac DeVille

1 Answer

Have new battery nd alternator however after a few minutes running the battery is dead and cluster info center not working.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 382 Answers

The instrument cluster itself is probably going to be your problem. If it has a burnt wire or corroded diodes, it will cause your battery to drain quickly. Unfortunately, there is no simple solution to your problem without testing wires and relays. Im sorry i could not have been of more help

Posted on Aug 05, 2010

Testimonial: " good fast response,best viable solution offered."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Battery drains until dead recharged it tahoe starts and runs gauges are dead alt light is on door locks, windows, keyless entry don't work 2003 tahoe 5.3 please help


Try disconnecting your alternator. Charge the battery but leave the alternator disconnected (remove the electrical plug from the rear of the alternator).

If the battery retains its charge and can start the car (you won't cause any damage by starting the engine with the alternator disconnected) it points towards a defective alternator.

If the rectifier pack - the diodes - in the alternator burn out this can cause a battery to discharge very quickly. Sometimes, quite literally, in a couple of minutes.

If the battery still discharges with the alternator disconnected this points towards a failing battery or a drain somewhere else in the electrical system.

It may be that your door locks and windows don't work for the simple reason there's not enough power to operate them. However, as you say your gauges are dead .. this could possibly point towards a drain in the electrical system, but not necessarily so.

It becomes too easy to replace parts one after the other in the hope that a fault is cured. This is an expensive way of going about things. The best option is to pay a workshop or an auto electrician to diagnose the fault correctly. Diagnose the fault first - an auto electrician will be able to tell you within minutes if it's the battery, the alternator or a drain elsewhere.

Mar 14, 2017 | Chevrolet Tahoe Cars & Trucks

2 Answers

Battery dead. recharged, car started. drove 20 miles. parked 8 hrs. drove back home. after parking 15 minutes car wont start. Which is problem, alternator or battery?


Don't know.
You would need to have both components tested. It could be a dead cell in the battery. Or a bad connection. If the alternator were at fault it should discharge when the engine is running and slowly go dead.

Aug 27, 2013 | 2002 Ford Taurus

2 Answers

2000 vw jetta alternator won't charge


the alternator gets power on big wire battery voltage the wire runs to starter, fuse box .alternator fuse goes to automatic shut down relay to relay control in ecm/pcm the field wire comes from ecm /pcm to alt.other field goes back to automatic shut down relay back to charge battery . if not charging at alt. try new alt. and retest.

Aug 05, 2012 | Cars & Trucks

1 Answer

Hello I am having what sounds like a common thing but I can't be sure. The instrument panel has been intermentant for about for about 8 months now. Sometimes works for a day or three weeks. I am now unable...


sounds like you need to have the alternator checked, if it were the instrument cluster the van would still run, you may still have a problem with the cluster, but the running 2 miles and the battery going dead is the charging system, you may have two problems. fix the charging system first then worry about the dash.

Feb 24, 2011 | 1997 Dodge Caravan

1 Answer

Cluster problem,transmation temp gage ,engine temp gage not working but in info message center flashing other problem like battery voltage flashing but working gage no high beem indecater only sometimes...


This sounds like a few problems, the first thing i would is to have the computer scanned for any storeed codes, have the engine computer and body computer checked then scan the cluster for any problems, these trcks had a few problems with the cluster and the throtlebody just to name a few things, start with the scanning then maybe replace the cluster, on most of these newwer trucks the replacement cluster must be program to truck inorder for the truck to run correctly and cluster to operate correctly. hope this is helpful also check with your dealer for any recalls on this cluster problem you may be able to get free repairs.

Jan 10, 2011 | 2002 GMC Sierra 1500

1 Answer

I RECENTLY had my engine replaced in my 2001 hyundai Elantra. This 'new' engine supposedly has only 10k miles on it. A new alternator had to be installed.The work was done by the dealer. I have had the...


The odds are the alternator is the problem again. I've installed brand new alternators in the shop that turned out bad. The battery barely had enough juice the crank the car and get it running. Then, the battery was the only thing keeping the engine running with the spark plug until the battery drain completely dead.

If the alternator was working normally, the alternator would have kept the energy up and keep the spark plugs going without the battery's help.

Basically, the battery's job is to start the engine only and the alternator's job is to keep the battery charged and supply energy for the car's needs.

Nov 29, 2009 | 2004 Hyundai Elantra

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

3 Answers

Generic Electronic module.


The gem is behind the dash in the center, behind the radio. It controls whipers, anti theft, 4x4, cargo lamp, insterment cluster, plus a few other things. Hope this helps.

Oct 07, 2008 | 2002 Mazda Truck

Not finding what you are looking for?
1991 Cadillac DeVille Logo

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...