Question about Dodge Ram 1500

1 Answer

Ive replaced my cam shaft sensor still indicates it im reving high rpm and im wondering if that is part of my issue

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 327 Answers

Any time you replace a sensor you have to clear the codes or they will stay there for awhile is the check engine light on ? is the engine reving high at idle ? you need to give all info when asking questions

Posted on Aug 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just replaced timing chains on my 5.4 24v engine now after about 30 mins of driving the engine struggles to run as if not running on all cyl at hwy speed ok but in stop start traffic not good


check the valve timing as it indicates a timing problem.
the higher rpm at highway speed indicates that the valve timing is coming correct as the rpm advances the timing in the solenoid actuation but at idle it is out a bit
could be one cam off a tooth
run the fault codes to see if the cam shaft advance operation is working ( wiring , cam shaft position sensor , actuator etc )
check the fuel pressure and injector operations as they may be failing at the lower pulse action

Jul 01, 2017 | Cars & Trucks

1 Answer

Car blows white smoke at high rpm runs bad


hmmm...This kind of problem usually is due to cam shaft/valve timing issues. Sometimes, the cam shaft is not properly positioned and is not in sync with the distributor thus the exhaust valves open early releasing unburnt fuel. This will cause the engine to definitely run bad.
I suggest that you try to adjust your engine's timing first (cam and distributor) and then see the results. Also, remember that there is a limit to the rpm that an engine must do- about 6,000rpm is enough for high or max hp. Another information, a camshaft will only work best at a given rpm range so if you run your engine too low or too high, the engine will not work properly. In fact, there are special cam shafts for engines intended to run at high rpm while sacrificing lower rpm levels (the engine runs grumpy at low rpm levels).
Worst case, however, is that white smoke sometimes indicates that oil enters your combustion chamber, this will cost an expensive rebuild if such is the fact.

Dec 24, 2010 | 1996 Nissan Sentra

1 Answer

It starts flashing when ive been driving for a bit. my truck also idles high and the rpm needle goes up and down while im driving and causes the truck to **** back and forth as if i was reving the engine....


Take your vehicle to nearest autozone have them test .tell them your check engine lihht comes on and tell them your symptoms .the test is free and they may get a computer code telling if a sensor (which I suspect) is bad.please leve good feedback if you are satified with this solution.

Dec 21, 2010 | Toyota T100 Cars & Trucks

1 Answer

I have a 2004 Neon that begins to buck and hesitate at high rpm's


try pushing in on plugs on PCM, below and inboard from the driver's side headlight. The cam sensor goes to the bottom plug.

Apr 24, 2010 | 2004 Dodge Neon

2 Answers

Replaced crank shaft position sensor from autozone. erased all codes. still showing code p1345. ive been told to use acdelco. am i doing something wrong?


Code p1345 is the crankshaft variation learn.You need to get the crankshaft variation learn done for the code to clear.You will need a scan tool.This should take care of the check engine light.Hope this helps.Good luck.

Mar 16, 2010 | 1996 Chevrolet C1500

1 Answer

Crank shaft sesor/cam sensor problem?


If you had a fault with the crank sencer your car would not start.Sounds like the air flow meter is giving you the problems.

May 28, 2009 | 2005 Dodge Neon

1 Answer

2002 Audi A4 Esp Light comes on, car turns off when I have to sto


I had the same issue with my '05 A4 1.8T.  Turns out it was the RPM sensor.  Audi tried to tell me it was teh fuel pump and the cam-shaft positioning sensor.  Paid for teh fuel pump replacement and it died 6 blocks from the dealership.  Then they replaced the RPM snesor, works great now... Except it's still an Audi.

Apr 09, 2009 | 2004 Audi A4

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...