Question about 1999 Mercury Cougar

3 Answers

MY COUGAR HESITATES GOING UPHILL AND STALLS BUT ITS OK ON FLAT SURFACE,I HAVE A FULL TANK,HAVE CHANGED THE MAF,THE TPS,THE PLUGS,THE FUEL PUMP,THE GAS REGULATOR,THE IN LINE FUEL FILTER AND THE IAT WHAT ELSE DO I HAVE TO DO.

Posted by on

  • ANDRES MELERO Aug 04, 2010

    THANK YOU FOR YOUR PROMPT ANSWER., YOU MENTIONED ABOUT THE PRESSURE REGULATOR AND MY PREVIOUS COMMENT I DID TEL YOU THAT I HAD CHANGED IT, BUT I FAILED TO MENTIONED THAT MY COUGAR IS A MANUAL TRANSMISSION AND ITS A 2000 NOT A 1999 AS I PREVIOUSLY STATED., WILL YOUR ANSWER TO MY PROBLEM STILL HOLD...ANDY

  • ANDRES MELERO Aug 11, 2010

    need to ask another expert

×

Ad

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Expert
  • 4,070 Answers

Hi! Have you tried replacing the automatic transmission fluid? The fluid may be burnt which can cause the car to perform poor going uphill. A smooth ride and shifting will be noticeable after the procedure. Hope this helps and have a good one!

Posted on Aug 11, 2010

  • ANDRES MELERO Aug 11, 2010

    my cougar has manual trans. do yopu think i have a clogged cat converter ..andy

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 22,246 Answers

Might sound daft to you but have had this before ok it was a diesel truck but ?? the fault was caused by a rust ball in the fuel line that was sort of caught in a straight section of pipe but rolled back going up hill ,yes this was 1976 and their was no fancy electrics in those days but its worth a try ,take each end of fuel line off and blow it through with a air line ,Another fault that caused a headache was a rag in the inlet manifold ,accelerate and engine only ran on 4.5 cylinders stop engine and it ran again ,Now just re read the question over twice again and ??????' try blowing the fuel lines and see what happens ,also remove the sender unit in the tank and check the gauze filter on the bottom of the pump,also whilst its out use a torch look inside for a plastic bag or a rag??' seem to remember a leyland mandator truck when i worked on a flour company with a truck that kept dying then when left it went again ,it went up to deliver to a place the other side of london and it went up a hill in north london and died completely ,when i got to it and couldnt pump fuel i changed fuel filter ,gauze water trap ,then i blew back down fuel line and it started ,moved a few feet and died again ,so removed the sender unit and on the end of the pick up was a rag with elastic band ,say no more

Posted on Aug 04, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,272 Answers

If power is normal and all other aspects seem fine suspect possible intermittant failure of the crankshaft position sensor.Check this sensor.Also as you mentioned that fuel pump and filter replaced,But get the fuel pressure checked.If the pressure is low then problem can be fuel pressure regulator.Get the pressure tested.Also the transmission shifter needs to be checked.The transmission converter and gears needs to be checked.
On flat driving the low pressure is required but on uphill more pressure is required so the transmission gears if slipping then pressure cannot be created and easily gets noticed. Check. Thanks. Keep updated for any more query. You can rate this solution and show your appreciation.

Posted on Aug 03, 2010

  • 8 more comments 
  • raj somaiya
    raj somaiya Aug 04, 2010

    Yes if its manual transmission then also the transmission needs to be checked.
    Also Check transmission fluid level.
    Check fuel pressure and change fuel filter. Fuel pressure must be within spec.
    Get the in-line fuel filters. It does sound like a little **** in the gas line.
    transmission could be slipping and when you accelerate while going uphill.
    Use lower gears when driving uphill to keep the car from stalling

    Thanks for keeping updated with your query.

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP AND THE IN-LINE FILTER ( UNDER CHASSIS) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE STARTED THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE FUEL MANIFFOLD I DROVE THE CAR FOR ABOUT 5 MIN. WHILE LOOKING AT THE TESTER (WHICH WAS TAPED ON MY WINDSHIELD) THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, WAITED THE USUAL 5 MIN. AND DROVE THE CAR BACK TO THE SHOP,. THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW THA WE CHANGED MOST OF THE SENSORS IT STALLS ON UPHILL AND NOT ON FLAT SURFACE. THE ONLY SENSOR WE HAVEN'T CHANGED ARE THE EGR THE EXAUST MODULATOR AND THE COIL PACK., PLEASE RESPOND ASAP....ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP AND THE IN-LINE FILTER ( UNDER CHASSIS) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE STARTED THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE FUEL MANIFFOLD I DROVE THE CAR FOR ABOUT 5 MIN. WHILE LOOKING AT THE TESTER (WHICH WAS TAPED ON MY WINDSHIELD) THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, WAITED THE USUAL 5 MIN. AND DROVE THE CAR BACK TO THE SHOP,. THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW THA WE CHANGED MOST OF THE SENSORS IT STALLS ON UPHILL AND NOT ON FLAT SURFACE. THE ONLY SENSOR WE HAVEN'T CHANGED ARE THE EGR THE EXAUST MODULATOR AND THE COIL PACK., PLEASE RESPOND ASAP....ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP AND THE IN-LINE FILTER ( UNDER CHASSIS) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE STARTED THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE FUEL MANIFFOLD I DROVE THE CAR FOR ABOUT 5 MIN. WHILE LOOKING AT THE TESTER (WHICH WAS TAPED ON MY WINDSHIELD) THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, WAITED THE USUAL 5 MIN. AND DROVE THE CAR BACK TO THE SHOP,. THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW THA WE CHANGED MOST OF THE SENSORS IT STALLS ON UPHILL AND NOT ON FLAT SURFACE. THE ONLY SENSOR WE HAVEN'T CHANGED ARE THE EGR THE EXAUST MODULATOR AND THE COIL PACK., PLEASE RESPOND ASAP....ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP AND THE IN-LINE FILTER ( UNDER CHASSIS) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE STARTED THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE FUEL MANIFFOLD I DROVE THE CAR FOR ABOUT 5 MIN. WHILE LOOKING AT THE TESTER (WHICH WAS TAPED ON MY WINDSHIELD) THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, WAITED THE USUAL 5 MIN. AND DROVE THE CAR BACK TO THE SHOP,. THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW THA WE CHANGED MOST OF THE SENSORS IT STALLS ON UPHILL AND NOT ON FLAT SURFACE. THE ONLY SENSOR WE HAVEN'T CHANGED ARE THE EGR THE EXAUST MODULATOR AND THE COIL PACK., PLEASE RESPOND ASAP....ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE DROVE THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE MANIFFOLD THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW THA WE CHANGED MOST OF THE SENSORS IT STALLS ON UPHILL AND NOT ON FLAT SURFACE. THE ONLY SENSOR WE HAVEN'T CHANGED ARE THE EGR THE EXAUST MODULATOR AND THE COIL PACK., PLEASE RESPOND ASAP....ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE DROVE THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE MANIFFOLD THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW IT STALLS ON UPHILL . THE ONLY SENSOR WE HAVEN'T CHANGED ARE THE EGR THE EXAUST MODULATOR AND THE COIL PACK., PLEASE RESPOND ASAP....ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., LET ME TELL YOU HOW THE PEOBLEM STARTED.,
    FIRST PROBLEM.. THE CAR WAS STALLING AFTER ONE HOUR OF NON STOP DRIVING, I WOULD TURN THE CAR OFF AND WAITED 5 MINUTES AND THE CAR WOULD START NO PROBLEM AT ALL., I WOULD DRIVE IT FOR 5 MINUTES NON STOP AND AGAIN THE SAME PROBLEM., THE TECH CHANGED THE FUEL PUMP) DROVE THE CAR FOR ONE HOUR AND STALLED AGAIN WAITED 2 MIN. AND STARTED AGAIN., TOOK THE CAR TO ANOTHER TECH AND HE SUSPECTED THAT THE FUEL PUMP WAS THE NOT THE ONE FOR THE CAR., HE TROUBLESHOOTED THE FUEL PRESSURE IT WAS OK 35-40 ., BUT WHEN HE DROVE THE CAR AGAIN WITH THE PRESSURE TESTER ON THE ENGINE MANIFFOLD THE PRESSURE DROPPED TO ABOUT 20 AND STARTED TO HESITATE THEN STALL, THE TECH CHANGED THE PUMP AGAIN., ALL OF THE ABOVE HAPPEN ON FLAT SURFACE., BUT NOW IT STALLS ON UPHILL . ANDY

  • ANDRES MELERO Aug 04, 2010

    THANK YOU., THIS CAR USED TO STALL AFTER AN HOUR OF NONSTOP DRIVING THE I WAITED 3-5 MIN. AND IT START AGAIN., THE FUEL PUMP HAS BEEN CHANGED TWICE IN ONE MONTH.,ALL OF THE ABOVE ON FLAT SURFACE AND NOW UPHILL., WE HAVEN'T CHANGED THE EGR IGNITION COIL, THE EXAHUST MODULE, AND THE OXIGEN SENSORS SO AS I SAID BEFORE NOW THAT WE CHANGED MOST SENSORS ITS STALLS UPHILL..,. ANDY

  • ANDRES MELERO Aug 06, 2010

    THNK YOU; WE TRIED YOUR RCOMMENDATIONS BUT NO LUCK, NOW WE CLEANED THE INJECTORS BUT NO LUCK NOW IT ALSO RUNS ROUGH ON FLAT SURFACE BUT STALLS ON UPHILL.,., WHEN THIS PROBLEM STARTED IT WOULD STALL ON THE HIGHWAY AT HIGH SPEEDS AFTER ABOUT AN HOUR OF NON STOP USE... THEN WAITED 1-2 MIN.AND WOULD START AGAIN

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

99 Lexus ES300 - Car hesitates & sputters when starting off usually until 2nd gear kicks in & sometimes when going uphill. However, no CEL. Ideas?


The flexible accordion hose that connects the MAF to the throttle body might have a small crack in it. They are sometimes hard to see, especially if in the accordion folds or underneath. Starting off or going uphill will result in enough torque to lift one side of the engine enough to open the crack and cause hesitation.

Mar 22, 2017 | 1999 Lexus ES 300

1 Answer

Surging, loss of acceleration under load


Have you checked the fuel pressure with a gauge, and is the check engine light on ? TPS check out with a meter ok ?

Feb 05, 2014 | 1997 Pontiac Firebird

1 Answer

Sputters and backfires when full pedal apilled


Year make and model ? Have you checked base fuel pressure hot and cold ?
Some of the components you replaced only adjust fuel mixture, while the MAF and TPS would directly affect acceleration. If any of the sensors were faulty you should have trouble codes. So fuel pressure and volume are often suspect. You could also use starting fluid sprayed into the intake to verify the problem is lack of fuel.

Jan 18, 2014 | Cars & Trucks

1 Answer

I have a 99 Buick Regal, it hesitates and even stalls out. I had the oil and filters changed as well as the fuel filter. It is still hesitant and feels like it wants to dye. When I changed the fuel filter...


A combination of problems could be causing your hesitation/stall issue:
  1. Bad MAF (Mass Air Flow) sensor
  2. Bad TPS (Throttle Position Sensor)
Getting a free diagnostic test to pull codes will make narrowing down your problem a bit easier. Most chain auto parts stores will do a complimentary diagnostic test. The most common cause with a car that stalls when warm is the TPS. It controls your idling speed under all conditions. Even replacing the MAF alone doesn't always fix the problem although it may show up as being problematic. The 2 parts basically go hand in hand with your particular problem.

Jul 13, 2011 | 1999 Buick Regal

1 Answer

84 Fiero. trouble starting and runs rough and the surges/stalls


It sounds like a fuel pump. Check the fuel pressure. What size engine?

Aug 01, 2010 | 1984 Pontiac Fiero

2 Answers

1989 F-150 stalls going uphill


you will need check with a ford dealer
there are a number of recalls and TSB's for the trucks with dual tanks.
and if a recall applies to you its free

Oct 22, 2009 | 1989 Ford F 150

1 Answer

Bad stumble on acceleration pops through t- body.


Sounds like the fuel pressure regulator. Could also be that the timing jumped. But I'm leaning towards the pressure regulator. Hope that I could help. Best wishes.

Jan 16, 2009 | 1997 Toyota Tacoma

Not finding what you are looking for?
1999 Mercury Cougar Logo

Related Topics:

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

fordexpert

Level 3 Expert

5546 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...