Question about 1999 Pontiac Montana

1 Answer

I had a transmission flush done 2 weeks ago. 1 week later my \low traction light came on whenever I accelerated from a stop. Now 1 more week later my ABS and TSC lights are on. There is a little shudder as I accelerate from a stop.

Posted by on

Ad

1 Answer

First, Iam not a fan of flushing a trans. Owned a trans shop years ago.
You may have caused some solenoid issues, with the clutch material and cooler sediment.
Work on the ABS,TSC issues. Wheel Speed Sensors may be going and just a coincidence, a couple weeks later.
Make sure the fluid is correct for your vehicle and at the correct level.
I pray you didn't go to one of the Quick Lube Franchises.

Posted on Aug 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 GMC Savana 1500 electrical problems,acceleration


sounds like the BCM is going out on your vehicle .

Mar 03, 2017 | GMC Cars & Trucks

1 Answer

What could cause my bank 1 O2 sensor to keep going bad


For the code pulled was diagnostic trouble code diagnostics done or was the O2 sensor just replaced > What was the code # P0xxx what . There are a number of codes for the O2 sensors on cars . They don't say replace the O2 sensor . diagnostics must be done , electrical circuit testing , plus other tests

May 16, 2017 | Jeep Cherokee Cars & Trucks

1 Answer

My sercurity light is on. indicated on my dashboard my car was last started 2 weeks ago what could the problem be.


Cluster warning lights

Whenever this warning light or any other stays on in the dash it is indicating that the systems control module (or the system sensor in the case of lights like low oil pressure, door open indicators etc.) has detected a fault, it then disables the system (this applies to ABS,TCS, TCM, SRS, TPMS, MIL, CEL and BCM faults and others) as long as the light is on. You must now have the dealer hook up a special electronic diagnostic tool and "scan" the system for the fault code that is stored for the problem(s)

Legend of Abbreviations. ABS Anti-lock brake system. TCS Traction control system, TCM Transmission control module, SRS Supplemental restraint system, BCM Body control module. TPMS Tire Pressure Monitor System, MIL Malfunction Indicator Lamp, CEL Check Engine Light.

Dec 08, 2012 | 2001 Oldsmobile Aurora

1 Answer

I have a 2008Chevy Impala SS that just had a tune up a week ago. Today I start it and it would go, but then it just stopped accelerating altogether. It;s NEVER done that and as I said the tune up is a week...


Is the check engine light on ?
If you have no acceleration, the problem could be low fuel pressure or a sensor problem. If a sensor fails, the check engine light should come on.

Sep 25, 2012 | 2008 Chevrolet Impala SS

1 Answer

I have a 2002 Santa Fe AWD (2.7L) with 302K KM. Two weeks ago, I noticed on two occasions that the transmission did not downshift as smoothly as before from 3rd to 2nd (auto trans) as I approached a stop...


first try flushing and replacing the transmission fluid,if this dose not help take unit to a trans service centre have them check the valve body, you may have some shift solinoid malfunction

Jul 27, 2011 | 2002 Hyundai Santa Fe

2 Answers

I have a mazda protege 2003 and my car stinks like rotten eggs when i put on the gas and on top of that, my engine light is blinking and my car shakes when i stop at a red light!


i have a 2003 mazda protege. this is the third time my check engine light has come on. the first time the car started to shake when i stopped at a light and the check engine light came on. i had a readout done and it said misfire. i took it to a garage and they changed my spark plugs and wires. 2 weeks later it came on again and my car started to shake whenever i stopped. readout said misfire. they fixed the coils. it has been 2 weeks since then and my car started shaking again whenever i stop and the light came on. what could possibly be wrong with it?

Feb 06, 2010 | 2003 Mazda Protege

1 Answer

Transmission issues after transmission flush


Well first off, coolant in the transmission will cause transmission failure if left in long enough. Proving why the radiator failed will be another story.

Jul 28, 2009 | 2000 Chrysler Town & Country

1 Answer

Rough idle, stalling


You must get the system scanned for fault codes, sounds like the electronic throttle control has a failure.

May 01, 2017 | 2008 Jeep Wrangler

Not finding what you are looking for?
1999 Pontiac Montana Logo

177 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8548 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...