Question about 1994 Jaguar XJ6

1 Answer

I have a 1982 XJ6 S3 4.2 auto. Both indicator tell-tales have failed, probably bulbs? Do i have to remove the speedo and tacho to get at these and how easy is this to do? Thanks.

Posted by on

  • dpedwards Aug 31, 2010

    Hi, I have had exactly the same problem with my 1982 series 3 4.2 auto. The solution which someone suggested to me online was to disconnect the lead that goes to the coolant level sensor (at bottom of the brown coolant expansion tank). I did this and both warning lights now work! Don't ask me how as they are not even in the same circuit. Only thing is now the low coolant level light flashes all the time so had to take bulb out. If you do need to change bulbs for the indicator warning lights the tacho and speedo can easily be removed by just turning the bezel by about 25mm.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jaguar Master
  • 22,156 Answers

Yes you do and its not easy ,now if both bulbs failed at the same time it could be the hazard switch ,1982?? you sure about this as these cars rust away or the rear wheel bearings fail ,so vehicle doesnt pass the annual mechanical inspection

Posted on Aug 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix it and where is the problem


there must be a short in the electrical circuit board the is behind the speedo , probably caused by whatever caused the crack, you will need to remove the speedo unit and check the rear for signs of burning,corrosion , loose electronic parts etc , if all looks ok with the ignition on and engine running remove one bulb at a time and see if ALL lights go out , if so then whatever that particular bulb was for is the circuit on the speedo head at issue,you havent said what vehicle etc if it is pre 2000 this is proberly going to help you if POST 2000 then it may not as around then all manufactures where using LED's instead of bulbs so a new speedo unit would be required or taken to a auto electrician who is experienced in these type of intricate repairs

May 02, 2015 | Cars & Trucks

2 Answers

How do i fix the tachometer?


you have an in cluster factory engine tachometer (RPM)?
the tacho is meter in the cluster and does not use speedo parts or its cable.
its just a meter that needs power, ground and spark tacho signals
if all 3 are good, the meter is bad. period.
the tacho signal goes to the ignition coil minus lug, and will good, as engine runs. so... wires bad, to tacho or tacho bad.
ever price a new one? or even used? $100 used?
you willing to pay that much for just a factory tacho?

there is NO speedo cable. this old 93 is electronic, (rare on most 93 cars made, toy is advanced)
here is the proof, amazing how books dont lie....
there is a speed sensor.
the tacho and speedo use the same power and ground
leaving just one wire,r-g red-green RPM sig. pin 5 of cluster
an is SPARK primary sig. so if only tacho is dead.
then the tacho is bad, or that pin 5 wire is dead.
got you to just 2 possibles.


25384019-pwhjtvbdga2ldpurmpdgxawg-1-0.jpg

Jan 26, 2015 | 1993 Toyota Corolla

1 Answer

Tacho and speedo incorrect readings


compared to what?

tell method of test.
tell numbers. my engines idles hot at 800 (hand tacho)
but gauge reads in dash 200.
or im going 50mph ,my cell phone with free GPS shows 40.
why?
like that, use real numbers.

Jan 31, 2014 | 1992 Toyota Celica

1 Answer

How to know whether my corolla 96 overdrive is on/ off mode... how to turn it off to get fuel efficency.? whether any indicator is there to know my overdrive is on/off.?


Yoiu should turn the overdrive switch on for better fuel efficiency.IF you have tacho an speedo there should be about 10% higher speed for the samme tacho rpm .IF there is no difference them overdrive soleniod is not engaging the overdrive gearset at the rear of the transmission

Apr 29, 2011 | Toyota Corolla Cars & Trucks

1 Answer

Why is my 1993 jaguar xj6 smoking


It's tough to say... White smoke means you probably have a blown head gasket. Blue smoke indicates your running too rich. black smoke is probably oil... tell us more.

Jun 02, 2010 | 1993 Jaguar XJ6

2 Answers

My speedometer is not working, what could be the problem, what needs to be done


May be the speedometer cable is broken or possibly a fuse.

Feb 16, 2010 | 1994 Isuzu Trooper

1 Answer

Speedo and Tacho illumination in my ford focus turnier dont work


you have to remove the instrument cluster/part of dash to reach them

Oct 06, 2009 | 2000 Ford Focus

1 Answer

Need to change out dash light bulb on a 1993


you will have to remove the dash panel around the cluster to get the cluster out. should be held in place with a couple of philips screws and some 7mm or 1/4in bolts remove these and the panel should pop loose will have to disconnect the switchs mounted in the panel. the speedo cluster is next and is bolted in place. you will probably have to work around the steering wheel and column. make sure to unplug speedo and if shift indicator on dash careful not to break it.

Aug 26, 2009 | 1993 Mercury Tracer

1 Answer

99 lancer,speedo tacho n gauge problem.


probably burnt or cracked circuit board on back of gauge cluster

Jun 21, 2009 | 2002 Mitsubishi Lancer

1 Answer

Jaguar xj6 1995... right indicator not working


check power supply from switch to light

Feb 20, 2009 | 1995 Jaguar XJ6

Not finding what you are looking for?
1994 Jaguar XJ6 Logo

Related Topics:

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jaguar Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

SPEEDY CAR WORK SHOP...

Level 2 Expert

489 Answers

Are you a Jaguar Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...