Question about 2003 Oldsmobile Alero

1 Answer

2003 alero coupe fan is not working at low speeds only works fine for high speed, what to do for low speeds, Pls. help me.

Posted by on

  • yamha25 Aug 02, 2010

    Thx

    I can hear the clicking sound - fan starts even at low speeds also but the air is not coming out of the vents.

    Same time when it's at low speed I opened the hood to make sure whether the fan is running or not and it was YES running.

    As per my sense fan is ok, trouble is only at low speeds - 1,2,3

    After 3 or high speeds no probs. air is coming out.

    Pls. let me know what you think

    Again thx.

  • yamha25 Aug 02, 2010

    Thx.

    Where I can find the BLOWER MOTOR RESISTOR OR THE AC & HEATER CONTROL SWITCH MODULE, pls. let me know and how to figure out ther are faulty.

    Again thx

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 14,036 Answers

PROBLEM IN THE BLOWER MOTOR RESISTOR OR THE AC & HEATER CONTROL SWITCH MODULE FAULTY.

Posted on Aug 02, 2010

  • Jonah Oneal Aug 02, 2010

    BLOWER MOTOR RESISTOR IS UNDER THE DASH NEXT TO BLOWER MOTOR ON THE PASSENGER SIDE.THE AC+ HEATER CONTROL SWITCH MODULE IS THE CONTROL SWITCH YOU TURN ON AND OFF AC + HEATER.YOU WILL BE WORKING CLOSE TO AIR BAGS.FIRST TURN OFF RADIO.THEN DISCONNECT NEGATIVE BATTERY CABLE FOR 20 MINUTES BEFORE WORKING ON DASH AREA ALLOW AIR BAG TO DISCHARGE.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Heater fan works only on high 2004 alero


this sounds like you will have to replace the blower motor resistor board to fix the problem.

Jul 14, 2014 | 2003 Oldsmobile Alero

1 Answer

2003 GMC Envoy Heater Fan doesn't always blow


Your problem most likely is the resistor block. In order to limit the fan speed a reistor is placed in the circuit which will limit current flow to the motor thus giving you the diferent speeds. High speed bypasse the resistor to get full motor speed. Since you only get high speed it is very likely that the resistor block is faulty

Oct 24, 2012 | 2003 GMC Envoy

1 Answer

2003 ford escape fans do not run in till the a/c is turned on.


There are four relays for the cooling fans .low speed control , medium speed , high speed fan control relay 2 , high speed fan control relay 1, there is also a engine cooling fan resistor .The engine coolant temp. sensor would most likely cause the check engine light to be on . There is also a dual pressure switch , this is for the A/C . The cooling fans will be turned on at 213 degress low speed , high speed at 226 degress . If you had factory scan tool or a professional type you could view coolant temp data in pcm , you could also energize the relays to see if the system is operating normally . There are other repair shops beside dealers

Mar 28, 2017 | 2003 Ford Escape

1 Answer

The ac/heat fan only works on the high speed


The blower resister located near the blower motor is bad,this is what controls the speeds,except the high setting.

Jul 16, 2010 | 2003 Oldsmobile Alero

1 Answer

2003 ford focus not putting out much cold air from ac


Make sure the fans are running when AC is on. The fans should run all the time and regulate from high to low speed. If it does not run on low speed the connector for the low speed resistor has burned out. It is located between the two cooling fans and has two wires. Mine was burned and I clipped the wires and replaced the connector with two heavy duty female spade connectors. Cost 4.99 . Ac works fine now. If all the fans are operating correctly and ac is cycling on and off it may be low on freon .

Jun 24, 2010 | 2003 Ford Focus

1 Answer

Cool fan low doesn't work. Doesn't appear to be


It needs to have the blower motor resistor card replaced.
It still works on high speed because on the high setting the voltage does not go through the resistor.
The resistor is mounted beside the blower motor and is easy to replace.
There you are, thank you for using FixYa.

KL

May 01, 2010 | 2003 Saturn VUE

3 Answers

F250 a/c not working at 60 mph. works fine at low speeds.


The belt could be loose.
The fan clutch could not be keeping up at high speeds to keep the system cool
I would have the cooling fan checked.

Jul 16, 2009 | 2003 Ford F250 Super Duty Crew Cab

1 Answer

I have a 1996 Cobra SVO SVT that the high speed


ok. so you know the fan is good. switch out the relay for that fan with another same relay and check with the a/c button.

Jun 26, 2009 | 1996 Ford Mustang

1 Answer

2002 olds ALERO fan switch


u will need to change the blower motor speed control resistor, it is located near the blower motor in the housing.

Mar 17, 2009 | 2002 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

935 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...