Question about 2005 Cadillac CTS

1 Answer

I have 122K+ on my CTS 3.6L w/ sputtering/acceleration problems

I have 122K+ on my CTS 3.6L. I have made a few change recently to better the performance, I thought…

This model requires removal of the upper intake manifold to change plugs or injectors. What a pain! Anyway, I installed E3 spark plugs and replaced the factory mufflers with Thrush turbo units. Shortly after this I started experiencing sputtering during acceleration at shift points. It seems to be just before it shifts. I need to put my foot into it for the sputtering to occur because slow city driving it is almost unnoticeable. Today, the problem (sputtering) is getting worse. It seems to occur sooner (mid-RPM) and continue longer. Gas mileage definitely decreased.

Since the “check engine” light does not come on I have not put the scanner on it. I have an Actron CP9180 scanner.

A few items that should be noted:
1) At about 100K miles I replaced the computer with a used one (but thoroughly tested by independent performance shop).
2) Shortly after replacing the mufflers (about 105K), the “check engine” light did come on. The fail code was P0420 and P0430. I assume that was due to muffler change. I reset the codes and light has never reappeared.
3) I am very hard on the vehicle. It is pushed 5 days a week 50 miles a day (to and from work) at high speed highway miles 80+.
4) Poor acceleration at any speed compared to performance at 100K.

I am just not sure of where to start. I don’t want to just start replacing everything. Thanks for your time and guidance in advance.

Posted by on

  • 1badcad Aug 01, 2010

    This engine has a coil for each plug. The ECM (most advanced in the industry) would have detected that. Vacuum and fuel pressure are fine. Sorry I didn't mention that.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 432 Answers

Sputtering/hesitating i would make a check on the coil and would also check for a vacuum leak. had the boss's wifes caddy doing the same thing, ended up being the intake boot had a split on the bottom side.

Posted on Aug 01, 2010

  • cjkelly025 Aug 01, 2010

    I know about the individual coils (even one can degrade) and even the most sophisticated computer can go bad, recommended the vacuum leak because even the smallest thing can do it. Try this, sit still in the car put it in drive and hold the brake very firmly with one foor and accelerate with the other will probably duplicate what its doing, pretty sure its a miss

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When I start my 1996 Honda accord the engine seems to sputter rpm gauge revs up on its own and spits and sputters as I'm driving down the road


My sputtering & stalling 1993 Honda Accord - YouTube

? 2:12
https://www.youtube.com/watch?v=Ki2H9aq8Xis
Jun 23, 2011 - Uploaded by mdpbfly
My sputtering & stalling 1993 Honda Accord ... 1996 Acura Integra, hesitation accelerating & misfire. ... 1993 Honda Accord Start Up and Review 2.2 L 4-Cylinder ... SIR B16A Engine sputter/ power loss at higher RPM - Duration: 1:14. by ... 1994 Honda Civic Check Engine Light Code Retrieval Tutorial ...

All comments on How To Solve Honda Idle Problems ...

https://www.youtube.com/all_comments?v=L788jKEVblY
What should I do if once I turn on my Ac my idle drops as if it's gonna die, and .... to a complete stop the rpms start going up and the car accelerates on its own. ... Honda Accord LX, and my Honda just started sputtering in idle. check engine .... My cousin replaced my radiator on my 90 civic and since then my temp gauge is ...

Acceleration Bog/Sputter/Hesitation - Honda-Tech

honda-tech.com/honda-accord.../acceleration-bog-sputter-hesitation-279...
Jun 11, 2010 - 1990 Honda Accord Ex F22 209000 miles, recent alternator change When I ... When I take off from a stoplight I get a little hesitation/bogging/sputteringfeeling until about 2,000 RPM then ... My 1999 Accord had a similar problem (F18B2engine). ... It only lasted a second or so before it would actually rev up.


Dec 28, 2015 | Honda Cars & Trucks

1 Answer

What to do with sputtering and lack of acceleration


Scan for codes stored ion the OBD computer. Many auto parts stores can do this for you at no charge. Based on the results - a complete tune up may be in order.

Good luck!

Apr 14, 2015 | 2002 Ford Taurus

1 Answer

Nissan sputtering engine


run fault codes as if there is a sensor malfunctioning then a code will be recorded

Dec 31, 2013 | 2004 Nissan Sentra

2 Answers

Cadillic 2003 cts won't start


Temperature sending unit could be sending erratic signal.

Nov 22, 2013 | 2003 Cadillac CTS

1 Answer

Fuel coming exhaust


I recently had a similar situation with my 04 Taurus
My engine light was on for a few mos... changed, plugs and wires it helped performance but didn't turn the light out still had acceleration issues... brought to mechanic becuase I thought it was the rear O2 sensors and he said his error codes led him to the intake manifold gasket / $300ish dollars later and she runs like a charm!

Hope this helps,
Christine

Nov 04, 2013 | 2004 Ford Taurus

1 Answer

1995 5.0 f150 missfireing sputtering down


i would try a major tune up first(plugs wires etc.)first if they are that old mileage wise.

Nov 22, 2012 | 1995 Ford F150 Styleside Regular Cab

1 Answer

2001 Buick Regal keeps stalling and running rough has white smoke coming out of tail pipe


The upper intake plenum is leaking coolant into the cylinder heads. The head gaskets on this motor are awesome. So, chances are it's the upper intake plenum. You can check this, by removing the vacuum hose that runs between the upper plenum and the brake booster. Stick your finger in and try to touch the top of the lower intake manifold. If your finger is wet it the upper plenum. You might as well replace the lower intake gasket while you're performing this work because they are prone to failure also. Use a shop vac to pull any coolant out of the cylinder heads. Get brand new spark plugs because the old ones are probably fouled. Once you get the plenum and gaskets replaced, remove your fuel pump relay and leave the spark plugs out and turn the engine over repeatedly for about 10 seconds to push any excess coolant out of the cylinder heads. Then, put the spark plugs in and turn the engine over for 10 seconds again. This will burn excess fuel as coolant out. Then, replace the fuel pump relay to allow fuel to be pumped into the heads. Car will smoke for a few when it fires up, but will clear out quickly. CHANGE THE OIL! Twice within a week if possible.

Jul 23, 2012 | 2001 Buick Regal

1 Answer

My Ford Focus SE sputters when I accelerate. I replaced my spark plugs recently( and not with cheap ones). At times, it doesn't want to accelerate fast then starts to sputter. Any ideas on what it...


what does "not with cheap ones" mean? what did you put in.? Did it run like this before the plugs were changed? If you put some Bosch Platinum plugs in from Autozone take them out and put in the plugs that FORD calls for. You may have created your own problem. are your plug wires good?

Sep 01, 2011 | 2000 Ford Focus

1 Answer

I recently had water and debris in my gas on my Toyota Camry 1996 2.2 4 cylander.I drained the gas tank,replaced the fuel filter,replaced spark plugs and had the injecters cleaned and it still has idel and...


Yes, sounds like some debris is getting collected at the strainer and probably clogging the fuel filter. I would change the filter first and then go from there. Maybe that would save you from dropping the fuel tank again.

Jun 11, 2011 | 1996 Toyota Camry

Not finding what you are looking for?
2005 Cadillac CTS Logo

1,600 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...