Question about 1991 Ford Ranger Supercab

Open Question

I have a 1991 ford ranger 3.0 automatic,i changed my plugs, wires, and cap. In doing so i knocked of a vacuum hose. This makes it idle very bad. So bad it will not idle without the gas. I can plug the vacuum valve (where the hose came off) and it idles better, but still sounds like a miss and wont shift gears very well, I have looked all over the engine and under and cant find the hose.

Posted by on

  • Jeff Turcotte
    Jeff Turcotte Aug 20, 2017

    Hi nevrcoolnky, I want to help you with your question, but I need more information from you. Can you please add details in the comment box? Can you post a picture of the port that is missing the hose? Most likely it goes to the transmission.

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 58 Answers

SOURCE: 95 ranger 2.3l spark knock problem

Is this a manual trans in this truck, if so, try shifting down a gear. But yes a timing belt could cause this, but usually they wont run very well if the timing belt is that bad worn.

Posted on Jul 05, 2009

Ad
  • 104 Answers

SOURCE: ford code 1443 problem

look for vacuum leaks in the system going from the purge valve all the way back to the fuel tank.

Posted on Sep 11, 2009

csmock132
  • 4669 Answers

SOURCE: A 1994 Ford Ranger, complete tuneup, new plugs,

Fuel injectors, sounds like on the bad

Posted on Mar 27, 2010

Testimonial: "thanks."

  • 233 Answers

SOURCE: 1989 FORD RANGER, 2.9L ENGINE WAS RUNNING ROUGH

low fuel pressure comes to my mind.

Posted on Jan 29, 2011

nighttrain_r
  • 444 Answers

SOURCE: engine missing on 1994 ford aerostar 3.0 v6

before throwing random parts at it do a compression check,

Posted on Mar 19, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Both coils do not fire on 1 and 4. Will start but only running on 2 cylinders. Could both coils be bad or should I look elsewhere?


Part 3 -How to Test the Ignition Module and Crank Sensor ...

easyautodiagnostics.com > Ford > 2.3L
Mar 1, 2012 - Spark plugs for cylinders #2 and #3 get spark at the exact same time. ...voltage -12 Volts) to both individual ignition coils within the coil pack. ... Ford Mustang or Ranger (or 2.3L Mazda B2300), this is what you'll need ... for this 'Switching Signal' at the coil pack... but you can also test this ... 1991, 1992, 1993.

How to Diagnose a Misfiring Cylinder (2.3L Ford Ranger ...

troubleshootmyvehicle.com > Ford > 2.3L
Apr 3, 2012 - Bad Fuel Injectors can cause a Misfire Condition. ... the ignition system on the 2.3L Ford Mustang or Ranger consists of 2 ignition coil packs, ...

2002 ranger misfire rough idle - Discussion on Topix

www.topix.com > Ford Ranger
Jul 27, 2007 - My truck is giving the code misfire in number 4 cyl. I replaced my spark plugs, Wires, Coil packs (both of them) and all my fuil ... three (3.0L v6) go bad, the fuel/air mixture gets messed up. Judged: 2. 2 ... My truck runs rough only at idle. ...code for ford ranger 2002, 2.3 5speed. truck runs like a champ but that ...

Extremely stumped! I need the best and brightest 1994 Ford ...

answers.edmunds.com > Edmunds Answers

Jan 31, 2016 | Cars & Trucks

1 Answer

2002 ford ranger starts cold. will idle fine but dies after i rev it up, then will not start again. replaced plugs, plug wires, and battery.


When the engine is idling, listen very carefully to with the hood open for something that sounds like rushing air. There might be a vacuum leak on the engine (all you need to do is make sure the vacuum hose is tight). This should be a rubber hose that plugs onto a hose barb or into a small hole in the engine. There is a piece call the pcv valve that you probably need to replace if you don't hear any air leaks.

Jun 09, 2011 | 2002 Ford Ranger Regular Cab

1 Answer

Why does my 2000 ranger have a rough idle?


Thanks for choosing FixYa and welcome to the site. There are a few different things that can cause this rough idle to occur. Check your vacuum hoses for leaks. You could have a clogged air filter or fuel filter. If you haven't had a tune up in a long time, try to get it done. Change your spark plugs/coils, wires, distributor cap, coil pack. Check for any loose hoses or wires on the engine also. You might want to check your pcv valve as well. Anyone of these can cause this to happen so check then all out.

Apr 19, 2011 | 2000 Ford Ranger SuperCab

1 Answer

Wont idle when i let the key go


There are several causes why vehicle will start, but not run or idle.
Here goes.
1 Vacuum hose leak, or simply fallen off. That one is good for idle dropping off to zero.
The Fix? Locate the Hose and re-install, or replace. If the hose if loose, cut the old end off so that there is fresh rubber at the connection. If it is rotted, just replace.

2. Need new spark plugs and wires, perhaps a distributor cap and rotor. You did ths. Good for you.

3 Weak Coil, though this is not common.

4 Ignition timing

5 Air filter badly clogged

6 Clogged fuel filter, replace

7 A piece of Italian Salami lodged in the wrong part of the engine.
Remove, but don't eat.
markfreedman_3.jpg


Have a Happy New Year !
Mark

Dec 31, 2010 | 1987 Ford Ranger

1 Answer

1991 302 runs like it is chocking out, I have changed the fuel filter, plugs wires rotor cap, and map censor, runs rough and worse when in gear, eating gas..help please? The truck is a 1991 f150 NITE 4x4


is it idling high and you put it i gear it runs rougher and smoke black check your coolant sensor also connection or sensor itself and fuel pressure if high check for return line blockage also vacuum leaks make sure you have the right vacuum going to your map sensor you need to check right vaccum at idle going to your map sensor/

Jan 19, 2010 | 1991 Ford F150

3 Answers

1991 Chevy C1500 intermittent problem. Failed smog.


dont replace you o2 sensor crimp off the hose going to the brake booster if the idle smooths out the booster is your vacuum leak so replace it.

Feb 28, 2009 | 1991 Chevrolet C1500

1 Answer

1991 ford ranger idles high about 2grand its a 6cly


  1. Check and/or Replace the IAC (Idle air control)
  2. Check TPS (Throtle Possition Sensor)
  3. Check for any other vacuum leaks old rubber hoses are bad to rot and let extra air flow into the intake.

Please rate this a fixya

Jan 31, 2009 | 1994 Ford Ranger Supercab

Not finding what you are looking for?
1991 Ford Ranger Supercab Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...