Question about 1993 Chevrolet Camaro

1 Answer

WONT START AND TRIES TO TURN OVER BUT BACK FIRES

TRIES TO TURN OVER BUT BACK FIRES AND STRONG ODOR OF GAS LT1 V8 motor

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 170 Answers

AWESOME a real camaro problem.
backfire.
strong odor of gas because the gas isn't getting burned
caused from backfire. backfiring because the spark isnt sparking when its supposed to.
problems could be bad spark plug wires , bad plugs , bad ignition parts.
your gonna need to check wires for bad spots, check ignition coils and stuff like that. if all that stuff is ok, then your problems have to do with inside the engine. jumped time etc.

Posted on Jul 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Toyota platz not starting first time


Sounds like the battery is not up to par, replace the battery with same or larger type

Feb 04, 2015 | Toyota Cars & Trucks

1 Answer

Why my 5.7 350 lt1 engine not getting any fire?


May be bad gas...but probably an ignition module or crank position sensor...you need a mechanical diagnosis...

Aug 08, 2014 | 1994 Cadillac Fleetwood

1 Answer

89 jeep wrangler 2.5 4 cylinder wont start. It turns over strong but wont catch even with starting fluid it just goes whir, whur, whir, etc. I have spark. thought it might be injector but it seems like it...


Check the ignition timing as it appears that the firing order is wrong. Make sure that the cam shaft is turning as it could be the belt broken

Mar 09, 2013 | Cars & Trucks

1 Answer

1994 camaro lt1 wont spark


No it is likely the OPTI SPARK distributor has failed, it is the Achilles heal of the LT1 V8. The distributor is located under the water pump on the front of the engine, if the water pump leaks it goes right into the distributor. To replace the distributor you must drain the cooling system and remove the water pump and all other obstructing parts to get to it. Before you replace any parts I suggest you have a trained technician run a scan of the system for fault codes, other things can cause this as well. The distributor is very expensive and i am only guessing based on my experience with my own 1996 Corvette LT1

Jun 29, 2012 | Chevrolet Camaro Cars & Trucks

1 Answer

2008 Ford Escape Hybrid Strong odor of gas in Pass. comp. No odor in engine Comp., Could not find any leaks fuel filter cnaister fuel lines. Odor is stronger on passager side. aired it out but still...


lift the back seat and their should be an access panel on the floor pan where you gain access to the fuel sender which houses the fuel pump and i suspect that their is a leak here on the pressure side ,now if your unsure about tackling this type of job please go straight to a local mechanic to have a look for you as the vehicle is dangerous in this condition and could catch fire and petrol vapour is more explosive than liquid petrol.

Jan 27, 2011 | Ford Escape Cars & Trucks

1 Answer

I have the 1994 Chevy Caprice police package with the LT1 5.7L V8. Whenever I start it, there's a strong smell of gas, and if you push the pedal down too far, it stalls. I can barely get it in and out of...


I believe your injector seals are dried out and leaking when cold and/or regulator problem. A friend's Vete did this befor e I did o-rings on injectors

Oct 04, 2010 | Chevrolet Caprice Cars & Trucks

1 Answer

1997 Ford Escort Runs Poorly, Smells like fuel, now won't start.


it could also be your map sensor .it on the fire wall .or on the air in take.your motor is running rich that why it smell like gas .

Mar 28, 2009 | 1997 Ford Escort

Not finding what you are looking for?
1993 Chevrolet Camaro Logo

442 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...