Question about 2002 Mercedes-Benz C-Class

Open Question

Rough engine idle

Have a c class c240 2002 engine has a rough idle it's getting worst, it's only when it's idleling, at normal speed engine seems to be running fine. Can someone advise? Thank you

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 2002 1500 rough idle wont go over 35 mph service engine soon

Have you O2 sensors checked out. I have blowen out 2 on the same bank, sounds like the same problem. Check engine light will stay on solid, blink for a while, solid. Surefire way to check is run your finger in the tailpipe after it is cooled down. If it is very black with soot, then it probably is the O2 sensor.

Posted on Mar 19, 2009

Ad
  • 65 Answers

SOURCE: 1997 ford explorer not idleling right at a stop

sounds like it could be either your throttle positioning sensor or even mass air flow sensor

Posted on Mar 23, 2009

  • 30 Answers

SOURCE: loosing power at cruising speed

have you had the transmission flushed? it seems to be caught in a limbo. where the calibration of the speedo and the transmission are not compatable. Now as wierd as that seems it happens usally like when going up a hill if you have a manual trans. and cruise locked in. it cant hold that speed and moves to a different speed if you dont down shift. Or perhaps your cruise control cable is slipping. is it vacume over mechanical? pop the hood and make sure all your hoses to cruise control are tight and no leaks.

Posted on Apr 04, 2009

heavymetal77
  • 721 Answers

SOURCE: mercedes c240 2001 low idle speed

Yes,check the fuel pressure & filter. There's about a million other things to cause this,so start simple. Ask again if this doesn't help.

Posted on Jun 21, 2009

  • 126 Answers

SOURCE: misses fires and sputters

1 Inspect Distributor Cap and Rotor Kit Loose, Cracked or Worn Distributor Cap. 1 Inspect Wireset Worn or Damaged Spark Plug Wires. 2 Inspect Distributor Cap Loose, Cracked or Worn Distributor Cap 1 Inspect Condensor-Ignition Faulty Condensor-Ignition. 1 Inspect Timing Specification Incorrect Ignition Timing. 1 Inspect Timing Specification Incorrect Ignition Timing. 2 Inspect Spark Plug Fouled, Damaged, or Broken Spark Plug(s). 3 Inspect Distributor Worn, Damaged or Faulty Distributor.

Posted on Sep 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 05 chevy malibu is not excelerating or shifting properly...


I would test both the tps and map sensors.
map sensor is here:

0996b43f802030b8-etlvqcyxjdbbokifzikh1c5u-5-0.gif

Testing

Check the Manifold Absolute Pressure (MAP) sensor circuit as follows:
Ignition OFF, disconnect the MAP harness connector at the MAP sensor.Ignition OFF, test for less than 5 ohms of resistance between the low reference circuit terminal 2 and ground.If greater than the specified range, test the low reference circuit for an open/high resistance. If the circuit tests normal, replace the ECM.Ignition ON, test for 4.8-5.2 volts between the 5-volt reference circuit terminal 1 and ground.If less than the specified range, test the 5-volt reference circuit for a short to ground or an open/high resistance. If the circuit tests normal, replace the ECM.If greater than the specified range, test the 5-volt reference circuit for a short to voltage. If the circuit tests normal, replace the ECM.Verify the scan tool MAP Sensor parameter is less than 1 kPa.If greater than the specified range, test the signal circuit terminal 3 for a short to voltage. If the circuit tests normal, replace the ECM.Install a 3A fused jumper wire between the signal circuit terminal 3 and the 5-volt reference circuit terminal 1. Verify the scan tool MAP Sensor parameter is greater than 126 kPa.If less than the specified range, test the signal circuit terminal 3 for a short to ground or an open/high resistance. If the circuit tests normal, replace the ECM.If all circuits test normal, test or replace the MAP sensor.

0996b43f802030bb-etlvqcyxjdbbokifzikh1c5u-5-2.gif


Check the Throttle Position (TP) sensor circuits as follows:
Ignition OFF, disconnect the harness connector at the throttle body.Ignition OFF for 90 seconds, test for less than 5 ohms of resistance between the low reference circuit terminal C and ground.If greater than 5 ohms, test the low reference circuit for an open/high resistance. If the circuit tests normal, replace the ECM. Ignition ON, test for 4.8-5.2 volts between 5-volt reference circuit terminal E and ground.If less than 4.8 volts, test 5-volt reference circuit for a short to ground or an open / high resistance. If the circuit tests normal, replace the ECM.If greater than 5.2 volts, test the 5-volt reference circuit for a short to voltage. If the circuit tests normal, replace the ECM. Verify the scan tool TP sensor 1 voltage is less than 0.1 volt.If greater than 0.1 volt, test the signal circuit terminal D for a short to voltage. If the circuit tests normal, replace the ECM. Verify the scan tool TP sensor 2 voltage is greater than 4.8 volts.If less than 4.8 volts, test the signal circuit for a short to ground. If the circuit tests normal, replace the ECM. Install a 3A fused jumper wire between the signal circuit terminal D and the 5-volt reference circuit terminal E of the TP sensor 1. Verify the TP sensor 1 voltage is greater than 4.8 volts.If less than 4.8 volts, test the TP sensor 1 signal circuit for a short to ground or an open/high resistance. If the circuit tests normal, replace the ECM. Install a 3A fused jumper wire between the signal circuit terminal F and the low reference circuit terminal C of the TP sensor 2. Verify that the TP sensor 2 voltage is less than 0.1 voltIf greater than 1.0 volt, test the TP sensor 2 signal circuit for a short to voltage or an open/high resistance. If the circuit tests normal, replace the ECM. Ignition OFF for 90 seconds, disconnect the harness connector at the ECM.Test for less than 5 ohms of resistance on all TP sensor circuits between the following terminals:ECM C2 signal circuit terminal 65 to TP terminal DECM C2 signal circuit terminal 63 to TP terminal FECM C2 5-volt reference circuit terminal 3 to terminal E If greater than 5 ohms, repair the affected circuit for open/high resistance.Test for infinite resistance between TP sensor 1 signal circuit terminal D and TP sensor signal circuit terminal F.If less than infinite resistance, repair the short between TP sensor 1 signal circuit and TP sensor 2 signal circuit. If all circuits test normal, replace the throttle body.

0996b43f802030be-etlvqcyxjdbbokifzikh1c5u-5-5.gif
Fig. Throttle Actuator Control electrical connector


Throttle Body Relearn Procedure
NOTE
Do NOT perform this procedure if DTCs are set.

Start and idle the engine in PARK for 3 minutes.With a scan tool, monitor desired and actual RPM.The ECM will start to learn the new idle cells and Desired RPM should start to decrease.Ignition OFF for 60 seconds.Start and idle the engine in PARK for 3 minutes.After the 3 minute run time the engine should be idling normal.
NOTE
During the drive cycle the check engine light may come on with idle speed DTCs. If idle speed codes are set, clear codes so the ECM can continue to learn.

If the engine idle speed has not been learned the vehicle will need to be driven at speeds above 70 km/h (44 mph) with several decelerations and extended idles.
After the drive cycle, the engine should be idling normally.

If the engine idle speed has not been learned, turn OFF the ignition for 60 seconds and repeat step 6.Once the engine speed has returned to normal, clear DTCs.

Jul 29, 2017 | 2005 Chevrolet Malibu

1 Answer

Car engine interment rough idle


Sounds like possible vacuum leak. Next time it starts try spraying starting fluid around vacuum hoses, if engine speeds up, there is a vacuum leak at that point where you sprayed. Hope this helps.

Jun 11, 2012 | 1995 GMC Safari

1 Answer

When idleing once in a while it starts running rough and shaking truck, 1998 k1500 350. no engine light. when i gige it gas it smooths right out. engine seems like its a little louder than normal.


Here is the common cause of surges, cold stalls, stalls at stops, slow idle speed, erratic idle speed, rough idle and engine hesitation (and other problems), it is in most cases the idle speed control air-bypass valve and or throttle valve and upper intake, these area's get full of gunk and combustion residue over the miles and cause idle issues (stalls, low idle) like yours.

To correct this problem Buy a can of throttle valve cleaner (it is made by CRC) from the local auto parts store, NEVER USE CARB CLEANING SPRAY, IT DESTROYS THE ANTI-STICK TEFLON COATING, spray it into the air intake through the throttle body of the engine until you have used about half the can, you will need to hold the idle up while you do this, it will try to stall, after this shut the engine down and disconnect the Negative (-) battery cable for 5 minutes. The intake is now clean, if you continue to have the idle speed control problems you may need to seek the help of a professional.

Feb 13, 2012 | 1998 Chevrolet K1500

1 Answer

Idleling is normal. When accelarating the car is slugish.when decelarating to stop at a low rpm engine dies. This only happens when you are stopping or driving from a high speed to low speed pr stopping


CHECK THE CONDITION OF YOUR FUEL FILTER, TRY REPLACING IT, ALSO CHECK THE CONDITION OF YOUR THROTTLE BODY ASSEMBLY AND YOUR IAC SENSOR (IDLE AIR CONTROL UNIT)

Jul 20, 2011 | Mazda 323 Cars & Trucks

1 Answer

Sitting in car in parking lot with engine running - it dies, won't turn over... I get a jump start No changes in termperature gages at all Idles rough, check engine light on, reduced engine power reading -...


Hi and welcome to FixYa!
It is safe to drive and I assume that you are on limp mode. This is to restrict the speed to avoid further damage to the engine. You can be facing some sensor issues like the MAF (mass air flow) sensor or TPS (throttle position sensor). If one of these sensor is faulty the car tends to run sluggish, run rough or may even result to stalling.

Have the sensors replaced and observe how it goes. This can fix the issue.

Hope this helps and thank you for using FixYa! Have a good one!

Feb 17, 2011 | 2003 GMC Yukon XL

1 Answer

My engine seems to be idleling erratically.. its fine throughout the speed range.. just when idleing.. any ideas? starts fine, no hesitation.. ? thanks


Sounds like the IAC, Idle Air Control. It's what controls the idle so when it has lack of control the idle will suffer. It's going to be bolted near the throttle and have a wire connection on it.

Feb 03, 2011 | 2001 Kia Sportage

1 Answer

Ford longreach with rough idle


a diagnostic computer check from your local ford dealer will sort that problem for you,the cost for that check should be around $50 and from then on whatever the problem wil cost you whatever your local dealer charges for labour or unless of course you are able to do it yourself which is cheaper in the long run,hope that helps,,goodluck.

Nov 26, 2008 | 2000 Ford Focus

2 Answers

Engine runs rough at certain speeds 3.0 v6 flex-fuel 1999 ranger


Check and see if the EGR valve is leaking, to check this spray water on it at idle, if the water steams off the valve is leaking and is the source of your problem, also are you sure you hooked the new DPFE sensor up right? re-check it..

Nov 23, 2008 | 1999 Ford Ranger SuperCab

1 Answer

1997 Integra Idles Rough


Does the car accelerate normally under heavy acceleration, or does it feel a bit lethargic?
Fuel economy?
Check engine lights?
Engine shaking at idle or other speeds?
Everything work on it (engine wise)?

Jul 08, 2008 | 1997 Acura Integra Type R

Not finding what you are looking for?
2002 Mercedes-Benz C-Class Logo

Related Topics:

331 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Marvin
Marvin

Level 3 Expert

81285 Answers

Joseph Prosser

Level 3 Expert

772 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...