Question about 1996 Toyota Tercel

2 Answers

Hello, I have a 96 tercel with a 4sp man. I recently replaced the speedo cable to fix a MIL on due to VSS code. The cable had been broken for some time. After in stalling the new cable I still have the VSS code, even after multiple battery disconnects etc. The Vss wire to the ECU pulses about .07 to 4.5 when I tested it. What have I missed?

Posted by on

  • j1il01 Jul 31, 2010

    The VSS on this car is in the speedo. I tested the wire to the ecm and it is around .07 to 4.5 v when I move the car. However, the ecm can't seem to see the sensor since it was not moving due to a broken speedo cable for so long a time. I guess I am wanting to know if the voltage range needs to be 0 to 5 v or if it never actually reads zero. Also could the speedo cable being disconnected so long have damaged the ecu? Scan tool resets and extended batt disconnects don't reset it, it comes back after about 100 miles or so every time Thanks for all the help

  • j1il01 Aug 01, 2010

    It was p500, last night I replaced the rear struts and the guy that helped me used a Snap-On scanner and it was showing a different code than the first and second earlier scans using a more generic scanner. His unit showed a catalyst efficiency low, which he reset and this morning the MIL came back on. I have not had a chance to scan again today. I was thinking I would use the generic code reader today and if it also showed catalyst that I would change the O2 sensor. Seem sensible?

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 432 Answers

You have to replace the speed sensor itself not just the cable to correct that problem, the cable doesnt do anything with the computer, try that sensor and youll be ok.

Posted on Jul 31, 2010

Testimonial: "Good idea, I think thats the route I will go.Thank you."

  • cjkelly025 Aug 01, 2010

    then it would sound like the ecm is not interpreting the signal correctly, if you had a guinea pig computer i would say try it. I had one of those a few years back and ran into that being the problem, its a few and far between. Tho in toyotas ive seen the only normal problems being a distributor or the ecms traditionally for errors.

  • cjkelly025 Aug 02, 2010

    sometimes, it is cheaper than a converter but not by too much if you get a universal converter the same inlet and outlet diameter that you need. I personally would change the o2 sensor first then if that didnt clear the code then i would suspect the converter.

×

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 170 Answers

Pull the ecm fuse and turn the ignition key to the on position for a few seconds ( DO NOT START the car ) then turn key off and replace the fuse. maybe that will help- batt disconnects dont always reset the ecm

Posted on Jul 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix the speedometer needle when it doesnt move from below zero?


no make or model or year so here is a guess
if it is a cable driven speedo --replace the inner cable
if it is an automatic ---replace the VSS on a later car or the sender unit on an earlier model

May 13, 2016 | Cars & Trucks

2 Answers

Does my 1996 honda accord have a vehicle speed sensor


most old cars have a speedo cable.
is the odometer dead too. (we need that answer now)

there are 3 class evolutionary systems.
cable
electric sender to cluster
and sender to PCM and PCM drives cluster.
but honda does this on diffr, dates than most cars. (i learned)

so lets do that. we login to alldata.com and look , so can you at any time,
once a month i do random cars.
what engine, sometimes this varies by engine, and trans.
neither stated so Ill toss coin each time.
a/t trans.
1996
has electronic (hall) speed sensor VSS and runs
engine, cruise. odometer and cluster.

the 96 has no speedo cable, and works in modern mode, very advance for this time
also any scan tool on earth fits the PCM scan port
and if VSS is dead, it tells you that with a DTC , vss dead.
saving all that work wondering why it dont work.
see/?
PCM must see it work
and cluster
and cruise
if only cluster fails, and both speedo and odometer then its bad.
if only speedo fails but not odometer , then speedo meter is bad.
its that easy.

Mar 25, 2015 | Honda Cars & Trucks

1 Answer

How to repair speedometer 95 sidekick


hey and oldie but goodie.
why not post the full symptoms. ????

Speedo dead, makes noise, bounces? what? stuck high? what?
odometer dead.
CEL glows running, the check engine light glows, running
and you insert the 1cent paper clip in the DLC connector and you get
code flashing. code 24, VSS dead?
http://www.fixkick.com/CEL/CEL.html

if yes, the cable has snapped. (fell off at either end)
if not VSS dead, then the speedo is dead
if both odometer and speed are dead and VSS are dead the
snapped cable, or cable fell off rear of speedo head.
if VSS is not bad. (no 24s)
and only speedo is dead but , odometer is good
then that means the actual speedo clock inside the head is bad.

to repair a dead speed/cluster, you replace the whole head
if real frisky then you do this.
suzuki even sells new clocks, but are very expensive
what i do is find a used head. and use that. (car-parts.com) or at fleabay.
sometimes i mix 3 heads to get one, good head.
that is all you can do, on old cars unless rich, and $200 head is pocket change.

http://www.fixkick.com/sensors/speedo/unsafe-at-any-speed.html


tell more get more, ask.

Oct 18, 2014 | 1995 Suzuki Sidekick

1 Answer

Speed odometer


LSI 4cylinder or 3cylinder? engine. , all answer USA cars.
all answers now, are 3cylinder

did the odometer quiet too?
key fact
and in USA< connect any scan tool and see if VSS died.

the usa 96, 1.0L 3cyl has the VSS sensor in the speedo
and when the cable snaps, Speedo to transaxle flex drive cable.
snamps
the speed goes dead
the odometer goes dead
and Vss goes dead.
easy huh, if all 3 are dead.
but if speedo ONLY goes dead, that means ITS dead.
vss= veh.speed sensor. or MPH sensor.

Feb 26, 2014 | 1996 Geo Metro

2 Answers

Speedometer not working


the vss runs off a gear in your transmission.

a70e41a9-9601-4aca-9dcf-8e3f0081dfde.jpg

Dec 09, 2013 | Cars & Trucks

1 Answer

95 buick regal custom speedo issues


There is a gear that drives the sensor gear much like the old speedo cable gear.
If you connected the sensor and the check engine light went off, chances are the sensor is working.

Jul 04, 2013 | Cars & Trucks

1 Answer

How to fix a speedometer cable


Well you know it does not have a speedo cable since you replaced the speed sensor in the transmission.
My guess would be a problem with the speedo or cluster.

Jan 09, 2013 | 2004 Oldsmobile Silhouette

3 Answers

Speedometer and odometer dont work on ford f-250 1992 7.5 lt 2 wheel drive


INSPECT YOUR SPEEDO CABLE, IS IT BROKEN?????, IF NOT THEN IT'S YOUR SPEEDO HEAD BROKEN....IF YOURS IS ELECTRONIC THEN CHECK THE SENSOR AT THE TRANS "VSS" SENSOR...WITH OUT TEST EQUIP. JUST REPLACE IT AND RETEST.....gl

Jul 10, 2009 | 1992 Ford F250

2 Answers

2002 Nissan Quest speedometer not working


it is likely the VSS, vehicle speed sensor on the top rear of the trans. one 10 mm bolt, but often the VSS won't come out due to corrosion. spray with penetrating oil.

The VSS sends a signal to the speedo cluster. Cluster converts signal and sends it to speedo and odometer and also to engine computer.

If your cruise control also does not work, it is VSS.

Try prying back and forth at base after soaking.

May 06, 2009 | 2002 Nissan Quest

Not finding what you are looking for?
1996 Toyota Tercel Logo

225 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...