Question about 2001 Mitsubishi Eclipse

1 Answer

I have a 2003 Spyder 4 - cyl. that has the turn signals stopped working. Is there a usual problem with these? I can here a sound from the 12.5 volt distribution box under the dash. All the fuses are good. What do I do ?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,340 Answers

Sounds like the blinker switch itself.You can try asking a dealer where it is.They will most likely tell you for free.If they don't call a couple of mechanic shops.Someone will tell you for free.Many are under the hood.No hazards too probably?It's the switch that makes that click click switch when it is working and you turn on your signals.

Posted on Jul 30, 2010

Testimonial: "Yup, I thought of that too! It is all Japanese to me."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Mazda mpv right side flasher doesn't work but left side does


Have you tried replacing the light bulbs? When a bulb goes bad, the turn signal for that side will usually blink twice as fast as it should. If the bulbs are known to be good, you may want to take a multimeter and test your bulb sockets to be sure you're getting about 12 volts.

Oct 01, 2014 | Cars & Trucks

1 Answer

Turn signal not working


TAIL LIGHT NOT WORKING

It can be faulty tail light bulb or its issue with tail light control switch or its wiring's are short.

Check the voltage at fuse slot of tail light.Do you receive 12 volt there.If not,then it says tail light switch is not receiving power supply.


---------

There are few help links related to your problem.I suggest you refer the list and check the help links.Click the link below:-----




Turn Signal Not working

http://technoanswers.blogspot.com/2012/11/turn-signal-not-working.html

----------

Right turn signal not working on Pontiac Car?

http://schematicsdiagram.blogspot.com/2011/12/right-turn-signal-not-working-on.html

--------

Only one side indicator light working on car?

http://schematicsdiagram.blogspot.com/2011/12/only-one-side-indicator-light-working.html

-----------

Turn signals not working on 1987 Jeep Wagoneer?

http://schematicsdiagram.blogspot.com/2011/12/turn-signals-not-working-on-1987-jeep.html

-----------

SOLVE YOUR 4 WAY FLASHER RELATED PROBLEMS HERE

http://repairhelpcenter.blogspot.com/2012/11/4-way-flasherturn-signal-flashersignal.html

----------

1994 Toyota Camry: Bypass Tail light Relay Circuit?

http://whatisbyme.blogspot.in/2012/04/1994-toyota-camry-bypass-tail-light.html

-----------

2008 Toyota RAV4: Replace Tail light Lens Cover?


http://technoanswers.blogspot.in/2012/04/2008-toyota-rav4-replace-tail-light.html

--------

2003 Chevrolet S10 Tail light Fuse

http://schematicsdiagram.blogspot.com/2012/11/2003-chevrolet-s10-tail-light-fuse.html

---------

Chevrolet Parking light and Tail lamp light Wiring diagram

http://schematicsdiagram.blogspot.com/2012/11/chevrolet-parking-light-and-tail-lamp.html

----------

Car Tail Lights Not Working?

http://schematicsdiagram.blogspot.com/2011/12/car-tail-lights-not-working.html

----------

These details will help.

Thanks.

Feb 15, 2013 | 2004 Pontiac Grand Am

1 Answer

The tail lights do not work. The headlights, blinkers, and brake lights work. I checked the fuses and they are all good.


It can be faulty tail light bulb or its issue with tail light control switch or its wiring's are short.

Check the voltage at fuse slot of tail light.Do you receive 12 volt there.If not,then it says tail light switch is not receiving power supply.


---------
There are few help links related to your problem.I suggest you refer the list and check the help links.Click the link below:-----
1994 Toyota Camry: Bypass Tail light Relay Circuit? http://whatisbyme.blogspot.in/2012/04/1994-toyota-camry-bypass-tail-light.html

-----------
2008 Toyota RAV4: Replace Tail light Lens Cover?


http://technoanswers.blogspot.in/2012/04/2008-toyota-rav4-replace-tail-light.html
--------
2003 Chevrolet S10 Tail light Fuse http://schematicsdiagram.blogspot.com/2012/11/2003-chevrolet-s10-tail-light-fuse.html
--------- Chevrolet Parking light and Tail lamp light Wiring diagram http://schematicsdiagram.blogspot.com/2012/11/chevrolet-parking-light-and-tail-lamp.html
---------- Car Tail Lights Not Working?

http://schematicsdiagram.blogspot.com/2011/12/car-tail-lights-not-working.html

----------
Turn Signal Not working http://technoanswers.blogspot.com/2012/11/turn-signal-not-working.html
---------- Right turn signal not working on Pontiac Car?

http://schematicsdiagram.blogspot.com/2011/12/right-turn-signal-not-working-on.html

--------
Only one side indicator light working on car?

http://schematicsdiagram.blogspot.com/2011/12/only-one-side-indicator-light-working.html

-----------
Turn signals not working on 1987 Jeep Wagoneer? http://schematicsdiagram.blogspot.com/2011/12/turn-signals-not-working-on-1987-jeep.html

-----------

SOLVE YOUR 4 WAY FLASHER RELATED PROBLEMS HERE
http://repairhelpcenter.blogspot.com/2012/11/4-way-flasherturn-signal-flashersignal.html

----------
Thesedetails will help.
Thanks.

Nov 23, 2012 | Cars & Trucks

1 Answer

2003 eclipse driver window frozen up good power to switch moter dead


Hello! Set your meter to read 12 volts...Pry the up/down switch out...Turn on key...Test for +12 volts on the Yellow wire on the switch...Send a comment...

Guru..............Saailer

Oct 25, 2011 | 2003 Mitsubishi Eclipse Spyder

1 Answer

The horn on my 2003 Mitsubishi spyder has stopped blowing. I suspect an electrical problem as, recently, one or both of the horns would work PART of the time. Is this common?


Horns are pretty simple in their operation. I would more suspect a horn relay. I am not very familiar with your vehicle, but usually due to the electrical current used in the horn circuit, most manufacturers run the circuit through a relay. An easy way to eliminate your horn is to simply run a wire directly from your battery and touch on the horn contacts. The horn should sound when you touch the wires onto the horn terminals. Hope this helps.

Dec 16, 2010 | 2003 Mitsubishi Eclipse Spyder

2 Answers

My 2002 alero has 65,000 miles and ran great until I was in an accident a few days ago. I tried to start it and it wouldn't start. The check engine light came on and the low track light too. After a few...


Sounds like the Crankshaft sensor is damaged and needs to be replaced.
The Camshaft position sensor works along with the Crankshaft position sensor.
Determining the timing and injectors’ pulse, to deliver fuel to the cylinders.
The Camshaft position sensor is a hall sensor, which it triggered by a magnet in the Camshaft.

On 4 cyl(2.4) models the Camshaft position sensor is located to the left side of the timing cover.
On the V6(3.1 & 3.4) it’s located at the front of the engine block (passenger side), below the power steering pump.
Check the terminals for breaks and looseness, repair if needed.

Here is the plug indentification picture.
The wires are different for the 4cyl and V6, Please note below.
Though the plugs are the same three wire connectors.

Plug is as listed : 1 - Camshaft position sensor signal on 4 cyl,
12 volt supply on the V6
2 – Sensor ground 4 cylinder,
Camshaft position sensor signal on the V6
3 – 12 volt supply on the 4 cylinder,
sensor ground on the V6

First check for voltage and ground circuits from the PCM.
Disconnect the electrical connector from the Camshaft sensor and connect the positive lead (on the wiring harness) of the voltmeter to the red wire(#3) on the 4 cyl and the red/white wire on the V6(#1).

Connect the negative to the pink/black wire on the 4 cyl(#2), or black on the V6(#3).
Turn the key on, the voltmeter should read 12 volts, if not check the wiring to the PCM.
If the circuits are good, have the PCM checked out by a Dealer or other properly trained shop.

To check the operations;
Reconnect the Camshaft position sensor, using a probe to back probe the brown/white wire terminal of the camshaft PS. Plug locations on4 cyl (#1) and theV6(#2)
Connect the positive lead of the voltmeter to the probe and the negative to a good engine ground.
Turn the key on, the voltmeter should read approx 10 volts.

*Rotating the engine by hand with a breaker bar attached to the crank pulley. Watching the voltmeter, the voltage should remain a steady 10volts then quickly drop to zero and back to 10vlts as the magnet passes the sensor.
If the tests results are incorrect then replace the camshaft position sensor.

* Rotating the engine slowly, and at least two full revolutions of the engine for accurate results.


Camshaft sensor Replacement

On the 4 cylinder
- Disconnect the electrical connector
- Remove the camshaft position sensor-mounting bolt and pull the sensor out of the camshaft cover.
- Replace the “O” ring and lightly lubricate it with clean engine oil.
- Install in the reverse of those procedures.

On V6
- Remover the drive belt.
- Remove the power steering unit but don’t disconnect the hoses, just lay it aside.
- Disconnect the electrical connector from the harness; paying attention to the route the wires are in.
- Remove the camshaft ps mounting bolt and pull the sensor out of the block.
- Install in reverse procedure.

If the sensor flange breaks off and you cant remove the CPS, try screwing a heavy screw into the top of the sensor and pulling it out with plyers/vise-grips.

Good luck and thank you for using Fixya

Mar 10, 2010 | 2002 Oldsmobile Alero

1 Answer

The turn signals on my 04 eclipse spyder Stopped!


There is a relay for your turn signals at the fuse block in the engine compartment,the wipers are on another circuit, if all the other wiper positions work,you got a bad switch

Dec 15, 2009 | 1998 Mitsubishi Eclipse

2 Answers

97 honda accord turn signal problem


Flasher unit is bad. Replace flasher

Dec 28, 2008 | 1997 Honda Accord

Not finding what you are looking for?
2001 Mitsubishi Eclipse Logo

136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8572 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...