Question about 2002 Ford Expedition

1 Answer

HELP! PLEASE FAST

Hey umm my 2002 Expedition Eddie Edition Is Working fine but 1 problem my rear subwoofer wont work... is it a fuse or something if so were is the fuse box for the subwoofer and 1 more thing can someone please like give me blueprints or something about the STOCK SOUND SYSTEM! and Thank You

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

You can disconnect the sub from the car and test it to see if its blown by hooking it up to a regular house stereo. depending on what type of sub u have not all of them have protective fuses to shut it down before it blows. i always reccomend having more wattage on your speakers than your amp to add as a failsafe.

Posted on Jul 29, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Why is rear stock subwoofer not working?


I need to have more info about how you installed it, did you use rca wires from the radio to the amp.? Make sure the sub setting on radio is turned on. Make sure rca wire are in the input connection and not output, also check you connection from radio that they're in rite place. I really need more info about the map of your wireing

May 10, 2014 | 1998 Ford Expedition

1 Answer

My horn stoped working, when I press the horn I only hear a click.


There was a recall done on those vehicles in 2008 for the same issues. Something about a clock spring. If the recall work has not been done on your SUV, bring it to a dealer.

Apr 12, 2014 | 1999 Ford Expedition

2 Answers

I Have a 1999 Ford Expedition(Eddie Bauer) and I cannot find out why The Rear Suspension Air bags wont inflate. The bags don't have any Leaks, I'm assuming the compressor is working because the front of...


I believe it has to b reset / retrained by dealer or mechanic who has ability to read what the vehicle is or isn't doing. If you don't hear the compressor running constantly, you most likely don't have a leak, basically it'll run long enough to level up the vehicle and you shouldn't hear it again. try and dissconnect the battery, for a minute or so try it again.

Oct 12, 2010 | 1999 Ford Expedition

1 Answer

I need to know what fuse that powers the fuel pump in my 1999 ford expedition it has a 5.4 va 4 wheel drive


OK, there are fuses on the driver's side down below.

But, if you are having a fuel pump problem, it's likely that the fuse is alright and you need to replace the fuel pump. Same thing happened to our 1999 Ford Expedition Eddie Bauer Edition. It quit working. And the inertia fuel cutoff switch didn't help, either (flipping or pushing it).

So, if you have no fuel coming, it may very well be the fuel pump.

We changed ours around 112000mi.

Jul 17, 2010 | 1999 Ford Expedition

2 Answers

1998 Ford Expedition Eddie Bauer SERVICE ENGINE SOON light


Take the vehicle to any local auto parts store that will read the codes. WRITE THEM DOWN, and report back here for further help.

Dec 21, 2009 | 1998 Ford Expedition

1 Answer

Front A/C won't blow, rear works fine. 2002 Expedition


Check the fuses for the blower motor and check power to the front switch to the blower.

Jul 20, 2009 | 2001 Ford Expedition

1 Answer

I have a 2001 Ford Expedition Eddie Bauer rear AMP doesnt work?


there should be fuses near your amp and near the battery

Jan 07, 2009 | 2001 Ford Expedition

1 Answer

98' Ford Expedition radio, cd wont work! no message or anything


There could be a fuse you are missing. I don't know your model well enough to say, but some have a separate fuse under the dash.

Jul 12, 2017 | 2002 Ford Expedition

1 Answer

2001 expedition sub not working


there is an inline fuse running to the sub try locating it and replacing it it also may have cam out of its socket.

Dec 18, 2008 | 2001 Ford Expedition

Not finding what you are looking for?
2002 Ford Expedition Logo

433 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5522 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...