Question about 1999 Mercury Villager

1 Answer

I have an 99 mercury villager and the ''engine fan'' won't come on I took the connectoroff and wired it directly to the battery and it does work, So is it a blown fuse or some sensor and If so where is located?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers

You have one low speed relay and 2 high speed relays in the battery box under the hood. Check them first.
Could be the ECT Sesnor, engine coolant temp sensor. Does it come on when you turn a/c on?

Go here for team help

http://groups.yahoo.com/group/villagerquest/

Posted on Jul 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix my Mercury Villager 2002 with random misfire?


How to Fix error code P0300 for random misfires on your car ...

diy-auto-repair.wonderhowto.com/.../fix-error-code-p0300-for-random-...
Oct 15, 2010 - How to Fix error code P0300 for random misfires on your car ... amisfire (code P0304) on a 1999 Mercury Villager 3.3L · How to Fix error code P0500 ... I reset my codes and it ran fine for a couple of days, then I started getting ...

(code P0305) on a 1999 Mercury Villager 3.3L - auto repair

diy-auto-repair.wonderhowto.com/.../troubleshoot-misfire-code-p0305-1...
Sep 7, 2010 - The vehicle is a '99 Mercury Village, 3.3L, with 150000 miles on it. The chief ... How to Fix error code P0300 for random misfires on your car ...

2000 Villager Misfire - Car Forums and Automotive Chat ...

www.automotiveforums.com > ... > Mercury > Villager
May 24, 2010 - 2000 Villager Misfire Villager Car Forums. ... i was told that the 3.3L engines of 1999-2002 nissan quests/ mercury villagers are INTERFERENCE engines! ... Hope the following may help, and I will post if my last fix works. ... I have a 1999mercury villager that is showing a random multiple cylinder misfire ...

Rough Idle - 2000 Mercury Villager - RepairPal

repairpal.com > Questions > Mercury > Villager > 2000 Mercury Villager
Repair the code issue, because your Villager has OBD-II which is a very helpful Diagnostic system. Upvote (4) ... My 1999 Villager was running poorly; rough idle, lack of power at highway speeds and the engine problem light indicated random miss-fire, etc. I had new spark ... Have code po306 cylinder 6 misfire detected.

P0301 - OBD-II Trouble Code - RepairPal


Dec 17, 2015 | 2002 Mercury Villager

1 Answer

I have a 1996 mercury villager that's over


1) low water in the overflow canister. always add water/antifreeze there not directly in the radiator. 2) does the fan at the radiator turn or is running when engine is warmed up?
3) if so then check you belts on your engine? are you missing any?
4) could be bad water pump. do you or have you seen small drops of water coming from the engine area other than the radiator? and other than the A/C unit when car is turned off?
5) when checking fan/s you most like have two fans. One for normal and two come on if you are using air conditioner. make sure both fans are working with A/C on. That should do it.

Jul 10, 2012 | Cars & Trucks

1 Answer

How to remove the dashboard on a 2001 mercury villager minivan?


go to villager quest yahoo group for help.

gerry

I have manuals for sale for $20 plus $5 postage, shop manual plu wiring book.

99-02 essentially the same. villager & quest identical vans.

Jul 31, 2011 | 2001 Mercury Villager

1 Answer

We recently replaced the engine in my 1999 Mercury Village minivan. Now the wipers won't work when the engine is on Where is the wiper relay located or what could be the problem>?


The wiper governor is in the enigne comaprtment, driver side. You probably have a bad ground in the engine compartment casuing this issue from the engine swap.

Jul 07, 2011 | 1999 Mercury Villager

1 Answer

1999 mercury villager sputtering real bad it started after we did a tune up cap rotor and wires, plugs. the van ran fine around town on short drives then we took a trip and now where stuck 16 hrs later it...


You have a bad cam sesnor in the distributor- for certain. Rich Porter on ebay has the best reman for $200. Guaranteed fix. 99 was famous for this, runs cold for 15 mintues then acts up and quits, tach usually jumps around too.

Go here

http://groups.yahoo.com/group/villagerquest/

Dec 19, 2010 | 1999 Mercury Villager

1 Answer

93 villager runs good, but temp. gauge runs up to the hot line, but never runs hot. is the a colling fan that should go on.


the cooling fan should come on low speed and then high speed as it gets hotter.

The fan should come on anytime the a/c clutch engages, even cold engine.
3 cooling fan realys in battery box in front of battery. controlled by signal from engine coolant sensor. siganl from engine computer.

go here too

http://groups.yahoo.com/group/villagerquest/

Jun 22, 2010 | 1993 Mercury Villager

1 Answer

1997 Mercury villager, Air conditioner was working, now compressor kicks on and off, shows over charge in the red, why? Nobody added any freon.


high pressure is usually from heat not being removed from freon in the condensor. Usually it's because the cooling fan is not sucking air through the condensor. Check your cooling fan relays (3) in the battery box in front of the battery. Also, check to see if cooling fan has failed.
Does it work ok when the engine is cold and then quit after engine warm up? That would be a clue. When pressure gets too high, there is a high pressure cut-off switch.

Other posibility is a restrcition in the system. not common though.

go here for more help

http://groups.yahoo.com/group/villagerquest/

Aug 04, 2009 | 1997 Mercury Villager

1 Answer

1998 mercury villger fuel pump and cooling fan wont work


these are separate problems. You have a black fuse and relay box under the hood by the battery. There are 3 cooling fan relays in that box. 1 for low speed fan, 2 for high speed fan. You also have a fuel pump relay there.
First I would check and clean the positive battery post connection. It has 2 smaller wires that go to all the accessories. The big one is for the starter. I probably would buy a new termianl end and replace it.

Also, go here for our Villager Quest forum. files & photos to help you fix you van.

http://autos.groups.yahoo.com/group/villagerquest/


good luck. please rate as fixya if this solves your probelm.

Mar 08, 2009 | 1998 Mercury Villager

Not finding what you are looking for?
1999 Mercury Villager Logo

Related Topics:

214 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

fordexpert

Level 3 Expert

5516 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...