Question about Mercedes-Benz M-Class

Open Question

Glow plug on my MB100 is not lighting up. IT comes on after it is started up and runs rough..

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 265 Answers

SOURCE: 2.8l rd28t ohc 6cyl patrol

if only 3 plugs heat, probabilly one of the two pre-heat relays is defective ( or it's command ).
The relays are located left in the engin compartment, just in front of the battery and in the battery box. They should have green connectors.
If there is no fault found at the relays, but on their 'command', the pre-heat control box is located IN te vehicle under the steering column. ( Black plastic box with 4 screws, and a 16 or 20 position connector for engines with EGR )

Hope this explanation helps

Fabrice from belgium

Posted on Apr 02, 2009

Ad
ghost4548
  • 776 Answers

SOURCE: glow plug light flashes after can has been running

obviously there's a problem with the system... your best SOLUTION is take it in for proper DIAGNOSIS.. ya think?

Posted on May 26, 2009

  • 318 Answers

SOURCE: runs rough

Those tubes actually screw out. You could try unscrewing the tube and resealing it with your favorite sealer and it just may stop the oil leak.

Posted on Jul 15, 2009

Lloyd Six
  • 560 Answers

SOURCE: glow plug light wont come on on my fiat scudo but

Bulb or relay fault.

Posted on Nov 19, 2009

  • 1 Answer

SOURCE: had problems with vw caddy van starting when warm,...

2004 vw 2000sdi caddy van wont start some mornings you need to wind it over before it fires, immediately after it fires you can switch off ignition and it will start first time and continue to start all day. vw dealer says no fault codes present. gloplugs renewed, new battery,fuel problem? Has anyone come accross similar problem I

Posted on Aug 05, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 2004 (Land cruiser) PRADO 3000 Turbo Diesel 5sp- have issues starting when it's cold? It turns over and over does nothing, then when it starts, I get a big plume of smoke, then it idles rough...


glow plugs are activated if look on the dash when you turn the ignition just before cranking and you should see a light that stays on for several seconds then goes out and then you should crank the engine ! sometimes when its really cold or the glow plugs are worn try turning the ignition on and off each time light goes out 2 or 3 times to get more heat on the plugs then start ! if this doesnt work then glow plus and system needs checking !

Sep 02, 2014 | Cars & Trucks

1 Answer

6.0 2004 F-250 was starting hard when cold, replaced glow plugs &harness still starts hard runs rough, glow plug light stays on longer now though


time for replacement of or severe cleaning with fuelinjection cleaner..also if diesel, add cold start to the fuel system..check and replace oil filter type fuel filter since jelling of fuel may be a cold start issue..crack open an injector line and see if injector pump is pushing fuel really well..and see if air cleaner needs replaced blackened element is not good..good luck..

Jan 19, 2013 | 2004 Ford F250

1 Answer

Having cold start problems 2006 h.d. f350 ,truck is parked in heated garage all night,starts normal in the a.m.,sits outside all day at work,soon as temp falls below 30 F it starts then stalls immediately...


glow pug indicator and glow plug themself are 2 seperate system
test for power at the glow plug harness conector 1 each side over valve cover
test light clamp on batery neg test each wire going to relay for power on both side
then quick check on glow plug end test light clamp on positive test all wires
going to glow pug on each side f this does ligtht up the test light system should be o.k.
for the FICM i have used a hair blower on hi to warm the surface of if to start up a few of
these motors to get them back to the yard for replacment afterward
run a ffeet of these from 250 to 550 lots of problem and work 26 units
good luck

Feb 25, 2011 | 2006 Ford F 350 Super Duty

1 Answer

This is a diesel 87. I turn the key over to glow pug position and get no light. I have a block htr and the car starts anyway when I go to ignition. Today same situation but in the gnition position I get...


Glow plug light indicates if the system is working as designed too. If you have one or two glow plugs out it will start but idle rough at first.

If the glows do not come on, engine will not start or do so after extended cranking and idle rough if temperature below 50F.

If glow lamp not coming on, the 80 amp fuse may be blown. There is a black box on the left inner fender just back from the headlamp. . Under the cover is a thick fuse held by two Phillip head screws.( IIRC.)

If the engine will not crank, try moving the shifter lever back and forward while you turn ignition to crank. If still no crank, it is often the electrical switch under the ignition switch burnt.

Are the other cluster warning lamps, Oil, Battery, Brake, etc coming on when you turn on the ignition.?

Jan 19, 2011 | Mercedes-Benz 300-Class Cars & Trucks

2 Answers

I have f-250 diesel. keeps blowing fuse #22,glow plug controller. what might be the problem


You should start with the glow plug relay/timer.Check it to see if may be shorted.Remove the smaller wires going to it and turn the key back on,if the fuse does'nt blow then replace it,if it does then you need to unplug the fuel preheater in the filter housing and try the key on thing again,pretty sure it's one or the other.

Dec 08, 2009 | 1995 Ford F250

1 Answer

Hard starting diesel, at approxamately anytime temp gets below 45 degrees F. runs rough when started, smokes, then once warmed up no problem. Has quit on me twice in traffic.


only 2 things can maake a diesel run rough at start up ,,1--- air in the system 2----- 1 or more of the glow plugs not working. this sounds like the latter ,if you have a couple of glow plugs not working ,it will miss on those cylinders until it warms up ,and the smoke is mostll exesive fuel when it does fire . recommend you check the glow plugs

Oct 11, 2009 | 2001 Ford F350 Super Duty SuperCab

1 Answer

2001 Jetta Tdi runs rough


Hi Whitneyford
Your priblem sounds more like the glow plug timer relay than the exhaust. White smoke after start up is a sign of diesel entering the exhaust before it has burned completly. This is as a result of the glow plugs switching off too early, which is usually caused by one or more faulty glow plugs or a faulty timer.With engine COLD, IGNITION ON... Check voltage with all 4 plugs connected. You should have a reading of 10--12 volts
If there is no power, check in-line fuse on loom coming to plugs.
If power is present, check for How Long. If only for a few seconds, the problem is with the timer. This unit (the larger of the relays and usually black in colour) is fitted on the fuse board, and there are a few different types. They come in 7 pin..8 pin..and even 9 pin units.
The glow plug light is often NOT accurate (even with a new timer unit fitted) as to the time of heating, and you will almost certainly find that power will flow to the plugs for quiet some time after the light goes out. This is not unusuall with The Jetta Tdi.
Good luck.
I hope this helps you sort out this problem
John

Aug 18, 2009 | 2001 Volkswagen Jetta TDI

1 Answer

Wont start sometimes, rough idle.


Sounds like a bad ignition switch. If your car has a lot of miles (200k miles is pretty common), then it's likely.

Once something breaks loose in the ignition switch, well basically you got lil pieces of metal floating around making contact where they shouldn't, which create the scenerios you're talking about.

The glow plug light may or may not be related. But you won't know til you get that first problem fixed.

If the rough idle eventually smooths up after it warms up, then yes, you probably need to look at the glow plugs and/or glow plug relay.

Jan 27, 2009 | 1984 Mercedes-Benz Mercedes Benz 300 Class

1 Answer

Diesel Wait light does not come on, starts rough and thermostat pegs out.


either you have loose connections to the glow plugs or the fuseable link to the glow plugs is bad check this out and i'm sure your problem will stop. please rate the solution..thanks

Sep 21, 2008 | 1991 Ford F350

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

243 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...