Question about 2000 Saturn SL

2 Answers

My car is back firing when I try to crank it.When I try to drive it, it has no power.You can't even get it up to speed. It acts like it's not getting any gas.

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,092 Answers

Coil be ignition break down, possible coil packs, wire or boots to spark plugs, or ignition timing.

Posted on Jul 22, 2010

  • Hope Tabonia Jul 02, 2013

    i recently bought a 95 sl2. started fine when i bought it despite sitting for 5 years. then started backfiring when i cranked it... todayi found out that on the coil packs. under the plug wires. it was corroded. i cleaned em off and havent had the problem again.. so make sure you clean them posts on the coil pack or replace sparkplug wires.

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,044 Answers

With it backfiring you need to look at the timing. If you can't adjust the timing because it is totally electronic then you will have to replace the timing belt.

Posted on Jul 22, 2010

  • Hope Tabonia Jul 02, 2013

    check coil packs posts for corrosion under spark plug wires and on end where the plugs are. mine were really bad and i cleaned em off. and its good to go now

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 Toyota t100 stalls after driving a while try starting it it wont even fire ya let it sit for acouple hrs and it will start back up


Could be a cam sensor, crank sensor, ECM, fuel pump or coil module. All of these will act as you described. You will need a scanner to probably be able to locate and fix problem. The OBD2 generic software probably wont be much help, youll need the factory software to be able to track it down.

I’m happy to help further over the phone at https://www.6ya.com/expert/david_c087e4b7d13c0163

Oct 27, 2013 | Toyota Tacoma Cars & Trucks

1 Answer

98 jimmy four point three vortex will not fire until you let off the key. Acts like its out of time but has brand new timing chains and gears. The ignition mod tests good.


Even though your ignition mod tests good, you should try a different one. The tests do not always show a fault. What is happening is, your ignition is not getting enough power to fire in cranking mode. The usual reason for this is a faulty module.

Mar 18, 2011 | 1998 GMC Jimmy

1 Answer

Jerks and shakes from time its cranked. can drive it but still jerks, doesnt want to take in gas when speeding up, some back firing when giving it gas. engine light flashes red until letting off the gas...


Sounds like a fuel injector is clogged up or is not firing due to the computer not firing it. Check by putting a noid light on each injector and checking for pulse by viewing a blinking light from it. Also, one can check to see if a stethoscope can be used to listen for a clicking from the injector indicating it's at least pulsing that way.

Dec 18, 2010 | 1998 Toyota 4Runner

1 Answer

RPM's are fluctuating while driving. Turns over, but wont fire when cold. Have to hold accelerator pedal down to start when cold.


Sounds like you either need to reolace the crank sensor or the camshaft speed sensor,depending on which your engine comes with.If you tach doesn't get a signal then neither does the engine controller and it is like you are not even trying to start the car although you are in fact turning the key and cranking the engine.

Mar 24, 2010 | Eagle Vision Cars & Trucks

1 Answer

93 ford wagon xl engine cranks but will not start


if it was activated the button will be pushed out you will have to push it back in to get it to start again. if that don't work then it could be alot of different stuff after you check the fuel shutoff switch check to make sure you hear the fuel pump kick on. if you don't hear it kick on then check your fuses. if you hear it kick on then check and make sure your getting fire to the plugs and if your getting fire to the plugs then it might have jumped time and if your not getting fire then check the ignition control module and your ignition coil. it might even be the crank sensor or cam sensor.

Aug 23, 2009 | 1993 Ford Escort 4 Door

Not finding what you are looking for?
2000 Saturn SL Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8841 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...