Question about 1996 Plymouth Voyager

1 Answer

Guages, speedometer, not working , appears to be an electrical problem - will start working then quits again.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Plymouth Master
  • 6,674 Answers

You may want to have a look at one of my earlier replies. This is a common problem with those van's. Here's a cut and paste from that reply.

Don't know how handy you may be but would seriously consider removing instrument cluster, and checking solder on circuit board. Just did mine, wasn't hard, maybe a couple of hours work. Nice small, pointed solder gun will be needed as well. They have had many weird problems with gauges, starting, running etc, all narrowed down to that printed circuit board, where the solder on the contact pins become corroded or cracked and cause some pretty weird stuff. At the very least, try removing dash enough to remove 4 screws holding cluster in, and pulling off connectors and putting them back on a couple of times, just in case it's just a dirty connection. If you decide you want to try it, and need more specific instructions, let me know, or even google , Dodge or Plymouth instrument cluster soldering, as there is some pictures and videos out there on the subject. Good Luck, and let me know how you make out.

Posted on Jul 20, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I was drive the car running and shifting goog, then the speedometer went dead and transmission started sliping bad. Then the speedometer started working and it quit slipping for about a quarter mile t


Your speed sensor is giving out I believe. The transmission is fine, I'm very sure of it. So in short: It's electrical!

FYI: When the speed sensor signal is not reaching the computer, it doesn't know if/when to shift gears, or what gear to even be in. That's my basic summary of why this happens. There could be more to it than I know considering it's a newer car... but I think I'm right about it being a speed sensor.

Oct 06, 2014 | 2007 Ford Edge SEL

1 Answer

Speedometer quit tachometer quit temperature guage quit oil light came on 2005 nissan altima 3.5l


in the fuse panel there are 4 blue relays the bottom one is your problem swap it with another and i bet it will start working again

Aug 05, 2010 | 1996 Nissan Altima

1 Answer

Speedometer, gas guage, tack all quit working.


Sounds like you have blown a fuse check your fuse box and replace any fuses you find. Hope that helps

Oct 05, 2009 | 1999 GMC Sierra

1 Answer

Dash guages quit working. Gas, temp, tach and


Try disconnecting battery for couple minutes and see if it starts working again I have done that in the past

Aug 05, 2009 | 2000 Chrysler Town & Country

1 Answer

Speedometer and gas guage quit working at same time


Both of them are run on electricity, so check if any fuses gone and check if you are getting any voltage at the meter or somewhere along it must have shorted.....sodeep

Jun 15, 2009 | 1999 Plymouth Neon

1 Answer

Instrument panel guages don't read accuratly


I have a chevy cav 03 and my problem is just in the gas guage and temp guage now i cant seem to figure out how to fix it but for a quick fix i have jut been pulling out the instrument panel fuse and putting it back in it seems to fix t

Feb 26, 2009 | 2000 Chevrolet Cavalier

4 Answers

2004 Chevy Trailblazer Speedometer


replace the ip cluster will fix speedometer

Sep 29, 2008 | 2004 Chevrolet TrailBlazer

1 Answer

Electrical?


These sound electrical for sure. Almost sounds as if the computer is somehow getting a positive surge. Possibly a shorting wire somewhere.

I'd definitely take a look under the hood and see if there's any burn marks or corrosion (green/white powders) on the wiring. This could be a sign of a serious problem to come. Either way, if it's effecting that much, it's definitely shorting something.

daffodilnan, you could possibly check the fuse for the guage cluster, and the ECU. They could be loose and just vibrating on/off causing loss of guages. This should be located in the fuse box on the dash near the drivers door.

Sep 07, 2008 | 1998 Dodge Caravan

Not finding what you are looking for?
1996 Plymouth Voyager Logo

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

Marvin
Marvin

Level 3 Expert

83772 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22413 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8841 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...