Question about 2003 Ford Windstar

1 Answer

Battery light on.new battery put in.light still on

My battery light was on.van would not start after we turned it off.put a new battery in,van starts but light still. on runs fine

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Teacher:

    An expert who has written 2 tips or uploaded 1 video tip.

  • Expert
  • 123 Answers

The battery light indicates an "battery charging problem" something is with the alternator it could be the alternator belt or the alternator itself
good luck

Posted on Jul 19, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have no ign lights,engine turns over but wont start


Have you checked the battery terminals? sounds like they are dirty/corroded causing no power to starter.

Dec 16, 2015 | Cars & Trucks

1 Answer

01 chevy express van security light flashing and van won't start. Van sat for a while battery was completely dead charged it and put a new battery in it and now it won't start. Just cranks over


Do a reset. Ten minutes on, 30 seconds off. Try to start. If it doesn't, do a relearn. Which is 3 times the reset , don't try to start until the third time. Have a charger handy, don't let the battery get low.

Dec 21, 2014 | Cars & Trucks

2 Answers

Battery light and abs light come on,van wont start


Sounds like the GEM is bad. This is a computer module behind the radio that controls all those things.

Feb 10, 2014 | 1997 Chrysler Town & Country

1 Answer

Van wont start .checked alternator. fuses and brand new battery still wont start. van started acting u when fuse to rad fan went out. engine light came on but since we live in cold area never heated up....


I think you're over your head here. Take it to a professional mechanic and let her sort it out. Sounds like your alternator isn't putting out the correct voltage.

Apr 06, 2017 | 2000 Dodge Grand Caravan

2 Answers

Problems starting my van. new battery but one quiet click and it all goes dead


When the van was parked, was it in an area where mice or other rodents could get to it? If so, check for chewed wires near top of engine compartment and under van near starter.

Apr 09, 2017 | Toyota HiAce Cars & Trucks

2 Answers

Mercedes vito 110cdi starter motor problems. only when the van


Hi as it starts with a jump start, i would rule out a starter motor problem, i am taking it that what you mean by a jump start is your using a donor battery rather than pushing the van, so possible causes are (1) battery discharging due to a light left on, or the alarm system draining the battery or something similar, (2) alternator not charging the Battery, when you turn the ignition key does the ignition light come on, does it go off when the engine starts?

Mar 14, 2010 | 2004 Mercedes-Benz C32 AMG

1 Answer

Van wont start


Just maybe the battery and alt were good. You did test them,before replacing didn't you? How about the starter solenoid,starter or ground connections or cables with too much resistance. Do a voltage drop test, on all grounds, you can get to.

Feb 19, 2010 | 2003 Ford Windstar

1 Answer

Silhouette will not start, but battery put out 12+ volts


You better have the alterntor checked, you said the battery was putting out 12v. was that with the car running or off? If it was running, it should have pushing between 14 and 15 volts, if it wasn't with it running, replace alternator.

Jan 30, 2009 | 2000 Oldsmobile Silhouette

1 Answer

1999 chevy venture


hello , that is not fare to buy a new van because a small problem like that , i will try to help you , if the motor didn't make any noise when you try to start it , so you can check on the starter ( marsh ) , if it is ok so you can check on your denamo , but first be sure that the battery is good , and thank you for asking fixya.

Jun 26, 2008 | 1999 Chevrolet Venture

Not finding what you are looking for?
2003 Ford Windstar Logo

Related Topics:

387 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

fordexpert

Level 3 Expert

5610 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...