Question about 2006 Chevrolet Blazer

2 Answers

All gages work except gas gage. what's wrong?

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 17,970 Answers

Check the sending unit wires.

Posted on Jul 14, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It's probably the sending unit in the tank or the wires going to it.

Posted on Jul 14, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2000 Chevy s15 Rpm and Gas Gauge is not working


I didn't see an s15 in that model year, in my database?
If the speedometer works but the tach doesn't, I think something is wrong with instrument cluster?
GM has had a problem with fuel gage sending units. The sending units are not hard wired to instrument cluster, they send signal to pcm, the pcm sends serial data to instrument cluster, telling the cluster the gage settings.
It may be possible to use different size resistors in place of the fuel level sending unit, to see if fuel gage reacts properly to different resistors, if the gage reacts properly, then I think the problem is the fuel gage sending unit.

Nov 02, 2016 | Chevrolet Cars & Trucks

1 Answer

Gas gage does not work


Could be the gage or the sender unit. Have someone take the wire off the sender unit at the fuel tank and touch it to ground If the gage goes to full tank the replace the sender unit. Could also be a broken wire from the gage to sender

May 31, 2015 | Cars & Trucks

1 Answer

2001 Olds Silhouette: plenty of gas in the tank but the gage will read full, 3/4 full, 1/2 full, and everywhere in between. Van runs fine. No other issues except the gage goes crazy and can't depend on...


2000 Olds Silhouette: plenty of gas in the tank but the gage will read full, 3/4 full, 1/2 full, and everywhere in between. Van runs fine. No other issues except the gage goes crazy and can't depend on what it says. ...

Aug 12, 2010 | 2000 Oldsmobile Silhouette

1 Answer

Dash above steering wheel is out.


Did you happen to hook you stereo ground to the wire that lit the lights on you factory stereo from the dash light controls? I think its a brown wire

Mar 30, 2010 | 1995 Chevrolet Caprice Classic

1 Answer

2008 x5 v8 my gas gage and on board computer wrong readings


Faulty Fuel Pump, and run an injection cleaner into your gas tank (you can buy a bottle at your local parts shop) then get the fuel filters checked or replaced.

Chances are contaminated gas clogged your fuel works.

For a quick fix: Open the gas cap at 1/4 tank to relieve the vacuum. it will make your pump work less.

Nov 06, 2009 | 2008 BMW 550i Sedan

1 Answer

Truck runs but instrument panel gages are lit but gages dont work


check battery and alternator connections if good have battery and alternator tested some auto stores such as auto zone / advanced auto can bench test them for free

Oct 27, 2009 | 2004 Chevrolet TrailBlazer

1 Answer

ELECTRICAL PROBLEM


The prob seems like you have connected the power to your stero from the wrong place. You cut into live a wire for the power, this should be connected at the ACC on your fuse panel. Also make sure you stero has a good ground! Frankster016

Oct 23, 2008 | 1989 Ford F 150

1 Answer

Fuel level sensor in tank bad????


Yes it is all one unit, and yes that is what the problem is. don't use aftermarket parts, use OEM, (Delco Remy) they are much better quality.

Sep 08, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
2006 Chevrolet Blazer Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...