Question about 2000 Ford Expedition

1 Answer

Missing while excelerating, idle is fine. Check engine light just came on

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Idel is fine but give gas it skips

Posted on Jul 17, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine has hesitation/miss without a check engine light coming on upon acceleration


there are many things that could cause that from bad gas to weak fuel pump or dirty inline filter or timing chain could be weak or dirty intake or bad catalitic converter or no converter or even a vaccum line off or cracked or even a bad EGR valve so you see theres alot of things that cause poor exceleration or idle. Hope this was some what helpfull.

Jan 23, 2013 | 2004 Chevrolet TrailBlazer

1 Answer

Car idles fine but starts missing when given gas poping and sputtering


This could be caused by many different things. Do some research before you throw more parts at the problem. Try to extract the diagnostic code first. An engine needs 3 things to run: spark, fuel, and air. Your problem could arise from any of the 3 sources. Things to check include intake vacuum, ignition timing, fuel pressure to start. More information is needed to diagnose the symptoms you describe.

Jul 04, 2017 | 1990 Cadillac Deville

1 Answer

98 626 2.0 run idles but lungges and won't excelerate will idle. changed ecu not that


Check the air intake boot between the air cleaner and engine. It is a black rubber, accordian looking tube. Check the accordion tube area and down in the grooves for any tears that would allow unfiltered and unmetered air into the engine. Tube can look fine just sitting there but when trying to accelerate the engine torque will allow engine to move and open up the tear causing a lunging or surging feel on acceleration but not at idle.

May 25, 2011 | 1998 Mazda 626

2 Answers

My engine occasionally misses and a rough idle


My 1993 caprice had the same issue.
Would it happen to down shift out of overdrive on the slitest incline.
if so, one of your plugs is missing under load. Mine turned out to be a wire.

Feb 06, 2010 | 1991 GMC Sonoma

1 Answer

My test light flashes code 22 1 22 on my 89 2.3 ranger. Truck idles fine but when excelerated it brakes up real bad


Hi:
You most likely are tripping a MAP sensor out of range code 22, and should check it out, especially the vacuum line going to it, and any other vacuum line under the hood,

Here is a list of codes for you

http://www.extreme-check-engine-light-codes.com/Ford%20OBD1%20Decoder.htm

Nov 06, 2009 | 1992 Ford Ranger

1 Answer

2001 ford focus.engine cuts off when you excelerate runs fine at idle


Is your check engine light on? get a diagnostic done. could be a vacuum sensor

Feb 28, 2009 | 1988 Suzuki Samurai

Not finding what you are looking for?
2000 Ford Expedition Logo

Related Topics:

112 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...