Question about 2001 Saturn SC

2 Answers

Car is putting at an idle when gas is pressed runs smoothly

Replaced the plugs, wires and fuel filter. car went 3 miles then it started to miss, service engine soon light came on. hooked an auto x-ray diagnostics machine to it and it spit out code p0343 cam shaft position sensor malfunction, misfire in cylinder 1. Could not find anything about the cam shaft postion sensor in haynes manul. Replaced knock sensor that seemed to fix the problem. since then the car has been driven 80 to 120 miles. pulling in to a parking spot it made putting noise and trying to cut out service engine soon light came on. got it home it is still acting up but the light only comes on when it wants to. please help me try to fix this nightmare of a car any input will be helpfull. the car is a 2001 saturn sc1 with 118,000 miles on it. regular maintenance has been very well kept.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Try cleaning the trottlebody intake and EGR valve. Recheck wire connectors on the sensor you replaced. A great site for Saturn SC1 owners is You Tube. Search for "Richpin". Type "Saturn, Richpin" and you will find a bunch of videos on how to find and repair SC1 problems. He's great.

Posted on Jul 16, 2010

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 200 Answers

Sounds like either you have 2 of the wires crossed.........one is loose....probably #1 or your #1 plug needs regapped or is not tight and losing seal....all will cause a misfire and set the check engine light

Posted on Jul 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Just replaced MAF sensor with full tune up, but now idles rough..


replace the IAC, idle air control valve at throttle body. replace fuel fiter, put drygas in tank, todays fuel w/ethenol is bad news for older vehicles.

Jan 03, 2013 | 2000 Toyota Tacoma PreRunner

1 Answer

97 ford taurus: Cylinder 2 misfire


well..fuel injection systems are more than the electronic part. I suspect you are dealing with compression or injector fouling issues..

Oct 21, 2008 | 1997 Ford Taurus

2 Answers

When I turn the key sometimes it wont start but when i try it a second time it does


A couple of ideas-- you may have already considered. Is this an older car? If so, then some old cars get moisture in them on the electrical parts like say on the wiring harness or wiring. Another cause could be the battery is a bit weak. Go to Advance Auto or Autozone and get the battery tested. Then they getting the started tested. I hope this helps you! God bless!

Jun 18, 2010 | 1991 Buick Park Avenue

1 Answer

Rough starts and ''service engine soon'' light for 1992 chevy k2500


TO SAVE YOU TIME AND MONEY.HAVE TRUCK SCANNED TO SEE WHAT CAUSES SERVICE LIGHT TO COME ON.YOU CAN GO TO AUTO ZONE THEY WILL SCAN IT FOR FREE.BUT IT SOUND LIKE YOUR O2 SENSORS COULD BE BAD.

Apr 18, 2010 | 1992 Chevrolet C/K 2500

1 Answer

#1 Misses, Engine Light goeos On then Off.


i am wondering is if there is a leak in your pump assembly, in the tank, and as soon as the fuel level gets below that hole, it starts to **** air, or lose pressure.

May 01, 2009 | 1997 Oldsmobile Regency

3 Answers

Misses during acceleration , rough acceleration, service engine soon light on, power loss, still runs fair, 2000 ford expedition


Go get the codes ran at auto zone or advance auto parts they will do it for free. If the codes come up as a cylinder miss-fire then it is most likely a coil (being a ford). Write down which cylinder it is. I wouldn't replace any of the spark plugs , useless you have more than 100,000 miles. If you have to replace the spark plugs use BOSH double plautim or better. The cylinder placing is ( as your are looking at the front of the truck) passenger side front to back 1-2-3-4 driving side front to back 5-6-7-8. If you never seen a coil buy one so you know what you are looking for. The coil is held in by a 7mm bolt. Take the bolt out and replace the coil. Problem Solved. Estimated time 20 Mins with 60 dollars per coil.

Mar 10, 2009 | 2000 Ford Expedition

2 Answers

2002 Tahoe Dropping Cylinder


A tune up will not cure the lean code, in fact an engine miss gives a rich code from the unburned fuel. I would suggest u verify u have no vacuum leaks, also clean the inside of the MAF sensor if so equipped and replaced the bank two O2 sensor, that is the passenger side sensor before the catalytic converter. If u have the money replace both right and left sensors, it is better to do them in pairs.

Jan 15, 2009 | 2002 Chevrolet Tahoe

1 Answer

Fuel injectors or Distributor Cap?


the blinking CEL light is an indication of a miss-fire, run the code retrival test to find out what cylinder is the one missing, at your miles it could be almost anything from a low compression issue to a bad distributor cap, a fuel injector could be the problem, run the test and get back to me, Kragen and other chain parts stores will test the system for codes for FREE!

Nov 06, 2008 | 1999 Chrysler Sebring

1 Answer

1999 S10 Pickup miss fire


Your throttle position sensor should be located on the throttle body opposite of where the throttle cable hooks on too. Look for a small black box on the other side with wires leading into a connector. get your codes read and re post them it could be a simple fix.

Oct 22, 2008 | 1999 Chevrolet S-10 Pickup

4 Answers

2001 oldsmobile alero


I have a car in the shop right now same thing - it is being caused by a misfire. Need a real technition to diagnose the problem (auto zone - advance auto can't diagnose the problem - only read the code)
mine was caused by a failing fuel injector. good luck

Jun 26, 2008 | 2001 Oldsmobile Alero

Not finding what you are looking for?
2001 Saturn SC Logo

315 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8567 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...