Question about 1985 Chevrolet S-10

1 Answer

Speedcable stop working !985 S10 Blazer

Speedcable stop working, all it does is goes all the way around! the milliage reads ok, just don't know how fast I'm going. When I bought the truck, the seller said the cable was just replace but not hook up. So, I hook it up and I think there something wrong with the speed unit itself? maybe they tried tampering with it? Don't know?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 524 Answers

Hi

as you said there may be problem with the spedometer itself. but please check the cable once again.replace it with new cable and it works it was the cable problem. but if doesnt work thn the problem lies with the speedometer itself. you can service it or replace with new one.

if my answer was useful please vote me

Posted on Jul 12, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I need free vacuum line diagrams for a 94 s10 blazer 4x4


https://www.google.co.uk/search?q=vacuum+line+diagrams+for+a+94+s10+blazer&es_sm=119&tbm=isch&tbo=u&source=univ&sa=X&ei=RoJmVMLgN8fzasiagcgP&ved=0CCIQsAQ&biw=1920&bih=985#tbm=isch&q=vacuum+line+diagrams+for+a+94+s10+blazer+4x4&imgdii=_

Aug 29, 2014 | 1994 Chevrolet S-10 Blazer

1 Answer

1999 s10 truck


you may have broken a wire going to fuel sending unit under the truck along frame drivers side speed sensor on back of trans. may be broken , unpluged, or wire broken

Aug 11, 2013 | Cars & Trucks

2 Answers

NEED TO KNOW WHAT TYPES OF TRANSMISSION WILL FIT IN MY S10 4X4 BLAZER


Well if you can find one from like a 4x4 s10 around the same year it will fit

Mar 18, 2013 | 1995 Chevrolet Blazer

2 Answers

2.8l v6 in a s10 blazer. no head gasket problems thus far. wondering why my oil pressure gauge fluxuates? minor rpm change while oil pres guage does its thing why?


Oil pressure always changes with rpm.
At idle you should have around 10 psi, and it should max out at high rpm around 50 psi or so.
You not only can't have as much pressure at idle, but you don't need it either.

Jun 06, 2011 | 1989 Chevrolet S-10 Blazer

2 Answers

1994 s10 blazer no spark


Sounds like the ignition module. Do you know if it is tbi or cpi?

Mar 28, 2010 | 1994 Chevrolet S-10 Blazer

3 Answers

1991 Chevy S10 Blazer 4.3 4x4


4170636.jpgThis is all I've got.Hope this helps?

Dec 20, 2009 | 1991 Chevrolet S-10 Blazer

1 Answer

Where do i plug in at to check codes on 85 s10 blazer?


under drivers dash let me know what you find ok

May 26, 2009 | 1985 Chevrolet S-10 Blazer

Not finding what you are looking for?
Cars & Trucks Logo

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...