Question about 2000 Dodge Dakota Quad Cab

2 Answers

2001 Dodge Dakota Quad 4.7 L with No BuS on the odometer. And the gas gauge and the rest of the clusters gauges will not work. The lights at the bottom of the cluster will work but thats it. I changed the ignition switch and it started and ran fine for a day. Then the next day I went to start it and drove into town and it quit again. But before that you could wiggle the key in the on off position and eventually gauges would come on. But now it won't even do that. Since it will not run, I have changed the crankshaft sensor. I have unplugged the camshaft sensor to see if the No Bus would go off, but it didn't. I've checked all the ground wires they are clean and tight. I checked the TPS. I've checked all the pcm connectors and made sure they are clean and tight. I have checked ALL fuses and relays they are all hot and have good connection. I have ran each ignition wire to where they go and they are all hot where they meet the connectors. When I bought the truck the gas gauge didn't work. So the place I got it put 3 clusters in it before we got one that would work. I pulled the dash apart after the truck quit and it looks like the cluster was in a truck that had no windsheild and it got rained on. Please help... I have been a mechanic all my life and this has stumped me. I have done little more than work on it for the last 4 days. BTW what is the black box on the driver side floor board behind the side panel, closest to the door. I unplugged the connectors & it had white corroasion. But I cleaned it up and put it back together. It made no difference but I was wondering what it was. And at one time I discovered when it quit the last time that someone had a remote start on it and had cut it out and left all wires dangeling where they spliced onto things... just to let you know... but all wires were good when I went through them. Any help would be greatly appricated.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem on my 2001 Dodge Dakota. Then I noticed in addition to not having cluster backlighting, my parking lamps did not come on when I set the alarm or opened the doors. I replaced the 15 a fuse in the fuse panel for parking lamps. EDverything works.

Posted on Aug 14, 2012

Ad
  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Champion:

    An expert who has answered 200 questions.

  • Contributor
  • 245 Answers

Need a new bcm (body control moguel) Located under the dash by the brake pedel on the firewall

Posted on Jul 12, 2010

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

  • 381 Answers

SOURCE: will not start or ideal without given throttle,

If you are still getting the TPS code after replacing it I would start tracing back wires that are related to that sensor. Check for broken or shorted wires or bad fusible links that have corroded. I tend to find a lot of these kinda problems in the harness under the battery or in the wheel well. Can be very hard to find. Good luck

Posted on Oct 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What relay goes to the cluster in a 2004 dodge durango


Sorry no relay , bad instrument cluster . The gauges get there info from the PCM - engine computer over the SPI serial data bus ! Google SPI or Chrysler CCD data bus !

Sep 17, 2016 | 2004 Dodge Durango

1 Answer

My instrument panel lights up but nothing on it works. Speedometer, tach, gas gauge, nothing. All the message lights are on. In the odometer/tripmeter window in says: no bus. Truck runs just fine.


There may be a problem with the connection or the wiring harness between the instrument cluster and the body computer.
No Bus means no signal or power on the line between the two computers.

Jan 03, 2016 | 2011 Dodge Ram Pickup 1500

1 Answer

2002 dakota wont start


hav e ign. switch checked a lot of these problems come from these switches on all cars and trucks after they are a few years old, simple but usually fixes.

May 13, 2012 | 2000 Dodge Dakota Quad Cab

1 Answer

2001 grand caravan no gas gauge heat gauge no odometer rpm lights


check for an instrument cluster fuse in the fuse panel if it's good you will have to pull the cluster out and change the lights behind the gauges

Oct 19, 2009 | 2001 Dodge Grand Caravan

2 Answers

2001 ram 15oo, speed,tach,oil press,batt,fuel gauges all stopped working at once. message on odometer says--no buS . no noticeable difference in engine performance.


i am having the some problem with my 2001 dodge ram 1500 all of my gauges stop working after the engine light came on now on myodometer says no bus, Can you help me with it

Jul 17, 2009 | 2001 Dodge Ram 1500 Truck 2WD

1 Answer

Odometer reads no bus


check bulkhead connecter for corrosion, cluster is your body controll module, losing signal to fuel pump module , and pcm, thios is a communication issue, volt meter wil help, back probe diagnostic connecter, pin 7, white wire, to see if signal is there, GOOD LUCK RDJRP

Jul 16, 2009 | 1999 Dodge Ram

2 Answers

No Bus Error


All the modules are connected together to communicate with each other via the PCI bus. It is possible that one of the modules is pulling the bus down.Since the vehicle won't start it could be any one of the modules. It will be a process of elimination to find the faulty one by disconnecting them one at a time. Here are a few, powertrain control module (the one you replaced) Instrument cluster, overhead console, anti-lock brakes, airbag. Since the cluster unplugged wont read anymore, just try to start the vehicle to see if that was the one. Otherwise see if the odometer message of "no bus" goes away after each one is unplugged.

Apr 23, 2009 | 1999 Dodge Durango

1 Answer

Cluster lighting went out on 2005 dodge grand caravan


It is most likely a bulb.one bad bulb can really darken a cluster quite a bit.

Nov 26, 2008 | 2005 Dodge Caravan

Not finding what you are looking for?
2000 Dodge Dakota Quad Cab Logo

974 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...