Question about 1991 Chevrolet Suburban

2 Answers

Speedometer quit, will start again and run for some length of time and then quit again, how to fix it.

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 71 Answers

Replace speed sensor on the transmission.

Posted on Jul 11, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Check your cable it might be snapping then if thats not the case your gear might be bad that would be in your gear transmission goto http://www.buzzle.com/articles/speedometer-not-working-properly.html for more info

Posted on Jul 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whats wrong with Helen?


The speed sensor might be bad. I used to own a 99 Mitsubishi Eclipse with the same symptons. The car will start, but will not pass the 1st or 2nd gear, the speedometer will be at 0. I replaced the speed sensor and all the problems went away.

Apr 29, 2014 | 1995 Honda Civic

1 Answer

Check engine lights are on


"U" codes indicate a network communications problem
could be in the wiring and harness connections between the sensor and the ECM or CPU program
2107 concerns the throttle actuator control (TAC) module --processor fault ===causes --TAC control module
check wiring and all connections

Jun 04, 2017 | 2002 Saturn VUE

1 Answer

Stalls when I stop and start again. Speedometer


your speed sensor is gone.. you have an electronic odometer so when the electricity passes improperly.. you get what you got!!

Feb 26, 2010 | 1998 Jeep Cherokee

3 Answers

The speedometer quit working and the transmission quit shifting at the same time.


It sounds like the Vehicle Velocity Sensor (V V S) has gone bad or the wire harness has gotten damaged due to corrosion. The V V S sends signals to the ECM which will indicate to the transmission when to up and down shift according to the engine speed and will send signals to the speedometer. The sensor is on the driver's side along the tail shaft if the transmission, good luck and keep me posted. Auto Zone will have the sensor and give you the step by step instructions and should take no more then 15 min to replace, it's held on by one bolt and the wire harness just unclips.

Nov 02, 2009 | 1994 Chevrolet S-10 Blazer

3 Answers

SPeedometer not working.


U need to replace the vehicle speed sensor on the transmission, it has failed this will fix all the problems. see photo of sensor.
3f2d8c7.jpg

Apr 15, 2009 | 1995 Nissan Pickup

1 Answer

89 chev truck 1500 4X4. Speedometer only works sometimes.


Sounds like a loose connection on insterment cluster. or a dead spot on printed circute, either way dash will have to come apart to fix.

Feb 12, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Speedometer problems


It could be a short in the cable itself. You can buy a new cable but you will most likely have to buy from the dealer. It's important that you get the right cable length. It could also be that your cable has come partially disconnected with the differential in which case all you would have to do is tighten it.

Dec 02, 2008 | 1993 Toyota Pickup

Not finding what you are looking for?
1991 Chevrolet Suburban Logo

294 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...