Question about 1999 Ford Ranger SuperCab

1 Answer

Runs good to start off but after about 10 miles or so the oil pressure gauge bottoms out and iwhen you come to a stop it will cut off and hard to crank

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

You most likely have a pluggeed oil pickup tub which is on the other side of your oil pan.

Posted on Jul 09, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Recently had oil changed. Soon after, oil light started coming on w. alarm sound. We check oil and it's always full. Stops if I shift to neutral, resumes dinging when I shift back into drive.


I would suggest you have the oil pressure checked with a manual gauge. It sounds to me like you might have a restriction at the sump tube and your engine has low oil pressure.

Jan 22, 2016 | 1999 Chrysler Town & Country

1 Answer

In the last 6 months I have had 7 oil pressure switches fail, with oil coming through the switch into the wire harness. Any suggestions?


Those readings were from the gauge on the dash? Have you ever had a mechanical gauge on it? That is good pressure at 155K. Usually those pressures at new car pressures. 10 miles.

Aug 02, 2015 | Cars & Trucks

4 Answers

My 07 tahoe has no oil pressure ive drove it 10 mile to get homeit still runs good but still not showing any oil pressure


Hello, if your engine did not have oil pressure , I doubt you could drive it ten miles. I think you should check your oil pressure with an auxiliary pressure gauge. More than likely you might only need a new oil sending unit.

Mar 15, 2015 | 2007 Chevrolet Tahoe

2 Answers

Why won't my car start?


Sounds like your oil pump may have seized.You'll need a gauge to verify this. The engine has a mechanism by which it automatically cut the engine off if there's a sudden drop in pressure. I would replace the pump. If you do make sure you prime it prior to tightening the oil pan down. A big question is why you were that low on oil. Good luck!

May 27, 2014 | 2003 Toyota Sequoia

1 Answer

Oil pump ford explorer


No that is not the pump that you smell. You need to have a test gauge hooked up to verify that you have good oil pressure, if it is ok then replace the sending unit for the oil pressure gauge.

Mar 20, 2014 | Ford Explorer Sport Cars & Trucks

1 Answer

1999 JIMMY OIL PRESSURE drops with RPMs after warm


Normal is 10w30.
If the oil pressure gauge is correct, my guess would be worn engine bearings and / or oil pump.

Jul 14, 2012 | GMC Jimmy Cars & Trucks

1 Answer

2004 Doge Ram 2500 5.7 Hemi 190K mile had oil pressure gauge drop to ZERO and check gauges light come on and engine shut down.. Check oil 1 guart low, add oil. let cool. crank up, good gauges drove home 45...


If the valve lifters are quiet you most likely have oil pressure even with gauge showing "0".Sounds like the oil pressure switch going bad.I would try that first.

Apr 28, 2017 | 2004 Dodge Ram 2500

2 Answers

Possible oil pump problem


You need to determine if the engine has lost oil pressure (assuming the oil level is good) You need to place a mechanical gauge where the oil sending unit is that goes to your gauge. If this gauge reads low, you have an oil pump problem. Keep in mind that gauges and sending units can go bad. But the loosing power doesn't sound good. Start here to determine what is up.

Aug 20, 2009 | 1995 Chevrolet Camaro

2 Answers

1995 astro oil pressure low on gauge


GM oil pressure senders have a pretty high failure rate. Since your van is over 10 years old, and pressure senders are not too expensive. 
I would start by replacing your sender...there's a pretty high likelihood that you will eventually replace it anyway. Change the oil and filter every 3000 miles and use a 10W30 with a Lucas oil treatment and with a can of Restor would not hurt ether.
Getting to expensive to buy and replace a good running van over some light routine mantance for around $20.00 every 3000 to 5000 miles.
Good luck and hope this helps.

May 03, 2009 | 1995 Chevrolet Astro

Not finding what you are looking for?
1999 Ford Ranger SuperCab Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5481 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...