Question about 1996 Chevrolet Camaro

1 Answer

Fans not coming on overheating changed water pump, temp sensor fans work when hot wired

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

FROM PERSONAL EXPERIENCE:
1996 CAMARO Z28 5.7L ENGINE TROUBLES

  • Performance Symptoms:
    Overheats- Runs Rough- Runs Very Rough- Induction Backfires- Stalls Out-
  • Operational Symptoms:
    Won't start- Check Engine Light Turns On-
  • Diagnostic Error Codes:
    Various Cylinder Misfires- Overheat Condition- Oxygen Sensor Failure (Totally legit but, not related to other issues.) and a few others I forgot about.

    Overtime; I ended up replacing everything I thought could have been even remotely related to the problems, including the Engine Control Modual/computer. SOS!
The symptoms continue in an intermittent fashion. Sometimes it was happy for months with only a nerve racking sputter or two while at idle or even cruising at 70 mph. Then suddenly it just stops running. Crank, crank, crank but, not a plug fired or was it that not an injector injected. In any case the thing lay dead for half an hour before it just came to life again. It was fine for weeks after that.

Three things I came to notice about this whole miserable affair were:

  1. It all started “the day after” I did some maintenance under the hood. The work included replacing “one of the two” temperature sensors on the motor ( 'cause it had a broken connector latch..) while I changed out a leaking water pump (...which would drip on the serpentine belt and stall the power steering pump, YIKES!) and an R & R of the radiator to repair a small hole in the right side plastic tank.
  2. It would get normal and proper (as far as I could tell...) if I floored it!!! I discovered it would even start up, when it otherwise wouldn't, if I just held the throttle fully open..
  3. My scanner would report an Overheat Condition “well before” it was indicated on the temperature gauge.
  4. Some of the symptoms were most likely going to show up on cool and humid or moggy rainy days.

OK... Cutting to the chase now--- The problem turned out to be a poor and erratic connection between the Engine Coolant Temperature sensor (The one mounted in the front of the water pump...) and its connecter. A serious cleaning and "tightening" of the contacts inside that connecter was “The Fix!!!!”

Me Z' has been up & running like a bat outta' hell for over 3 years since I cleaned up and tightened those connector puppies... I mean it hasn't missed a single beat!

I think the poor and electrically chattering on and off of the connection was doing an input signaling number on the poor computer such that it didn't know how to respond. Under those conditions, whatever it did decide to do in response like, turn off the cooling fans, turn off fuel injection, go full rich injection, adjust ignition timing, were “Just Wrong!”

That's my story and I'm stickin' to it! I hope this helps you and some others who have been experiencing this sort of thing.
RAy

Posted on Jul 12, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

05 Durango 5.7 Hemi overheating. We replaced the water pump it was leaking. While we were doing that we changed the thermostat, flushed the radiator, replaced the belt and the coolant temp sensor.


You need to verify you have power going to the fans or run the Durango and see if the fan are coming on, you may have a bad wire or relay to the fans.

Apr 18, 2017 | 2005 Dodge Durango

2 Answers

Radiator fans not coming on. replaced thermostat and cooling sensor


Hi Bill, is the engine actually getting hot enough for the fans to come on? if the engine does have overheating problem (but you say the temp gauge reads normal) then i would check the operation of the engine temp switch, there are two, one for the gauge and one for the fans.

Oct 15, 2016 | 2006 Ford Escape

1 Answer

2005 lumina overheating without air conditioning


Sounds like your radiator fans are not coming on when the car gets hot. When the A/C is on the fans cycle on/off with the A/C pump so it keeps the fans on. Your engine temp sensor or fan sensor might be bad. Check the connections on the sensors and fans for water/corrosion too.

Mar 31, 2014 | 2005 Chevrolet Lumina SS

1 Answer

My 98 ford f150 overheats constantly. I have changed the thermostat, fan, fan clutch, gave it a flush and still overheating. A mechanic checked it and said the water pump is good cause water is...


does the heater work good, like real HOT when the truck is HOT? if not, flush the heater core with a water hose, both directions. Now when the truck is HOT open the hood and feel the air coming thorough the radiator, it should be HOT. if its not, the radiator may be plugged. If the mechanic has a Temp Gun, have him check the radiator temp, it should be uniformly HOT if you find cold spots (like if the radiator is 200f and there are places that are 150f) the radiator is plugged and "flushing" will do nothing.

Aug 30, 2011 | Ford F-150 Cars & Trucks

1 Answer

My 2005 pontiac grand prix was overheating and was leaking water out of the jug so I put a thermastat in it . And it still was overheating so I flushed the radiator and it was still overheating,then I...


Most likely it is a combination problem involving the water pump. The temp sensor being slow to respond being the problem would be easily identified. If the vehicle is over heating when you are moving and 30 to 40 mph it is not a sensor or Fan. It could possibly still be the fan if the fan clutches are not working and allowing it to free spin as air moves faster through the Radiator but this is less likely than a bad water pump.

Sep 15, 2010 | Pontiac Grand Prix Cars & Trucks

1 Answer

My 2000 Saturn SL2 is overheating. At first it would overheat when sitting idle and then once speed reached 35+mph it would cool off, but now it gets hot and stays. What is causing this?


Well, the overheating at an idle would normally be caused by your cooling fan not engaging. I would first check to see if you fan is working by turning on your a/c (this will override the fan sensor and turn it on before it gets above operating temperature). If it doesn't come on you should check your AUX. Fan Relay. If thats ok, you probably need a new fan motor but first replace your coolant temp. sensor as this is an inexpensive parts and may save you quite a bit of money (also your vehicle may be running at the normal temperature but your temp sensor may be sending a signal telling you it's hot). This will explain why it was overheating at an idle. As far as it overheating while driving, you should first check to see if your water pump is leaking and make sure your belt is intact. If the water pump pulley is not spinning your belt will be glossy from excessive heat from friction. If your water pump is good and you can spin the pulley by hand, you should then consider when the last time you replaced the thermostat as it may be stuck closed. also your radiator may have some blockages in it so I would replace the thermostat, drain the coolant by removing the lower hose and spray a hose into the radiator until the water comes out looking pretty clear. I hope this helps you figure this out.

Aug 16, 2010 | 2000 Saturn SL

1 Answer

Son has a 1997 contour with 2.0l overheated


hard to get to and difficult job...are you sure you dont have cracked head? is there water in the oil....does the oil look milky? look in the radiator is there oil residue in the coolant........

Nov 08, 2009 | 1997 Ford Contour

2 Answers

My car has overheating out of ordinary found that water pump was leaking replaced it, drove 2 blocks car said overheated again. Replaced thermostat and it still said was overheating. Even after I let car...


Sounds like you need a temp sensor for the gage. There's 2 under the hood one is a 2 wire in the intake manifold driver's side & a single wire one under the exhaust crossover pipe,also driver's side. You want to change the single wire one. Yes,it's tough. If it's still overheating quick, then it's a head gasket.

Jun 21, 2009 | 1994 Oldsmobile Cutlass Supreme

1 Answer

1990cad deville overheating


the first thing to check is to have the engine running. as soon as it reaches operating temp the upper radiator hose should get hot. if it doesn't then it's the thermostat. if it does then i believe your water pump is probably not circulating like it should and it should be replaced. however before replacing the wter pump make sure that the wire to sending unit is tight and not giving you a false reading. if your model has electric fans make sure the fans are running when the engine is hot. if they are not running check the relay in the fuse box for the fans with the engine running switch out the fan relay with the a/c clutch relay. ifthe fans kick on replay the relay with a new one. if they don't click on the it's either a bad wire or the temp sensor probe is bad. hope this answers your question. please rate this solution...thanks.

Aug 30, 2008 | 1990 Cadillac SeVille

7 Answers

Overheating problem


water pump. water pump. water pump. i am a vw dealer tech and on 2.0 and 1.8t beetles the water pump impeller is plastic, and what happens is usually another component, fans, fan control module (under battery tray), thermostat, fails and because the impeller is plastic with just one overheat the plastic becomes brittle and shatters, pull the water pump out and you will see the impeller in 3 or 4 pieces. replace water pump and make sure t stat opens, fans come on (a/c off) and proper water pump flow.

Jul 29, 2008 | 2000 Volkswagen Beetle

Not finding what you are looking for?
1996 Chevrolet Camaro Logo

450 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...