Question about 2000 Nissan Xterra

1 Answer

So i just put a new sound system in my 2000 nissan xterra and everything went good untill later today my speedomoter lights wouldent turn on... i dont know what to do i checked the fuse box but i cant seem to find a fuse thats broken what do i do???

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 524 Answers

Hi..
this is because the connection for the system might hav not properly insulated.
1.check weather the speedo meter wire and sound system wire are both touching.
2. if that is the case try insulating it properly.
3. and check the fuse also there may be some blown out due to short circuiting.

Posted on Jul 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2000 Nissan xterra 4x4 v6 and it recently started stumbling on acceleration. I changed the plugs an wires to see I that helped and it drove fine after that then started stumbling on Acceleration...


Sounds like it might be fuel related,,, get some GOOD injector cleaner,, mix generously..run it through two tanks worth.. then change the spark plugs...(the crude it removes gathers on the plugs sometimes!)

Jun 06, 2017 | 2000 Nissan Xterra

2 Answers

2000 Nissan XTerra Electrical Probs


Hi:
With your battery installed, turn on your head lights and see if they light up. If so, you most likely have a bad ignition switch.(not the key lock, but the actual switch )
It isn't a terribly expensive part, but will cause weird stuff if it fails.

Nov 19, 2009 | 2000 Nissan Xterra

1 Answer

000 NISSAN Xterra -- after warming up, loses RPM by 500-1000..... have replaced ignition wires and distributor, checked mass air flow sensor and OK.....


I had a problem on my Nissan Xterra 2000. Symptons sound similar. In my case, it ran fine for a while and then suddenly the engine starts to stumble and lose output. At one point it did not even have enough HP to move. Irregular idling too. Thought it was water in my fuel. Bought water remover from the store and added to gas tank. Problem did not go away. Instead, "Service Engine Soon" light came on. Had to have it towed to the dealer as there was no way the engine could keep up with traffic. Dealer replaced the "Crank Position Sensor" today. Parts $33.00, Labor: $300 (about 3 hrs worth of work). Seems to work fine now but I will wait and see. Dealer also stated that Distributor bearing appears to be noisy and will need to be replaced sooner or later. I will wait for it to go before I fix that.

May 22, 2009 | 2000 Nissan Xterra

1 Answer

My 2000 nissan xterra just quit it turns over but that is it


sounds more like one of your cam position sensors has failed

May 13, 2009 | 2000 Nissan Xterra

2 Answers

My 2000 nissan xterra just quit it turns over but that is it


The fuel pump died out .
Replace the fuel pump , sometime they give no warning .

Good Luck

Apr 18, 2009 | 2001 Nissan Xterra

2 Answers

SUV WONT START


check you battery and battery cables...sounds like a big voltage drop

Feb 22, 2009 | 2002 Nissan Xterra

2 Answers

2000 Nissan Xterra has power but then dies


I suggest you begin by charging and testing the battery, your description indicates it is discharged.

Why it is discharged remains to be seen - you need to check the alternator drive belt and the alternator charging.

Sep 28, 2017 | 2000 Nissan Xterra

Not finding what you are looking for?
2000 Nissan Xterra Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...