Question about 1996 Mercury Grand Marquis

1 Answer

Replaced ground cable, now car skip under load, could the wrong cable be installed?

Posted by on

  • A Miller Jul 09, 2010

    are you talking about the cable that goes from NEG on the battery to the engine block? If this is the case ... this cable is only a heavy wire that provides a connection for the common ground of the vehicle. You may have knocked another wire loose that effects your engine operation ... but the ground didnt do it.

  • cfa3saa Jul 09, 2010

    thanks.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 8,404 Answers

Welcome

Posted on Jul 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2005 Lincon ls v6 is skipping and loses power when trying to go up an incline. What is wrong with it?


Could be a fuel system problem - starving for fuel under load. I would check the system (fuel pump, filter, etc.).

Jul 17, 2017 | Cars & Trucks

1 Answer

GROUND CABLE CLAMP BROKE AND IS BADLY CORRIDED


its just taped into the harness you should be able to run a new one along side the harness

Jul 11, 2012 | 1999 Jeep Grand Cherokee

1 Answer

My 06 jeep liberty giving me alternator problems. The alternator light keeps coming on and voltage is droping when I put it under a full load such as turning on my radio,lights,wipers,andradio at the same...


Sounds like a bad battery ground. Check your cables and make sure you replace any that are corroded. bend the cables and if they are stiff and brittle, they need replacement.

Jun 28, 2011 | Jeep Liberty Cars & Trucks

1 Answer

Toyota camry V6 1993 Car has been running fine until just now. In drive position it is missing real bad with no back fire. It seems ok at this point in nutral & park. In the midst of floods &...


if the car is missing only when it is under a load my first guess would be the coil, i would hate to point you in the wrong direction since cash is short for everyone right now, you didnt mention the last time you changed the sparkplugs and wires but it seems if it was one of these the skip would be continuous, although i have seen a bad wire cause a skip under load,it really could be a number of things but this is the best place to start

Jan 14, 2011 | Toyota Camry Cars & Trucks

2 Answers

How do I find the spark plugs and plug wires so I can replace all on my 02 Ford Crown Vic (I have a skip under load)


I THINK I UNDERSTAND THE SKIP UNDER LOAD,LOL,BUT THIS CAR DOES NOT HAVE WIRES,IT HAS BOOTS,UNDER THE COIL PACKS,AND I HATE TO TELL YOU THIS,BUT,IF IT IS A 4.6 LITER,THEN,FUEL RAIL HAS TO BE LIFTED,GOOD LUCK

Apr 05, 2010 | 2002 Ford Crown Victoria

1 Answer

2002 Ford Windstar p0300 skips and backfires under load


Just put a coil on a 2002 today. Coils fail a lot with no codes given

Mar 09, 2010 | 2002 Ford Windstar Cargo

1 Answer

Engine skips


That sounds like a dirty EGR valve...I had the same problem. Change the EGR valve and your problems shall be gone.

Jan 12, 2010 | 1995 Cadillac DeVille

1 Answer

Sound system skips out when the bass hits or the trble gets too high at a certain degree of volume and the dash sometimes cuts out or doesn't come on, i have to hit the dash in the right spot with the...


There is a loose/damaged/corroded ground connection -- sounds like it's under the dash.


But, I would check the battery cables and the chasis ground strap as well. The chasis ground strap is usually near the bottom of the engine compartment -- it's a braided cable running rom the engine block to the chasis.


Charlie

Aug 16, 2009 | 1998 Dodge Caravan

1 Answer

I sprayed water under hood now car jerks


The 4.6 lit motors have individual coil packs. usually, they are not very suceptable to water but... If the check engen light comes on (amber light on the dash) It's probly just skipping. Get some one to put the car in drive and hold the brake. Under load the skip will be worse. Unplug each coil one by one. As they are unpluged,the motor will shake worse. when you unplug one and the skip dosn't get worse, you have found the bad cylender. Odds are it's a coil pack but replace the plug too.

May 12, 2009 | 2001 Mercury Grand Marquis

Not finding what you are looking for?
1996 Mercury Grand Marquis Logo

Related Topics:

32 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

fordexpert

Level 3 Expert

5537 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...