Question about Cars & Trucks

1 Answer

I have 2006 mitsubishi eclipse 76000miles. When i first start up my car and start to drive it make a grinding sound only when i start it up. Also my brakes do not catch till more then half way down and my pads are new. Ihad the master cylinder and brake booster replaced and the brakes were fine. After a month its doing it again and the dealer says its normal as well as the grinding noise that has not happened the 4 yrs i have had it

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 6,826 Answers

I would adjust the rear brakes if you have drums back there. That will raise your pedal. If you have disc brakes in rhe back, then they self adjust better than rear drum brakes.

Grinding noises are never good, as it indicates there is metal to metal contact somewhere.

Without listening to it, I would have trouble determining exactly what that was.'

good luck to you.

Posted on Jul 09, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How many oxygen sensors02 does a 2006 Mitsubishi eclipse have?


There are a total of 4 oxygen sensors on a 2006 eclipse. This applies to either of the avaliable engines, the 2.4L engine and the 3.8L engine.

Dec 21, 2016 | 2006 Mitsubishi Eclipse

1 Answer

Transmission make loud sound when put it in revers


PLEASE HELP! SOS! car starts but doesnt move! - Club3G Forum ...

www.club3g.com > ... > Performance & Tech Forums > Problem Reports

Nov 16, 2010 - 61 posts - ‎14 authors
now yes, i will take the transmission is fubar into consideration but theres an .....however... idk about my cv joint, my car ONLY would make a loud ping noise when i move from a stop or brake ..... almost always when i put it into reverse. such as an engine mount sound, ... Vehicle: 2004 Eclipse Spyder GT. Loud knocking sound after oil change..
14 posts
Sep 20, 2010
Horrible noise upon start when cold
21 posts
Dec 24, 2009
Sporty knocking.. Oh noez!!one!!1!
16 posts
Mar 22, 2006
More results from www.club3g.com

Loud thump when I shift into drive or reverse - CarGurus

www.cargurus.com > Questions > Chevrolet > Cavalier

CarGurusDec 19, 2012 - And while driving loud thump when car motor shifts th... ... Bad throttle position sensor can trip both lights and make the transmission shift at high rpms and shift hard even under light acceleration. .... the transmission will shift hard when firstput into reverse or drive ... 2004 Chevrolet Cavalier LS For Sale.Missing: mitsubishi ‎eclipse

Mitsubishi Transmissions & Drivetrains Repair Questions ...


Dec 06, 2015 | 2004 Mitsubishi Eclipse

1 Answer

I have a 2006 eclipse. It shut down while driving, put fuel in it.And it will not start.


try resetting fuel pump kill switch , something have bumped into a accident sensor . did it sputter to a stop or just stop running ? if it sputtered try to prime pump by turning car on for a few seconds a couple of times then try to start . the kill switch is behind one of the side panels in front of the doors . good luck

Sep 21, 2012 | 2006 Mitsubishi Eclipse

1 Answer

2000 mitzubishi eclipse, clunked out and now will not start


Possible the fly wheel has no teeth left. That would be the humming sound.

Apr 11, 2010 | 2000 Mitsubishi Eclipse

1 Answer

Does a 2006 mitsubishi eclipse have a fuse for tho


no.....only the head unit is fused which would mean no sound at all if the fuse was blown

Nov 09, 2009 | 2006 Mitsubishi Eclipse

1 Answer

Grinding coming from Rear Wheel Driver side when I drive ...


its the brakesd you should change the pads from the back and for safety the ones int he front.good luck

Sep 17, 2009 | 2001 Mitsubishi Eclipse

1 Answer

My mitsubishi eclipse stereo has a button for 'folder'. Was just wondering what that meant. Bought the car used and it has no manual.


It is used for MP3 discs, where the files ar organized in folders (like on your computers hard drive)

Sep 17, 2009 | 2006 Mitsubishi Eclipse

1 Answer

2006 Mitsubishi Eclipse won't start. Came home from work parked the car no problems at all. Few hours later went out to leave and it won't start. Just out of the blue. I was able to jump start it. No...


Battery is dead... get a volt meter, jump the car and with the car running on its own power check the voltage, anything less than 12v could point to an alternator but a new battery is a better place to start. put it to you this way if the car shuts off while driving, then its your alt, and if its fine wen drivin but wont start back up... its all battery

Aug 19, 2009 | 2006 Mitsubishi Eclipse

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...