Question about Cadillac DTS

1 Answer

I have a 2001 cadillac dts with the codes po171 and po174 changed MAF, intake gasket, plugs and boots car still running rough can any body help

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,272 Answers

The error codes P0171 and P0 174 on cadillac dts are related to fault in Bank one and two O2 sensor, Map, Maf, TPS, All the injectors, and fuel pressure regulator. The problem can be due to any of this part faulty.So check and recheck all this parts still you have replaced it.But If you have replaced this parts and rechecked them and confirmed it that its working properly but still you have this error codes then it's saying the mix is running lean on both sides. You may have a vacuum leak again. Start looking at the intake gasket you replaced and listen for any hissing. PCV valve and hose OK? Plastic intake cracked? Brake booster line connected? Stuff like that. IMPORTANT
An improperly installed air cleaner or a distorted/missing intake air duct may cause this DTC to set. Ensure air cleaner assembly/IA duct is installed correctly and that there are no kinks, folds or damage to the IA duct or possible debris in the air cleaner assembly or the MAF sensor inlet screen (air flow straightener) that may distort the air flow.
Step 6
Visually/physically inspect the following items.
Vacuum hoses for splits, kinks and proper connections.
TB,
intake manifold and EGR valve for vacuum leaks.
PCV valve and/or system for leaks including a loose or missing oil fill cap or dipstick.
Contaminated fuel.
PCM and sensor grounds are clean, tight and in proper locations.
Air induction system after MAF sensor for vacuum leaks. Engine mechanical failure.

If the problem was not found in the above areas then

Visually/physically inspect the following items.
Exhaust leaks, missing or loose exhaust hardware.
HO2S are installed correctly and electrical connector not contacting exhaust system or ignition wires.
Injector "O" rings.



In between the intake and the throttle body crossover there is a 6 inch x 1 inch rubber coupler hose. These can develop a crack in the rubber and leak causing the problem you describe. The intake has to come off to replace this hose.
Also check for the vacuum leak on my STS, in, between T/B backer plate and intake manifold.
Thanks. Keep updated for any more query. You can rate this solution and show your appreciation.




Posted on Jul 08, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I HAVE CODES PO171 AND PO174 04 CADILLAC SRX 4.6L


please go to : repairpal.com/obd-II-code-po171-and-PO174 FOR MORE INFO, good-day!

Apr 17, 2014 | 2004 Cadillac SRX

1 Answer

My cadillac escalade runs rough in idle.


PO174 &171- Both banks lean. This could be caused by a defective MAF or O2 sensor but something as simple as a vacuum leak could cause this problem. Also make sure there are no air leaks from the MAF sensor to the intake manifold. I have repaired many vehicles with these codes that was caused by a vacuum leak. Hope this helps

Nov 27, 2013 | Cadillac Escalade Cars & Trucks

1 Answer

I have a 2000 Cadillac Deville with 180k miles. I've been getting P0171 and a P0174 code. Yet there is no vacuum leaks. I replaced the MAF and still its idles rough once it heats up. Any suggestions?


Have you not Googled the Codes PO171 & PO174
to learn the problem ?

I would suspect you never changed the front O2 Sensors
at 100,000 miles & they both have now failed

The MAF shouldn't have been the issue

You may also have converters that are worn out
with a 14 year old vehicle

Are you changing Spark Plugs every 3 years ?

A rich fuel issue will drive the O2 lean also
Need to look at Fuel Trim on scan tool & other data

Aug 22, 2013 | Cadillac DeVille Cars & Trucks

1 Answer

2002 Cadillac Escalade code po102,po171,po174 comes up runs rough at start up then get better but still rough.


Anytime I see P0171 and P0174 together the first thing I look for is vacuum leaks. Specifically the upper intake plenum gaskets. The codes indicate that both banks of the engine are running lean. The rough run at start up and then gets better supports this.

With the engine running rough carefully spray carb spray around the area where the intake bolts to the heads. If the idle changes and or smooths out you found the leak. Be careful when doing this as carb spray is flammable.

I wouldn't worry about the P0102 (MAF code) until you figure out if there is a vacuum leak or not. If there is no vacuum leak than I would investigate that code further.

Dec 28, 2010 | 2004 Cadillac Escalade Ext

1 Answer

Lean bank 1&2,have replaced intake gaskets and throttle body seal,new fuel pump,still sets po171,po174 codes-help


Did you Erase the diagnostic trouble codes after the repairs were made? If not then they will keep coming back on screen as stored trouble codes untill they are removed from the computers Memory.If you did Erase the codes then you need to disconnect the possitive battery terminal this will reset the computer. Good Luck.

Dec 11, 2010 | 2004 Cadillac Deville

3 Answers

2001 ford focus had the spark plugs and wire change. Has a code po171.. ran good for two days. The spark plugs are blacker than acs of spades which is running rich. Don't know what to do next. To me its...


PO171-System to Lean (Bank 1)

Air filter cover tight?
All intake ducting tight?
Clean MAF Sensor.--CRC MAF Cleaner
Fuel Pressure Regulator?
EVAP Purge Valve-stuck open?
Vacuum leaks?
EGR System-issues?

Seems your getting a lean O2 Code,because it is trying to correct for a rich condition,as you said.

Is the Throttle Position Sensor-original?

Work on what is driving it rich,my list is a possible.

May 19, 2010 | 2001 Ford Focus

1 Answer

I have a 2003 gmc yukon 5.3 the engine idles rough sometimes the idle will get so low the engine will shut off.(the engine runs good while driving) hooked to scaner po101 maf/vaf (dont know what vaf is),...


you have a vacume leak somewhere.check all of your vacume hoses for leaks.Injector seals can cause this too.Also intake gaskets could be leaking.Running to lean usually means the car is getting to much air coming in.To check leaks spray brake cleaner around the hoses and the bottom of your intake if the rpms change then you found a leak.

Feb 21, 2010 | 2003 GMC Yukon XL

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

199 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...